none
Move of large mailbox failing

    Question

  • Hi

    Moving all mailboxes from one store to a new one to reduce the problem of lost white space due to archive stubbing.

    All mailboxes moved with no issues apart from one. It is a large mailbox (17GB) with lots of folders (17,500).

    When the move starts it sits at 10% for many hours and the last log entry is:

    "Initializing folder hierarchy in mailbox 'Primary {....} 17700 folders total"

    Up to 10-11 hours later the log then states "Folder hierarchy initialized for mailbox 'Primary {...}"

    Some time later (0.5 - 1 hr) there is an entry from one of the other CAS servers:

    "The Microsoft Exchange Replication service is examining the request"

    And then "Restarting the move because checkpoint data doesn't exist or isn't valid in 'Primary {...}"

    Eventually the move starts constantly retrying with:

    "Couldn't switch the mailbox into Sync Source mode.

    This could be because of the following reasons:

    Another administrator is currently moving the mailbox.

    The mailbox is locked.

    The Microsoft Exchange Replication service (MRS) doesn't have the correct permissions"

    Eventually after many retries the job fails.

    It looks to me like the other CAS server takes over the move for some reason but the mailbox shows as being locked due to the initial move request.

    I can't see anything obvious in the event logs on the CAS or mailbox servers at the time the CAS servers switch so not sure what's going on.  There are no corrupt items showing in the log.

    I've now retried 3 times with the same results., both with choosing "Resume move request" and also removing the request, waiting a few hours and starting again.

    Anyone seen this problem before or can advise ?

    Thanks

    John

    • Edited by jarweb Wednesday, January 16, 2013 9:57 AM
    Wednesday, January 16, 2013 9:36 AM

All replies

  • You might want to disable the mailbox and connect it again. Start the Move again and post the result.

    Gulab Prasad,
    gulab@exchangeranger.com
    My Blog | Z-Hire Employee Provisioning App

    Wednesday, January 16, 2013 11:09 AM
  • Hello,

    Please wait for the mailbox to be released before attempting to move this mailbox again. Because MRS may continue to encounter this error for up to 2 hours - this duration is controlled by the TCP KeepAlive settings on the Mailbox server.


    Cara Chen
    TechNet Community Support

    Thursday, January 17, 2013 6:44 AM
    Moderator
  • Hi

    The problem isn't that the move doesn't start. The issue is that, during the move, it looks like something causes the move to restart and a different CAS server tries to take over the move. But it can't because it looks like the original move hasn't been released.

    I'll try the suggestion of disabling and re-enabling the mailbox or, worst-case I will export to PST but I'd rather not if I could avoid it.

    Thanks

    Thursday, January 17, 2013 9:06 AM
  • Hi,
    I had the same problem not long ago and for me it was solved by temporarily increasing the KeepAliveTime setting to 6 hours.

    I used the script found here to do that.

    Martina Miskovic

    Thursday, January 17, 2013 11:51 AM
  • Great - thanks for that.  Do you know if the server(s) requires a reboot or if there is any outage while the setting is changed ?

    I'm trying the move again (started at a different time of day to see if this helps) but will look into changing this setting if (or, more likely, when) it fails again.

    Thanks

    Thursday, January 17, 2013 12:05 PM
  • I didn't reboot my two Multi-Role Servers.
    All I did was change the setting and restart MSExchangeMailSubmission and then waited many hours for the mailbox move to complete.

    UPDATE: There was no outage when making the change.


    Martina Miskovic


    Thursday, January 17, 2013 12:18 PM
  • Hi

    Was it only the KeepAlive registry entry you added (via the script) ?  I see from Microsoft articles there are other timeout settings available - e.g. KeepAliveInterval

    Thanks

    John

    Thursday, January 17, 2013 4:12 PM
  • Yes, that was the entry I added.
    I could have added in manually in regedit, but I really liked that script.

    Martina Miskovic

    Thursday, January 17, 2013 4:23 PM
  • Hi Martina

    When your mailbox moves were complete, did you delete the registry key for KeepAliveTime or just change it to 7200000 (default) or another value ? 

    Just want to check if deleting the key puts the setting back to its default or the key needs to stay once it has been added, since it isn't there by default.

    Thanks

    John

    Friday, January 18, 2013 9:00 AM