none
Exchange Autodiscover Error

    Question

  • Hi all :
       I haved met a problem it's about autodiscover Error :  When contacting https://mail.macaulkf.com/EWS/Exchange.asmx received the error The request failed with HTTP status 401: Unauthorized. 

       Anyone Can tell me what's the error ,I just try to do something as below :
    1.enable the anonymous access at the EWS of ISS 6 ,
    2.My SSC already include mail.macaulkf.com ,autodiscover.macaulkf.com

    By the way , Our CAS is NLB and Our Mailbox server is SCC.

    There is the output of Test-OutlookWebServices as below :

    Id      : 1003
    Type    : Information
    Message : About to test AutoDiscover with the e-mail address test@hotelking
              sway.com.mo.

    Id      : 1007
    Type    : Information
    Message : Testing server lkfitprocas03.macaulkf.com with the published name htt
              ps://mail.macaulkf.com/EWS/Exchange.asmx & https://mail.macaulkf.com/
              EWS/Exchange.asmx.

    Id      : 1019
    Type    : Information
    Message : Found a valid AutoDiscover service connection point. The AutoDiscover
               URL on this object is https://lkfitprocas03.macaulkf.com/Autodiscove
              r/Autodiscover.xml.

    Id      : 1006
    Type    : Information
    Message : The Autodiscover service was contacted at https://lkfitprocas03.macau
              lkf.com/Autodiscover/Autodiscover.xml.

    Id      : 1013
    Type    : Error
    Message : When contacting https://mail.macaulkf.com/EWS/Exchange.asmx received
              the error The request failed with HTTP status 401: Unauthorized.

    Id      : 1016
    Type    : Error
    Message : [EXCH]-Error when contacting the AS service at https://mail.macaulkf.
              com/EWS/Exchange.asmx. The elapsed time was 0 milliseconds.

    Id      : 1015
    Type    : Information
    Message : [EXCH]-The OAB is not configured for this user.

    Id      : 1014
    Type    : Success
    Message : [EXCH]-Successfully contacted the UM service at https://lkfitprocas03
              .macaulkf.com/UnifiedMessaging/Service.asmx. The elapsed time was 109
               milliseconds.

    Id      : 1013
    Type    : Error
    Message : When contacting https://mail.macaulkf.com/EWS/Exchange.asmx received
              the error The request failed with HTTP status 401: Unauthorized.

    Id      : 1016
    Type    : Error
    Message : [EXPR]-Error when contacting the AS service at https://mail.macaulkf.
              com/EWS/Exchange.asmx. The elapsed time was 0 milliseconds.

    Id      : 1015
    Type    : Information
    Message : [EXPR]-The OAB is not configured for this user.

    Id      : 1014
    Type    : Information
    Message : [EXPR]-The UM is not configured for this user.

    Id      : 1017
    Type    : Success
    Message : [EXPR]-Successfully contacted the RPC/HTTP service at https://mail.ma
              caulkf.com/Rpc. The elapsed time was 0 milliseconds.

    Id      : 1006
    Type    : Success
    Message : The Autodiscover service was tested successfully.

    Id      : 1021
    Type    : Information
    Message : The following web services generated errors.
                  As in EXCH
                  As in EXPR
              Please use the prior output to diagnose and correct the errors.


    Anyone can tell me what's going on at my Exchange envirnment, thx a lot .



    sam
    Monday, February 16, 2009 9:15 AM

Answers

  • HI all :
      
        I fixed it after disable the loopback check at my Exchange CAS server and the result as below :

    Id      : 1003

    Type    : Information

    Message : About to test AutoDiscover with the e-mail address test@hotelking

              sway.com.mo.

     

    Id      : 1007

    Type    : Information

    Message : Testing server lkfitprocas04.macaulkf.com with the published name htt

              ps://lkfitprocas04.macaulkf.com/EWS/Exchange.asmx & https://mail.maca

              ulkf.com/EWS/Exchange.asmx.

     

    Id      : 1019

    Type    : Information

    Message : Found a valid AutoDiscover service connection point. The AutoDiscover

               URL on this object is https://lkfitprocas04.macaulkf.com/Autodiscove

              r/Autodiscover.xml.

     

    Id      : 1006

    Type    : Information

    Message : The Autodiscover service was contacted at https://lkfitprocas04.macau

              lkf.com/Autodiscover/Autodiscover.xml.

     

    Id      : 1016

    Type    : Success

    Message : [EXCH]-Successfully contacted the AS service at https://lkfitprocas04

              .macaulkf.com/EWS/Exchange.asmx. The elapsed time was 593 millisecond

              s.

     

    Id      : 1015

    Type    : Information

    Message : [EXCH]-The OAB is not configured for this user.

     

    Id      : 1014

    Type    : Success

    Message : [EXCH]-Successfully contacted the UM service at https://lkfitprocas04

              .macaulkf.com/UnifiedMessaging/Service.asmx. The elapsed time was 0 m

              illiseconds.

     

    Id      : 1016

    Type    : Success

    Message : [EXPR]-Successfully contacted the AS service at https://mail.macaulkf

              .com/EWS/Exchange.asmx. The elapsed time was 93 milliseconds.

     

    Id      : 1015

    Type    : Information

    Message : [EXPR]-The OAB is not configured for this user.

     

    Id      : 1014

    Type    : Information

    Message : [EXPR]-The UM is not configured for this user.

     

    Id      : 1017

    Type    : Success

    Message : [EXPR]-Successfully contacted the RPC/HTTP service at https://mail.ma

              caulkf.com/Rpc. The elapsed time was 15 milliseconds.

     

    Id      : 1006

    Type    : Success

    Message : The Autodiscover service was tested successfully.


    sam
    • Marked as answer by samuelwai Tuesday, February 17, 2009 12:22 PM
    Tuesday, February 17, 2009 12:22 PM

All replies

  •  




    Hi,

    I do not know why you changed the authentication to “anonymous access”. Base on some article, Exchange Web Service has BasicAuthentication and WindowsAuthentication. The default settings is Windows Integrated Authentication.

    So I recommend you change the authentication to Windows Integrated.

    Default settings for Exchange-related virtual directories in Exchange Server 2007

    http://msexchangeteam.com/archive/2008/02/01/447989.aspx

    Set-WebServicesVirtualDirectory

    http://technet.microsoft.com/en-us/library/aa997233.aspx

    Regards,

    Xiu

     

    Tuesday, February 17, 2009 8:19 AM
  • HI all :
      
        I fixed it after disable the loopback check at my Exchange CAS server and the result as below :

    Id      : 1003

    Type    : Information

    Message : About to test AutoDiscover with the e-mail address test@hotelking

              sway.com.mo.

     

    Id      : 1007

    Type    : Information

    Message : Testing server lkfitprocas04.macaulkf.com with the published name htt

              ps://lkfitprocas04.macaulkf.com/EWS/Exchange.asmx & https://mail.maca

              ulkf.com/EWS/Exchange.asmx.

     

    Id      : 1019

    Type    : Information

    Message : Found a valid AutoDiscover service connection point. The AutoDiscover

               URL on this object is https://lkfitprocas04.macaulkf.com/Autodiscove

              r/Autodiscover.xml.

     

    Id      : 1006

    Type    : Information

    Message : The Autodiscover service was contacted at https://lkfitprocas04.macau

              lkf.com/Autodiscover/Autodiscover.xml.

     

    Id      : 1016

    Type    : Success

    Message : [EXCH]-Successfully contacted the AS service at https://lkfitprocas04

              .macaulkf.com/EWS/Exchange.asmx. The elapsed time was 593 millisecond

              s.

     

    Id      : 1015

    Type    : Information

    Message : [EXCH]-The OAB is not configured for this user.

     

    Id      : 1014

    Type    : Success

    Message : [EXCH]-Successfully contacted the UM service at https://lkfitprocas04

              .macaulkf.com/UnifiedMessaging/Service.asmx. The elapsed time was 0 m

              illiseconds.

     

    Id      : 1016

    Type    : Success

    Message : [EXPR]-Successfully contacted the AS service at https://mail.macaulkf

              .com/EWS/Exchange.asmx. The elapsed time was 93 milliseconds.

     

    Id      : 1015

    Type    : Information

    Message : [EXPR]-The OAB is not configured for this user.

     

    Id      : 1014

    Type    : Information

    Message : [EXPR]-The UM is not configured for this user.

     

    Id      : 1017

    Type    : Success

    Message : [EXPR]-Successfully contacted the RPC/HTTP service at https://mail.ma

              caulkf.com/Rpc. The elapsed time was 15 milliseconds.

     

    Id      : 1006

    Type    : Success

    Message : The Autodiscover service was tested successfully.


    sam
    • Marked as answer by samuelwai Tuesday, February 17, 2009 12:22 PM
    Tuesday, February 17, 2009 12:22 PM
  • Thanks for your feed back. :)
    Wednesday, February 18, 2009 8:12 AM
  • Hi friends

    According to me there is problem with your IP Address. Check the IP address
    otherwise concern with the Administrator.

    Joseph

    Thursday, February 19, 2009 10:15 AM