none
The remote server returned an error: (405) Method Not Allowed.

Answers

  • This was eventually resolved with a call to Microsoft Tech Support:

     

    We removed the Autodiscover virtual directory with the command:

    Remove-AutodiscoverVirtualDirectory -Identity "mynode\Autodiscover (Default Web Site)"

     

    Then created a new instance with the command:

    New-AutodiscoverVirtualDirectory

     

    After that I started getting a 404 error on all the Autodiscover web pages. This was resolved by going into IIS Manager and changing the status of "ASP.NET v2.0.50727" from Prohibited to Allowed. After that everything seemed to work fine. The Test-OutlookWebServices command returned no errors and the Autodiscovery test from an Outlook 2007 client returned success for this test as well.

     

    Monday, August 13, 2007 1:42 PM

All replies

  • You may want to try reseting the URL for you AutoDiscover site.  You can do so with the following cmdlet:

     

    Set-ClientAccessServer –Identity “your CAS server name” –AutoDiscoverServiceInternalUri https://mail.domain.com/autodiscover/autodiscover.xml

    Wednesday, August 08, 2007 10:12 PM
  • Lee,

     

    Thanks for the post but even after I got the mail.domain... alias set up and working (MX record just points to the system by name) I still get the same error.

     

    Grayson

     

    Thursday, August 09, 2007 1:35 PM
  • This was eventually resolved with a call to Microsoft Tech Support:

     

    We removed the Autodiscover virtual directory with the command:

    Remove-AutodiscoverVirtualDirectory -Identity "mynode\Autodiscover (Default Web Site)"

     

    Then created a new instance with the command:

    New-AutodiscoverVirtualDirectory

     

    After that I started getting a 404 error on all the Autodiscover web pages. This was resolved by going into IIS Manager and changing the status of "ASP.NET v2.0.50727" from Prohibited to Allowed. After that everything seemed to work fine. The Test-OutlookWebServices command returned no errors and the Autodiscovery test from an Outlook 2007 client returned success for this test as well.

     

    Monday, August 13, 2007 1:42 PM
  • Just thought I would add a word of caution on to this message in regards to deleting and recreating your Autodiscover virtual directory.

     

    One customer's Exchange 2007 server had all 3 roles installed on it with a single certificate for a single name. I have had no problems in the past following the steps in the following KB for other customers:

    http://support.microsoft.com/?kbid=940726

     

    For the one customer, this worked everything worked except for Autodiscover so subsequently Outlook 2007's Out Of Office wouldn't work. I spent over 1/2 a day troubleshooting why the customer's Outlook clients wouldn't talk to the Autodiscover service (I used the test option in Outlook which went no where) and had exhausted everything before I attempted the Remover-AutodiscoverVirtualDirectory and then the subsequent New-AutodiscoverVirtualDirectory.

     

    The result of this is we are now in a worse situaiton than before. Before when I would try to get to http://FQDN/Autodiscover/, it would authenticate me and then show me the Autodiscover place holder text.

    Now I get caught in a authentication loop that never stops, and the application log records the following error error for every new attempt (which goes no where):

    Event Type: Warning
    Event Source: ASP.NET 2.0.50727.0
    Event Category: Web Event
    Event ID: 1310
    Date:  4/15/2008
    Time:  5:28:56 PM
    User:  N/A
    Computer: CLIENTSERVER

    Description:
    Event code: 3008
    Event message: A configuration error has occurred.
    Event time: 4/15/2008 5:28:56 PM
    Event time (UTC): 4/15/2008 9:28:56 PM
    Event ID: 7599f66bc8d948b3a87bc9bd9dfcc7a6
    Event sequence: 2
    Event occurrence: 1
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/1/Root/Autodiscover-1-128527685359713250
        Trust level: Full
        Application Virtual Path: /Autodiscover
        Application Path: C:\Program Files\Microsoft\Exchange Server\ClientAccess\Autodiscover\
        Machine name: CLIENTSERVER 
     
    Process information:
        Process ID: 6548
        Process name: w3wp.exe
        Account name: NT AUTHORITY\SYSTEM
     
    Exception information:
        Exception type: ConfigurationErrorsException
        Exception message: Could not load file or assembly 'Microsoft.Exchange.Clients.Owa' or one of its dependencies. The system cannot find the file specified. (C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\web.config line 64) (C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\web.config line 64)
     
    Request information:
        Request URL: https://FQDN/Autodiscover/Autodiscover.xml
        Request path: /Autodiscover/Autodiscover.xml
        User host address: 172.27.11.3
        User: 
        Is authenticated: False
        Authentication Type: 
        Thread account name: NT AUTHORITY\SYSTEM
     
    Thread information:
        Thread ID: 1
        Thread account name: NT AUTHORITY\SYSTEM
        Is impersonating: False
        Stack trace:    at System.Web.Configuration.HttpModuleAction.get_Entry()
       at System.Web.Configuration.HttpModulesSection.CreateModules()
       at System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers)
       at System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context)
       at System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context)
       at System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)

    I have tried re-registering the .NET Framework 2.0 on the box with no luck. I have tried deleting and recreating the virtual directory a second time with no change. I have verified that the Autodiscover virtual directory settings "look" right to me.

    The test-Outlookwebservices cmdlet finds the autodiscover server, but gets "(500) Internal Server Error" when it trys to talk to it.

     

    So now I am pretty sure I am stuck with having to reinstall the CAS role which *hopefully* will resolve the issue.

    Not that I wouldn't have tried the remove and re-add, but had I known it would put the server in a worse situation I would have thought twice.

     

    So be forewarned.

    Tuesday, April 15, 2008 9:50 PM
  • Hello all,

    We finally solve this problem by :

    - Repairing .Net
    - Remove-AutodiscoverVirtualDirectory
    - Restarting  IIS
    - New-AutodiscoverVirtualDirectory

    I hope it will help.

    Laurent

     
    • Proposed as answer by SudhirBidye Friday, December 02, 2011 1:56 AM
    Friday, February 20, 2009 2:16 PM
  • I know I'm reviving an old thread, but I used the same solution to help resolve my broken Out of Office Assistant and Offline Address Book.

    I was working on Exchange 2007 Standard Edition, running on a Windows Server 2003 R2 SP2 x64 server.

    In the Exchange Management Shell, I removed the Autodiscover virtual directory with the command:

    Remove-AutodiscoverVirtualDirectory -Identity "Autodiscover (Default Web Site)"

     Then created a new instance with the command:

    New-AutodiscoverVirtualDirectory

    AFter that, I recycled all the MSExchange IIS application pools, just to be on the safe side.  I ran

    Test-OutlookWebServices

    and it passed, and I was able to run the Test E-mail Autoconfiguration app in Outlook 2007 and get a success.  Plus, the error (0x8004010F) in my Outlook went away.  Hope it helps somebody else out there.

    Tuesday, December 28, 2010 4:29 PM
  • This was eventually resolved with a call to Microsoft Tech Support:

     

    We removed the Autodiscover virtual directory with the command:

    Remove-AutodiscoverVirtualDirectory -Identity "mynode\Autodiscover (Default Web Site)"

     

    Then created a new instance with the command:

    New-AutodiscoverVirtualDirectory

     

    After that I started getting a 404 error on all the Autodiscover web pages. This was resolved by going into IIS Manager and changing the status of "ASP.NET v2.0.50727" from Prohibited to Allowed. After that everything seemed to work fine. The Test-OutlookWebServices command returned no errors and the Autodiscovery test from an Outlook 2007 client returned success for this test as well.

     


    This worked for me as well. Thanks!
    Friday, February 04, 2011 4:38 PM