none
unable to start the iis service on Exchange 2003 server

    Question

  • Dear Team,

                        Recently we have applied a hot fix for our Exchange server for below mentioned event ID. then we have rebooted the server.
    After few minutes IIS service stoopped unexpectedly. While trying to restart it manually its showing error.

    Kindly give some suggestions to activate the server to live.

    Details:

    Sql server version 2003 & Exchange 2003.


    Could not start the IIS Admin service on local computer.
    Error 230: The pipe state is invalid.
    <!-- /* Font Definitions */ @font-face {font-family:"Cambria Math"; panose-1:2 4 5 3 5 4 6 3 2 4; mso-font-charset:1; mso-generic-font-family:roman; mso-font-format:other; mso-font-pitch:variable; mso-font-signature:0 0 0 0 0 0;} @font-face {font-family:Calibri; panose-1:2 15 5 2 2 2 4 3 2 4; mso-font-charset:0; mso-generic-font-family:swiss; mso-font-pitch:variable; mso-font-signature:-1610611985 1073750139 0 0 159 0;} /* Style Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal {mso-style-unhide:no; mso-style-qformat:yes; mso-style-parent:""; margin:0in; margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman";} .MsoChpDefault {mso-style-type:export-only; mso-default-props:yes; font-size:10.0pt; mso-ansi-font-size:10.0pt; mso-bidi-font-size:10.0pt;} @page Section1 {size:8.5in 11.0in; margin:1.0in 1.0in 1.0in 1.0in; mso-header-margin:.5in; mso-footer-margin:.5in; mso-paper-source:0;} div.Section1 {page:Section1;} -->

    Hot fix link : <!-- /* Font Definitions */ @font-face {font-family:"Cambria Math"; panose-1:2 4 5 3 5 4 6 3 2 4; mso-font-charset:1; mso-generic-font-family:roman; mso-font-format:other; mso-font-pitch:variable; mso-font-signature:0 0 0 0 0 0;} @font-face {font-family:Calibri; panose-1:2 15 5 2 2 2 4 3 2 4; mso-font-charset:0; mso-generic-font-family:swiss; mso-font-pitch:variable; mso-font-signature:-1610611985 1073750139 0 0 159 0;} /* Style Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal {mso-style-unhide:no; mso-style-qformat:yes; mso-style-parent:""; margin:0in; margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman";} a:link, span.MsoHyperlink {mso-style-noshow:yes; mso-style-priority:99; color:blue; text-decoration:underline; text-underline:single;} a:visited, span.MsoHyperlinkFollowed {mso-style-noshow:yes; mso-style-priority:99; color:purple; mso-themecolor:followedhyperlink; text-decoration:underline; text-underline:single;} .MsoChpDefault {mso-style-type:export-only; mso-default-props:yes; font-size:10.0pt; mso-ansi-font-size:10.0pt; mso-bidi-font-size:10.0pt;} @page Section1 {size:8.5in 11.0in; margin:1.0in 1.0in 1.0in 1.0in; mso-header-margin:.5in; mso-footer-margin:.5in; mso-paper-source:0;} div.Section1 {page:Section1;} -->

    http://support.microsoft.com/kb/932182

     

    Event ID: 9582
    Event Type: Error
    Event Source: MSExchangeIS
    Event Category: Performance
    Description: The virtual memory necessary to run your Exchange server is fragmented in such a way that normal operation may begin to fail. It is highly recommended that you restart all Exchange services to correct this issue.

    For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    895407   (http://support.microsoft.com/kb/895407/ ) In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups
    Saturday, November 28, 2009 1:45 PM

All replies

  • Can you let us know what SQL and Exchange are doing on the same server?

    Is this default installation of IIS or some changes has been done on it?

    Have you updated your Anti virus recently. Can you disable the AV for a while and then try to restart the IIS services?
    Raj
    Saturday, November 28, 2009 1:59 PM
  • Thank you for your repose  Raj,
    Yes, default installation of IIS 6.0, AV Trent micro is updated on today only,


    I will check with my server without AV services.


    Saturday, November 28, 2009 2:06 PM
  • Hi,

                Even we have disabled the AV services also, but still we are getting the same error.
    Saturday, November 28, 2009 2:13 PM
  • Hi,

    As my understanding,after you have apply kb 895407, IIS Admin service cannot start,is that ture?

    Then I'd like to know what are other application that has been installed on the Exchange Server?

    Please check event log and post the detail error event which is related to IIS service.

    Also please check task manager to see if memory has been in high usage.

    Regards,
    Xiu
    Monday, November 30, 2009 8:07 AM
  • What happens when you start IIS with IISRESET /Noforce switch?
    Vinod |CCNA|MCSE 2003 +Messaging|MCTS|ITIL V3|
    Monday, November 30, 2009 12:26 PM