none
Outlook 2007 prompts for Password each time outlook starts under windows 7

    Question

  • I recently ran a 2003 to 2007 upgrade install of outlook 2007 on my windows 7 system and I am prompted for password each time I load outlook. Occasionally for some reason there will be no prompt but only after Outlook has load at least once prompting me for password. My exchange account is through Hostways Exchange service so I have set it up using recommended auto discovery which connect to Microsoft Exchange using HTTP and uses basic Authentication for proxy authentication setting. I have been in contact with the tech support at Hostway and their troubleshooting systems are running XP and they can't seem to recreate this problem. Anyone know why this could be happening is it server side?, did the install screw up?, is it windows 7? any help would greatly be appreciated.  
    Friday, June 11, 2010 9:17 PM

Answers

  • Hi,

    By default, the prompt password behaviour should be received as expected for basic authentication. To fix this issue, you should change the basic authentication to NTLM on the Outlook side.

    Thanks

    Allen

    • Marked as answer by Allen Song Monday, June 21, 2010 2:29 AM
    Thursday, June 17, 2010 7:29 AM

All replies

  • Open the Windows Key Manager:

    Click Start > Run
    Type "control keymgr.dll"
    Click OK, then Add
    Enter your Server Name
    Enter your mailbox password
    Click OK and then Close

    Please also note keymgr is not available on home versions of OS.


    MCITP: Enterprise Messaging Administrator
    Saturday, June 12, 2010 6:11 PM
  • Thank you for your reply. you are aware I am running windows 7 right? The Windows Key Manager is now called Credentials Manger. I have tried creating a windows credential and a generic credential and neither work. Any help is greatly appreciated. 
    Sunday, June 13, 2010 7:59 PM
  • Hi Brad, a bit of clarification:

    For Windows 7 specifically - you will need to add a new entry. Use "Add Windows Credentials" link in the top of the list of Credentials Manager. Type "*.domain.com" (that represents your server address) in the Internet or Network Address field. Enter your primary email address as a User Name and your mailbox password.

    Once done you will need to reboot the computer. These are the the steps that should work.


    MCITP: Enterprise Messaging Administrator
    • Proposed as answer by eddiemam Wednesday, November 28, 2012 4:42 PM
    Monday, June 14, 2010 4:33 AM
  • On the network prompt where it says "Connecting to Blank.server.name " Blank.server.name is the domain right? If so, I have tried this without any luck. I am still prompted for password. When I setup the exchange account in outlook the first time I was prompt for password and the prompt had the remember password check box. I checked the check box and proceeded into oultook. closed outlook and on the next start I was prompted for password and the remember password check box was gone. I created a new profile and setup the account and the same thing happened. Is the server I am connecting to requiring me to enter password each time? Thanks again for any help. 

    p.s. the Windows 7 Computer the is connecting to the exchange account is not on a domain.

    Monday, June 14, 2010 7:45 PM
  • Brad, which type of authentication is selected on Exchange Proxy Setting for Outlook profile?

    What other options are selected on that tab?


    MCITP: Enterprise Messaging Administrator
    Wednesday, June 16, 2010 4:41 PM
  • Hi,

    By default, the prompt password behaviour should be received as expected for basic authentication. To fix this issue, you should change the basic authentication to NTLM on the Outlook side.

    Thanks

    Allen

    • Marked as answer by Allen Song Monday, June 21, 2010 2:29 AM
    Thursday, June 17, 2010 7:29 AM
  • This is why I was asking what is set there:)

    The following things are also worth of checking:

    Check Connect using SSL only:
    - check Only connect to proxy servers that have this principal name in their certificate
    The Principle name for the proxy server is in the following format:
    - msstd:proxy.server.com   (proxy.server.com is the same as the Proxy Server URL)


    MCITP: Enterprise Messaging Administrator
    Thursday, June 17, 2010 8:19 AM
  • Hello there Brad,

     

    Any chance they are using RPC of HTTPS, if so then my understanding is that you should be prompted each time when starting Outlook 2007. I am aware that Outlook 2010 does not require login. I currently use another hosted exchange provider that just started offering Outlook 2010 and i have to say i'm impressed.

     

     


    Office2Mobile, On the move with enterprise-class tools hosted by http://themessagecenter.com/
    Thursday, June 17, 2010 9:13 AM
  • 2Office2Mobile - the solution described above assumes that rpc over https is used and this workaround should work.

    Options on Security tab in Outlook need to be verified and keymgr entry should be added properly.


    MCITP: Enterprise Messaging Administrator
    Thursday, June 17, 2010 1:47 PM