none
SMTP Error 500 Line too long

    Question

  • We are running Exchange 2007 SP1 on Windows 2008 SBS. Some email coming from the outside (usually AOL) are getting kicked back to the sender with the error:

    >>> DATA

    <<< 500 Line too long

    554 5.5.0 Remote protocol error


    From what I can tell in researching this is the email contains more than 1000 characters on a single line. We never encountered this with Exchange 2003 so I'm thinking that this is an enhancement made in exchange 2007 to help combat spam. We use a hardware firewall for spam filtering so we were wondering if there is a way to set Exchange to ignore this.

    Anyone have any ideas?
    Monday, April 13, 2009 8:24 PM

Answers

  • You were right! The message was coming from the SMTP proxy service on the firewall. The proxy service has a setting that controls the maximum line length. This was set to 1000. To fix it I increased the limit to the one you said was imposed by Exchange of 8,000, resent my test email and it went through just fine.

    Just an FYI-for some reason most of the emails I was notified of came from the AOL.com domain.

    To fix (I have the Watchguard Firebox X Edge X20e)

    1. Firewall > Incoming > SMTP Proxy
    2. Click Edit
    3. Click the SMTP Settings Tab
    4. Change Maximum Line Length
    • Proposed as answer by Milind Naphade Wednesday, April 15, 2009 2:54 AM
    • Marked as answer by Elvis Wei Wednesday, April 15, 2009 6:57 AM
    Tuesday, April 14, 2009 7:57 PM
  • Where does the incoming email land first of all? Is it your Exchange Server directly from internet or some other SMTP service? This isnt an Exchange Server 2007 problem I believe. AFAIK, the accepted line length is increased to 8,000. The one you have described above is for Exchange Server 2003.

    M
    Milind Naphade | MCTS:M | http://www.msexchangegeek.com
    • Marked as answer by Elvis Wei Wednesday, April 15, 2009 6:57 AM
    Tuesday, April 14, 2009 6:33 AM

All replies

  • Where does the incoming email land first of all? Is it your Exchange Server directly from internet or some other SMTP service? This isnt an Exchange Server 2007 problem I believe. AFAIK, the accepted line length is increased to 8,000. The one you have described above is for Exchange Server 2003.

    M
    Milind Naphade | MCTS:M | http://www.msexchangegeek.com
    • Marked as answer by Elvis Wei Wednesday, April 15, 2009 6:57 AM
    Tuesday, April 14, 2009 6:33 AM
  • The incoming email hits a watchguard firewall first which does the spam filtering for us via a SMTP proxy. Do you think this could be causing the line too long error?
    Tuesday, April 14, 2009 7:32 PM
  • You were right! The message was coming from the SMTP proxy service on the firewall. The proxy service has a setting that controls the maximum line length. This was set to 1000. To fix it I increased the limit to the one you said was imposed by Exchange of 8,000, resent my test email and it went through just fine.

    Just an FYI-for some reason most of the emails I was notified of came from the AOL.com domain.

    To fix (I have the Watchguard Firebox X Edge X20e)

    1. Firewall > Incoming > SMTP Proxy
    2. Click Edit
    3. Click the SMTP Settings Tab
    4. Change Maximum Line Length
    • Proposed as answer by Milind Naphade Wednesday, April 15, 2009 2:54 AM
    • Marked as answer by Elvis Wei Wednesday, April 15, 2009 6:57 AM
    Tuesday, April 14, 2009 7:57 PM
  • I am glad that it is working for you now.


    Milind Naphade | MCTS:M | http://www.msexchangegeek.com
    • Proposed as answer by Milind Naphade Wednesday, April 15, 2009 2:53 AM
    Wednesday, April 15, 2009 2:53 AM