none
How do I move autocomplete data to a different/new mailbox?

Answers

  • ok I found the solution (well seems to work for me running Outlook 2010 on Windows 7 x64)

    Close Outlook. If you have the old Stream_Autocomplete file the old mailbox used - copy it to:

    C:\Users\[username]\AppData\Local\Microsoft\Outlook\RoamCache

    There will already be a new Stream_Autocomplete file in there in use by the new account (if there isn't - open Outlook and start typing in the "To" field to create that file.Then close Outlook again).

    Highlight the new file, hit F2 and copy the filename to the clipboard. Then delete that file. Highlight your old file, hit F2 and paste in the new filename.

    Start Outlook.

    That did the trick for me. All my old auto-completes now appear as soon as I start typing. Glad it's working but pretty annoyed it was this difficult to get working. The video on Microsoft's own website here: (http://www.microsoft.com/showcase/en/us/details/32b0e97c-c4d2-4e44-85b0-7e715922c587) says Outlook 2010 includes autocomplete data in an exported PST file. Well I am running Outlook 2010 and my exported file absolutely did not include this data. I had to hunt round until I found the Stream_Autocomplete solution on another site:

    http://benosullivan.co.uk/windows/how-to-copy-auto-complete-in-outlook-2010/

    cheers

    Jason

    Monday, May 23, 2011 3:56 AM

All replies

  • Hi,

    There is "Stream_Autocomplete file" in outlook 2010 and outlook 2007 use .nk2 dat file to store autocomplete data. Did you tried to move this dat file as per your outlook version and tested it.

    Below thread have good piece of information:

    http://social.technet.microsoft.com/Forums/en-US/exchangesvrclients/thread/69d72432-4726-4e40-a71b-048033ee33a0/

     


    Anil
    • Proposed as answer by Anil K Singh Tuesday, May 03, 2011 3:06 AM
    Thursday, April 28, 2011 2:46 PM
  • I've done that.  The link I provided has similar steps. But we are using Outlook 2010 in non-cached mode to connect to exchange 2010.

    It seems the entries are only associated with the mailbox in exchange and was wondering if there was a way to extract those.

    Thursday, April 28, 2011 3:17 PM
  • This DAT file only generate once you use cache mode in outlook and not in Exchange mailbox (As per my knowledge).
    Anil
    Thursday, April 28, 2011 3:44 PM
  • So in order to move the data you'd have to set the account up in cached mode to get the data cached in those files once.  Then back up those files like you normally would?

    Monday, May 02, 2011 6:44 PM
  • I set the account to cached mode. Logged into the server with the acount, opened outlook, then closed it. and Copied those files.  Importing them to the same account once the new mailbox was setup did not carry over the auto complete data.

    Monday, May 02, 2011 11:54 PM
  • Hi,

    This forum is for exchange related issues. For questions about Outlook please use the following links which would be the most relevant forum for your question.

    Outlook IT Pro Discussions

    http://social.technet.microsoft.com/Forums/en-US/outlook/threads

    Related information:

    Import Auto-Complete List from another computer


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Anil K Singh Tuesday, May 03, 2011 3:06 AM
    Tuesday, May 03, 2011 2:51 AM
    Moderator
  • We are using Outlook 2010 in non-cached mode which means the auto complete data is stored in the users exchange 2010 mailbox. (according to Anil K Singh)  I'm looking for a way to extract that data from the mailbox in exchange 2010.  I don't have an NK2 file I can copy since we are using Outlook 2010.  I have also tried copying the autocomplete file from the profile of the user with no luck; even while temporarily setting the account in cached mode, then trying again. (I have posted the link to the steps I followed.)

    It seems the exchange 2010 mailbox will not release the autocomplete data.

    Tuesday, May 03, 2011 1:45 PM
  • Outlook 2010 auto complete data is stored in the mailbox and suggested contacts.

    Suggested Contacts is a way for administrators and users to control AutoComplete cache contents directly through the Outlook interface.

    It is easy to export and import suggested contacts.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, May 04, 2011 1:28 AM
    Moderator
  • When I exported the data before moving the user to a new mailbox, it did grab the suggested contacts.  They were even there when I reimported to the new mailbox. But nothing still comes up when you start typing into the "To" field.

     

    And based on this article Autocomplete is not the same thing as suggested contacts:

    http://news.office-watch.com/t/n.aspx?articleid=1432&zoneid=4

     

    So far; having the suggested contacts in the new mailbox setup does nothing, and also copying the Strean_Autocomplete file from the old profile to the new one does nothing.

    Wednesday, May 04, 2011 1:54 PM
  • Just tested importing with a different account and it seems to be something with the roaming profile.

     

    I'll post in a bit when I get a definite answer.

    Wednesday, May 04, 2011 2:01 PM
  • When I exported the data before moving the user to a new mailbox, it did grab the suggested contacts.  They were even there when I reimported to the new mailbox. But nothing still comes up when you start typing into the "To" field.

     

    And based on this article Autocomplete is not the same thing as suggested contacts:

    http://news.office-watch.com/t/n.aspx?articleid=1432&zoneid=4

     

    So far; having the suggested contacts in the new mailbox setup does nothing, and also copying the Strean_Autocomplete file from the old profile to the new one does nothing.

    I am experiencing the exact same thing. I am moving to a different hosted Exchange company. I exported my Outlook 2010 into a PST file. Configured Outlook with my new hosts settings and imported my PST. All my Suggested Contacts are there - but nothing comes up when I start typing in the "to" field. According to Microsoft, in Outlook 2010, autocomplete info is included in the PST file but it doesn't seem so here. I also tried copying the Stream_Autocomplete file  from the old profile to the new one and it just gets overwritten the instant I open an email and start typing.

    Did you find a solution??

    Monday, May 23, 2011 3:35 AM
  • ok I found the solution (well seems to work for me running Outlook 2010 on Windows 7 x64)

    Close Outlook. If you have the old Stream_Autocomplete file the old mailbox used - copy it to:

    C:\Users\[username]\AppData\Local\Microsoft\Outlook\RoamCache

    There will already be a new Stream_Autocomplete file in there in use by the new account (if there isn't - open Outlook and start typing in the "To" field to create that file.Then close Outlook again).

    Highlight the new file, hit F2 and copy the filename to the clipboard. Then delete that file. Highlight your old file, hit F2 and paste in the new filename.

    Start Outlook.

    That did the trick for me. All my old auto-completes now appear as soon as I start typing. Glad it's working but pretty annoyed it was this difficult to get working. The video on Microsoft's own website here: (http://www.microsoft.com/showcase/en/us/details/32b0e97c-c4d2-4e44-85b0-7e715922c587) says Outlook 2010 includes autocomplete data in an exported PST file. Well I am running Outlook 2010 and my exported file absolutely did not include this data. I had to hunt round until I found the Stream_Autocomplete solution on another site:

    http://benosullivan.co.uk/windows/how-to-copy-auto-complete-in-outlook-2010/

    cheers

    Jason

    Monday, May 23, 2011 3:56 AM
  • Excellent!  I'll give that a try.  I kind of lost hope for this until I checked back in.
    Thursday, May 26, 2011 3:32 PM
  • Awesome answer, worked perfectly. I had to extract the AUTOCOMPLETE from an old pst to a new pst... worked.

    Tuesday, December 11, 2012 7:19 AM