none
Security Alert for Security Certificate while openning outlook

    Question

  • Dear All,

    We have MS Exchange 2010 installed on Windows Server 2008 R2, it was decommissioned improperly, now we have installed it properly and installed the Security Certificates from Valid vendor, but when we open Outlook "Security Alert" message pop-ups 2 times, stating "The name on the security certificate is invalid or does not match the name of the site."

    Only Outlook is giving this problem, OWA is working fine. SSL Certificate status is OK/valid for my domin.

    For OWA fqdn is mail.company.com and for internal fqdn in the dns is mail1.company.com, MX record is not in local dns, hosted somewhere else.

    Can someone give me hint how to get rid of these couple of time repeated Security Alert Pop-up messages.

    Thanks in advance

     

    Saturday, October 15, 2011 12:41 PM

Answers

  •  

    Hello,

     

    The most possible cause should be described in the following article:

     

    http://support.microsoft.com/kb/940726

     

    In order to understand the issue more deeply on your server, please also collect the following information for my further research.

     

    [Please provide a screenshot of the certificate warning in Outlook]

      

    [Collect AutoConfiguration Status in problematic Outlook]

    ========================================

    1. While Outlook is running, click the CTRL key and then right-click the Outlook icon in the system tray and then select “Test Email Autoconfiguration”.

    2. Confirm that your email address is in the address field, uncheck “Use Guessmart” and “secure Guessmart authentication” boxes. Then click the “Test” button.

    3. Once it runs, please send me a screen shot of the Log and Results tab..

     

    [Certificate configuration information]

    =============================

    On CAS server, open Exchange Management Shell and type the cmdlet:

     

    Get-ExchangeCertificate |fl >c:\certlog.txt

    Get-autodiscovervirtualdirectory | fl >c:\auto.txt

    Get-clientaccessserver | fl >c:\cas.txt

     

    You can reach me at: v-simwu@microsoft.com

     

    Thanks,

    Simon

    Monday, October 17, 2011 10:02 AM
    Moderator

All replies

  • The issue is documented here http://support.microsoft.com/kb/940726
    Jasjit Singh Dhindsa | ITIL v3 | IASA Foundation Certified | MCITP:Exchange 2010 | Exchange 2007 | MCTS:OCS 2007 | Exchange 2010 | Exchange 2007 | MCSA:Messaging | Security | MCSE:Messaging | Security | MCP
    Saturday, October 15, 2011 12:54 PM
  • This KB article may properly help:

    Security warning when you start Outlook 2007 and then connect to a mailbox that is hosted on a server that is running Exchange Server 2007 or Exchange Server 2010: "The name of the security certificate is invalid or does not match the name of the site"
    http://support.microsoft.com/kb/940726


    MCTS: Messaging | MCSE: S+M
    Saturday, October 15, 2011 12:55 PM
  • Hi Jon-Alfred,

    Its Exchange 2010, and when we start Outlook then it connects to Exchange 2010 and the pop-up appears couple of time, and i press OK then i can work normaly.

    Anyways thanks, I'll read and will get back to forum...

     

    Saturday, October 15, 2011 1:02 PM
  •  

    Hello,

     

    The most possible cause should be described in the following article:

     

    http://support.microsoft.com/kb/940726

     

    In order to understand the issue more deeply on your server, please also collect the following information for my further research.

     

    [Please provide a screenshot of the certificate warning in Outlook]

      

    [Collect AutoConfiguration Status in problematic Outlook]

    ========================================

    1. While Outlook is running, click the CTRL key and then right-click the Outlook icon in the system tray and then select “Test Email Autoconfiguration”.

    2. Confirm that your email address is in the address field, uncheck “Use Guessmart” and “secure Guessmart authentication” boxes. Then click the “Test” button.

    3. Once it runs, please send me a screen shot of the Log and Results tab..

     

    [Certificate configuration information]

    =============================

    On CAS server, open Exchange Management Shell and type the cmdlet:

     

    Get-ExchangeCertificate |fl >c:\certlog.txt

    Get-autodiscovervirtualdirectory | fl >c:\auto.txt

    Get-clientaccessserver | fl >c:\cas.txt

     

    You can reach me at: v-simwu@microsoft.com

     

    Thanks,

    Simon

    Monday, October 17, 2011 10:02 AM
    Moderator
  • I have the same issue but different scenario.  I too am getting that Security Alert for security certificate while opening Outlook.  But in my case, my Exchange Server 2010 crashed and was never recovered.  We moved to the Exchange Cloud instead.  Our Outlook is configured using Outlook Anywhere to point to the cloud but for some reason some Outlook users are getting that Security Alert trying to get the user to accept or deny the old Exchange Server certificate.  First I thought it had something to do with the users old Outlook profile before the crash, but we have one new user with the same issue that has a new computer and Outlook was freshly installed and configured.


    How can I get rid of that old Exchange certificate alert from popping up with no Exchange server?


    Thanks. - Rogie


    Rogie O

    Wednesday, February 06, 2013 10:24 PM