none
When setting up with iPhone, I recieve the message: "Unable to verify account information"

    Question

  • I have tried to connect to our exchange server via iPhone on both iPhone 3GS and iPhone 4.  When I setup the account on the iPhone, it keeps giving me the message "Unable to verify account information".  All parameters seem correct, and we had this working on Blackberry with no problems.  Why is it not connecting with the iPhone?
    Monday, April 25, 2011 4:12 PM

Answers

  • I have figured this out.

    Every network running exchange server and ISA is different, so for our exchange server I had to put the following settings into my iPhone in order for it to work:

     

    email: (my e-mail)

    server: www.mycompany.ca

    domain: (I left blank)

    username: (my user name, not the e-mail address!)

    password: (my password)

     

    This allowed connection to my exchange.  If you append "mail" to the beginning of the server name like "mail.mycompany.ca", then you have to edit the OMA Web Publishing Rule in ISA firewall, and add the address "mail.mycompany.ca" under the "Public Name" tab.  I didn't bother, and just used "www.mycompany.ca".

    • Marked as answer by E.Zero Tuesday, April 26, 2011 12:49 PM
    Tuesday, April 26, 2011 12:49 PM

All replies

  • I just figured out that ISA firewall is denying my iPhone connection when trying to connect to Exchange.  Here is what ISA firewall says:

    Denied Connection

    Log type: Web Proxy (Reverse)
    Status: 12202 The ISA Server denied the specified Uniform Resource Locator (URL).
    Rule: Default rule
    Source: External ( ***.***.***.***:0)
    Destination: ( ***.***.***.***:443)
    Request: OPTIONS http://mail.mycompany.ca/Microsoft-Server-ActiveSync
    Filter information: Req ID: 19109d22
    Protocol: https
    User: anonymous
     Additional information
    • Client agent: Apple-iPhone3C1/808.7
    • Object source: Processing time: 1
    • Cache info: 0x8 MIME type:

    How do I allow the iPhone to get through to Exchange?

    Monday, April 25, 2011 6:40 PM
  • I have figured this out.

    Every network running exchange server and ISA is different, so for our exchange server I had to put the following settings into my iPhone in order for it to work:

     

    email: (my e-mail)

    server: www.mycompany.ca

    domain: (I left blank)

    username: (my user name, not the e-mail address!)

    password: (my password)

     

    This allowed connection to my exchange.  If you append "mail" to the beginning of the server name like "mail.mycompany.ca", then you have to edit the OMA Web Publishing Rule in ISA firewall, and add the address "mail.mycompany.ca" under the "Public Name" tab.  I didn't bother, and just used "www.mycompany.ca".

    • Marked as answer by E.Zero Tuesday, April 26, 2011 12:49 PM
    Tuesday, April 26, 2011 12:49 PM