none
Can't setup Outlook for Mac 2011 with Exchange Server 2010 - Connection Issue

    Question

  • I am trying to setup an exchange account in Outlook for Mac 2011. 

    I have entered name, e-mail, username (domain\username) and password.

    If I use auto setup it puts https://mail.servername.com/ews/exchange.asmx :443

    I am using the SSL to connect.

    If I configure manually, I just entered mail.servername.com into the server field.

    I have also tried to enter my username without the domain.

    I have verified the settings using my I-Phone and it connects.

     

    I have tried this several ways and it still will not connect.

    The server is Exchange 2010.

    I am not sure what else to try?

    • Moved by Frank.Wang Friday, November 19, 2010 8:14 AM Exchange 2010 query (From:General Discussions)
    Wednesday, November 17, 2010 1:22 AM

All replies

  • Hi brickyard007,

    Do all MAC users meet the same issue? How about Outlook users?

    Please Removed and recreated EWS virtual directory by using below commands:

    Remove-WebServicesVirtualDirectory -Identity "server\ews (Default Web Site)"
    New-WebServicesVirtualDirectory

    After that, please perform IISreset /noforce on the server and try again.


    Frank Wang
    Friday, November 19, 2010 8:25 AM
  • Hi Brickyard007,

    As Franks says there is some further investigation neccesary. In addition to his suggestions I've got a couple of things that may help troubleshoot.

    Are you able to browse to OWA from the Mac without any certificate issues? Does OWA and doing things like setting Out of Office in Outlook 2007+ work successfully?

    If your Client Access server is available externally, you might wish to try the Exchange Remote Connectivity Analyser , testing the Exchange Web Services (which is what Outlook 2011 uses to connect).

    Steve


    Steve Goodman
    Check out my Blog for more Exchange info or find me on Twitter

    Friday, November 19, 2010 9:55 AM
  • Hi brickyard007,

    Any updates on your issue?


    Frank Wang
    Monday, November 22, 2010 2:58 AM
  • Hi Frank,

     

    I am having our network administrator try the suggestions provided.

    Currently all of the users are PC based - I am the first one to try a Mac.

    I will provide an update as soon as I hear back.

    thank you very much for your input.

     

    Regards

    Brian Rickards


    Brian Rickards
    Monday, November 22, 2010 6:42 PM
  • I just realized what OWA was....

     

    Yes - I can access the web app fine - no issues.

    Thanks

    Brian Rickards

     


    Brian Rickards
    Monday, November 22, 2010 6:44 PM
  • I had our IT person do the suggested above on our exchange server.  Still can't connect.

    OWA works fine - I just can't get the exchange connection to work in Outlook Mac 2011.

    I am connecting using Outlook 2007 on Pc with no problems.

    I ran the test suggested above and got the message below.

    I am traveling to our corporate office to meet with our IT person tomorrow.  Any suggestions? 

     

    Test Steps

     
    ExRCA is attempting to test Autodiscover for brickards@paladinbrands.com.
      Autodiscover was tested successfully.
     
    Test Steps
    Ensuring that the test mailbox folder is empty and accessible.
      ExRCA couldn't confirm that the folder is accessible and empty.
     


    Brian Rickards
    Friday, December 10, 2010 2:55 AM
  • I am experiencing the exact same issue as brickyard007, no problems connecting to exchange 2007 from the outlook 2011 (Mac version), it also works in OWA fine (for exchange 2011 as well). Unable to connect directly to exchange 2010 (64bit).

    No error message, it just sits there with no connectivity.......

     

    thanks and regards

     

    Wednesday, December 15, 2010 5:17 PM
  • Aside from the autoconfigured Exchange server (https://mail.domain.com/EWS/Exchange.asmx:443), the Directory Service server must be there as well. Can you confirm that the server field it is pointing to your domaincontroller.doman.com:3268 using "Log in with my Exchange Account credentials" checked? We had a similar issue as the DC field was not populated properly. Once we manually set it, logins commenced just fine.
    Wednesday, December 15, 2010 6:33 PM
  • Thanks for addressing this question!  I am having the same issue.  Work uses PCs, Exchange 2010 and I just bought Office 2011 for my Mac.  I think that your solution will work for me, but I don't think I am formatting my addresses correctly. [Please bear with me, because I'm pretty clueless.]

    The error I get when I try to send/receive is "Unexpected data was encountered." Error code is '-17997'.

    According to About OWA for my company, the server name is: PTR-MAIL1.company.local

    So when I am entering the Server information in Outlook 2011, what's the proper format? I've tried all of these and none of them work. [:443 is in all]

    https://PTR-MAIL1.domain.com/EWS/Exchange.asmx
    https://PTR-MAIL1.domain.com
    https://PTR-MAIL1.domain.local
    PTR-MAIL1.domain.local

    For the Directory Service Server, would 'domaincontroller.domain.com' be formatted as 'PTR-MAIL1.domain.com' or something else?  I've only duplicated the server information.  Use SSL is checked for both and I've checked 'Use my Exchange account credentials.'

    Lastly, my version of Outlook 2011 has the :3269, instead of :3268.  It's greyed out, so I hope that doesn't matter.

    Thanks so much for any help you can provide!!

     

     

     

    Saturday, January 15, 2011 11:01 PM
  • this is what you have to go,

    in outlook 2011, the place where you type your server name, make sure you put this at the end:   EWS/Exchange.asmx

    so if your domain is example.com, you would type the whole domain as follows:   https://example.com/EWS/Exchange.asmx

     

    also for directory service, put in your active directory ip or name.

     

    and in regards to what to type for username and password, i have enabled my exchange so that it would handle just the 1st part of the username.  but yours maybe different.  try both.   GOOD LUCK!!!!!!!!

     

    Thursday, February 03, 2011 1:00 AM
  • Thank you Sam, that worked a treat and I would never have got there on my own. Perfect! :)
    Friday, March 18, 2011 12:08 PM
  • Sam, I have the exact same problem.  However, the solution that you propose does not fix my problem.  I also noticed that the IMAP and POP3 services weere not running on my Exchange server, yet it still does not work.

    Here is a clue:  The Mac user was able to have full email functionality until I created and applied another Exchange certificate to solve an autodiscover problem I was having.  The new cert has all of the services the old one had.  But all I get when the user tries to send or receive email is "unexpected data was encountered".

     


    David Napolitan
    Monday, April 18, 2011 7:30 PM
  • Sort of having the same issue also. I am using a CAS Array. When i point Outlook2011 at each Arrary member, it works perfectly. But when I point at the casarray url, is when it fails. Any ideas?

    Monday, May 02, 2011 6:18 PM
  • Have you resolved this yet?  If not, do you have a .local domain?  If so, I may have an anwer for you.
    Thursday, May 26, 2011 10:33 PM
  • I'm having the same problem.  Outlook 2011 for Mac, trying to connect to Exchange 2010 SP1.  If the laptop is connected to the same network as the Exchange 2010 server I can use the local server name without issue.  If I try to use the external name it doesn't work.  All Outlook 2010 clients work perfectly, it's just Outlook 2011 for Mac that doesn't work. Ideas?
    Saturday, June 18, 2011 5:19 PM
  • Sam thanks much. This is what I was looking at and I would not have reached there by myself.
    Monday, June 27, 2011 8:22 PM
  • You are genius! Thanks a million.  Just couldn't get it to work and absolutely no help from the hosting company or tech support.  All working now.  Thanks again. 
    Monday, August 15, 2011 7:23 PM
  • Hi, I have a .local domain.  Is there another solution to this issue? thx.
    Tuesday, August 30, 2011 6:17 PM
  • Enabling Basic Authentication on EWS (Exchange Web Services) on Exchange 2010 worked for me.

    http://dryerr.wordpress.com/2010/11/10/outlook-2011-mac-with-exchange-2010-problems/

    Friday, December 16, 2011 8:38 PM
  • Ich have the same problem also with a .local domain!

    Can someone help please?
    Sunday, December 18, 2011 9:36 PM
  • Hi brickyard007,

    Do all MAC users meet the same issue? How about Outlook users?

    Please Removed and recreated EWS virtual directory by using below commands:

    Remove-WebServicesVirtualDirectory -Identity "server\ews (Default Web Site)"
    New-WebServicesVirtualDirectory

    After that, please perform IISreset /noforce on the server and try again.


    Frank Wang

    Hello,

    I just wanted to post here and let you know this is what fixed my problem. We've done migrations from Exchange 5 to 2000 to 2003 to 2007 and once on 2007 Out of Office stopped working for our 2007/2010 clients and has been like that for about 4 years now. I have a single mac user I was trying to get working and I tried everything anyone has proposed and it wouldn't connect until I used the method you posted. I did get an error when trying to create the new directory so I found another solution.

    Remove-WebServicesVirtualDirectory -Identity "server\ews (Default Web Site)"

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False 

    New-WebServicesVirtualDirectory


    Then everything worked and for fun I checked OOF and that started working so you're a big hero in my book right now.


     

    Wednesday, January 04, 2012 6:05 PM
  • thanks.  that did for me too!
    Sunday, March 25, 2012 2:16 AM
  • Check http://www.howexchangeworks.com/2012/04/how-outlook-2011-connects-to-exchange-2010-sp1.html to know how Outlook 2011 connects to Exchange 2010.

    Rajith Enchiparambil | http://www.howexchangeworks.com |

    HowExchangeWorks.Com

    Tuesday, April 03, 2012 10:47 AM
  • What was the answer - I am having this issue and we have a .local address
    Tuesday, March 19, 2013 7:03 PM
  • this is how it works for me (Outlook 2011 with Exchange 2010 on SBS2011):

    Authentication => Method: User Name and Password

    user name: domainname\username ( do not add .com or .local)

    ADVANCED... =>>

    Microsoft Exchange
    Server: mail.domainname.com 443 use SSL checked

    Directory Service

    Server: mail.domainname.com :3269
    Use SSL (checked)
    Log in with my Exchange Account Credentials (checked)

    works like a charm.. Lemmie know..


    • Edited by Alex Leshan Tuesday, June 11, 2013 12:00 AM
    Monday, June 10, 2013 11:59 PM
  • Thanks SAM, 

    https://webmail.contoso.com/EWS/Exchange.asmx  URL at Server Address is working fine for MAC ( outlook 2011).

    Also Sharing one MAC Script which is required to resolve such kind of issues, it will disable Autodiscover.

    Step1. First Check Outlook Profile name from Outlook's Tools->Accounts dialog

    Step2. Open AppleScript editor and paste this script and click on Run

    tell application "Microsoft Outlook"

                         set background autodiscover of exchange account "OutlookProfileNameto false

    end tell

     

    Note: Outlook 2011 should be RUNNING when you run above script.


    Kirpal Singh

    Friday, October 04, 2013 10:09 AM