none
S/MIME controls for Outlook Web App seems to be missing in hosting mode

    Question

  • Hey there,

    we've deployed a multitenant exchange 2010 sp1 setup and i've just noticed that i am unable to open S/MIME signed emails in OWA.

    this is the error message:

    "This message has a digital signature. The digital signature couldn't be validated because the S/MIME control isn't available."

    I know from owa 2007 that without this control it is not possible to verify signed mails, but in owa 2010sp1 it is not possible to even read the mail that was signed. the body of the mail is simply empty.

    then i tried to install the mentioned control element, i've searched for it, but there is no option to download/install the control via options menu.

    i can live with the missing S/MIME features, but it has to be possible to read signed(not encrypted) mails.

    so, is this some configuration problem on my side or is this simply a bug?

    • Moved by Andrei Talmaciu Wednesday, September 15, 2010 10:59 AM Move by OP Request (From:Exchange Server)
    Wednesday, September 15, 2010 8:59 AM

All replies

  • hmm i've tried to send this post to "exchange server for hosters" subforum, but it seems that this was not saved there.

    mods, can you please move the thread? thx

    Wednesday, September 15, 2010 9:01 AM
  • Hi Peter,

    hmm i've tried to send this post to "exchange server for hosters" subforum, but it seems that this was not saved there.

    mods, can you please move the thread? thx

    Is S/MIME enabled in Outlook Web App and is the plugin installed? http://technet.microsoft.com/en-us/library/bb738137.aspx
    http://technet.microsoft.com/en-us/library/bb124432%28EXCHG.65%29.aspx

    I believe it is not...

    Best regards
    Christian

    Wednesday, September 15, 2010 9:14 AM
  • yes S/MIME is enabled for the owa virtual directory

    and no, i cannot install the S/MIME control via options menu, since there is no security tab..

    Wednesday, September 15, 2010 1:21 PM
  • I haven't had the time to look at this yet but each tenant should have their own OWA Mailbox policy and I believe you can enable and disable SMIME over there too. Check that out. If I have some time later, I will look at it in more depth.

    Run,

    get-owamailboxpolicy -organization Alpineskihouse | set-owamailboxpolicy -SmimeEnabled $true


    Regards, Kip Ng - http://blogs.technet.com/b/provtest/

    Thursday, September 16, 2010 4:06 PM
    Answerer
  • Hey,

     

    hmmi did not know that there were additional mailbox policy options for every tenant.

     

    Now i've set the option to enabled, but when i got to the S/MIME Tab in ECP (in IE8) I'll get the following error:

     

    This feature isn't supported in the light version of Outlook Web App.  

    This feature isn't supported if Outlook Web App is set to maximize the blind or low vision experience. 

     

    hmm, i'm already using IE8, so why does OWA think, that i'm using OWA Light?

     

    Monday, September 20, 2010 3:37 PM
  • i do not know why, but appearently s/mime works for me in IE9. IE8 and other browsers still does not work.. :-/
    Tuesday, October 05, 2010 3:16 PM
  • S/MIME is not supported in Outlook Web App Light. I guess you know that already.

    IE8 should work but other browser, I am not so sure. What error are you getting? Have you tried that from another machine with IE8?


    Regards, Kip Ng - http://blogs.technet.com/b/provtest/
    Wednesday, October 06, 2010 3:52 AM
    Answerer