none
"Your request can't be completed" when trying to view a message on internal URL

    Question

  • I have two problems, but the second problem started when I tried to integrate an office web apps server with exchange 2013 so I am putting them into one post.

    I have two Windows Server 2012 boxes, one with Exchange 2013 (both roles) one with only Office Web Apps Server 2013. Exchange 2013 was working perfectly internally and externally.

    First issue - When I try and preview a document, I get the message "The WebReady Document Viewing service has been disabled by the administration for your organization. For more information, contact your helpdesk"."

    I am not using https for this test setup (AllowHttp is True), and the http.../hosting/discovery URL works fine both internally and externally.  I followed this guide to integrate Exchange with my Office WA server:

    http://technet.microsoft.com/library/2591b1be-92c4-4192-9f5e-e4e6b319170a

    Second issue - if I access Exchange OWA on the internal URL http://server/owa, when I click on a message the right pane says in red text "Your request can't be completed right now. Please try again later.

    If I access the external URL (even from an internal computer, where DNS is setup to resolve to the internal IP address of the exchange CAS), everything works fine (except for the Webready Document viewing)

    This second issue only started occurring when I tried to integrate office web apps, but even If I remove the WACDiscoveryEndPoint from the exchange OrganizationConfig the problem persists.

    Any help appreciated.


    Blair

    Sunday, January 20, 2013 1:40 AM

All replies

  • With regard to the "Your request can't be completed" problem, my original description was wrong. It is not the external URL that works, it was the fact that it was over https.

    So I get the error over http (which is only available internally), but if I access OWA over https (internally or externally), it works fine.

    I still don't know how to fix it, but this should narrow my search down.


    Blair

    Sunday, January 20, 2013 10:06 PM
  • Hi

    By default, it will access OWA over https, you said you use http to access, did you do the HTTP Re-direction or disable SSL before?

    Cheers


    Zi Feng
    TechNet Community Support

    Monday, January 21, 2013 9:15 AM
    Moderator
  • Hello,

    Out of the box both http and https work. I can't think of a good reason to allow http access, so I would prefer that it automatically redirect any http URLs to the https equivalent.

    So http://domain/owa would redirect to https://domain/owa and http://domain/ecp redirects to https://domain/ecp, etc.

    What is the best way of achiving this in 2013?

    Blair


    • Edited by Blair003 Monday, January 21, 2013 9:48 PM
    Monday, January 21, 2013 9:48 PM
  • Regarding the first issue:

    "The WebReady Document Viewing service has been disabled by the administration for your organization. For more information, contact your helpdesk".",

    I did not fix this issue per se, but I figured if we were going to use it in production we would do it over SSL, so I installed an SSL certificate (from a public CA) for the web office apps server.

    I reconfigured the farm specifying the SSL certificate and now it works fine.


    Blair

    Monday, January 21, 2013 9:51 PM
  • Blair, I'm not going to be any comfort but I have exactly the same problem: OWA over https works but http gives the error you describe.

    My servers do have a lot of other stuff on them and I've just built one up from new but my testing wasn't good: I hadn't grasped the non-SSL issue until now so was testing on https.  What a waste of two days!

    I'll now have to try again from scratch: this time testing via HTTP at every stage.  I'll let you know how I get on.

    Wednesday, April 10, 2013 6:39 PM
  • Blair, I've just done three clean installs on formatted partitions in order to try to solve your second issue.  The last one was EXACTLY as per the Exchange 2013 instructions and in none of them could I use http (after unticking "Require SSL" in IIS manager.

    It ocurred to me that the problem might orginate in the back end rather than the front end since we can get so far with displaying the email subject and preview but not the content.  So, I created a new user with a mailbox on the newly built server but this had no effect.

    So, unless I have something in my AD or GP that is causing the issue, I would have to dispute that http works OOB.  I think users will just have to educated to use https and, if working with a certificate from a private PKI, they will have to be provided with, and install, the CA's root certificate.

    I will have to go with the latter because I can't afford the cost of a public SAN certificate. I have 16 users whose devices I don't control and some of these are naive users.  Headaches ahead, I think!

    I haven't yet found a way to re-direct http to https in spite of some web users claiming it works.

    Friday, April 12, 2013 9:13 AM
  • Blair, thank you for the info above. You helped us narrow it down to IIS.

    The IIS "Exchange Back End" -> OWA -> Enable Anonymous Authentication fixed this issue for us.
    Notes taken from BCurran3 on this site:
    http://social.technet.microsoft.com/Forums/exchange/en-US/e23d2c95-068b-40a2-a20e-fb764f8fbebe/outlook-web-app-users-are-unable-to-see-body-of-the-email-message-while-connecting-with-the?forum=exchangesvrclients&prof=required

    • Proposed as answer by kenbarclay Sunday, February 23, 2014 5:18 PM
    Wednesday, February 19, 2014 9:34 PM
  • Blair, thank you for the info above. You helped us narrow it down to IIS.

    The IIS "Exchange Back End" -> OWA -> Enable Anonymous Authentication fixed this issue for us.
    Notes taken from BCurran3 on this site:
    http://social.technet.microsoft.com/Forums/exchange/en-US/e23d2c95-068b-40a2-a20e-fb764f8fbebe/outlook-web-app-users-are-unable-to-see-body-of-the-email-message-while-connecting-with-the?forum=exchangesvrclients&prof=required

    The post by Zed_s did it for me, thanks!

    http://social.technet.microsoft.com/Forums/exchange/en-US/e23d2c95-068b-40a2-a20e-fb764f8fbebe/outlook-web-app-users-are-unable-to-see-body-of-the-email-message-while-connecting-with-the?forum=exchangesvrclients&prof=required

    Sunday, February 23, 2014 5:19 PM