none
How to manually move the database file location in Exchange 2010

    Question

  • Good day,

    I have an Exchange 2010 SP2 mailbox server. Harddisk size is 200GB , database is 80GB in size and the Transaction log growed to fulfill the whole HD . moving Transaction Log files via "Use the EMC to move the mailbox database path" wasn't successful with error "wmi exception occured on server. quota violation" , also backup wasn't successful to free up the hard disk.

    I have created a new partition on the server with 200GB size and want to copy the log files manually to it , then use the ADSIEDIT utility to relocate the transaction log files path. is it possible ? if yes, how is it done ? otherwise what could be done ?

    Regards

    Elias Dayeh

    Monday, September 24, 2012 1:48 PM

Answers

  • Hi

    You can dismount the database, move/robocopy the log files and then run this command to update AD (there is no need to use ADSIedit):

    Move-DatabasePath –identity <NAME> –logFolderPath <path> –configurationOnly:$TRUE –verbose

    By the way, if your log files are filling up the disk this means that they are not being truncated (cleaned up) by your backup process.  You need to investigate this otherwise the problem will keep happening.

    Cheers, Steve

    • Marked as answer by Elias Dayeh Monday, September 24, 2012 5:23 PM
    Monday, September 24, 2012 3:09 PM

All replies

  • Instead of going through all that, simply dismount the database. This will commit any uncommitted log files to the database and puts it in a clean shutdown state. Go to the location of the log files and create a new empty folder. MOVE all the log files and the E00.CHK (checkpoint) file to that new folder. Go back to your console and mount the database. Once it successfully mounts, delete the folder containing the log files and free up space. Now that you have free space, you can use the Exchange management console to move the transaction log path.

    Get your backup working as soon as possible.


    Thank you, Ibrahim Benna MCSA+Messaging, MCSE+Messaging,MCITP, MCT, MVP "Did you backup your Information Store Today?!" ***Don't forget to mark helpful or answer***

    Monday, September 24, 2012 1:54 PM
  • Do you have DAG or it's a single mailbox server with standalone database copy?

    ExchangeGeek (MCITP,Enterprise Messaging Administrator)

    ***Don't forget to mark helpful or answer***

    Monday, September 24, 2012 1:55 PM
  • Thank you for your answer. please clarify the following:

    "Go to the location of the log files and create a new empty folder" :

    the Transaction log files location is on D:\ Drive , the new created drive is G:\

    you mean that create a new folder in the new drive location G:\ ? how would exchange realise the new path?

    Regards

    Elias

    Monday, September 24, 2012 2:05 PM
  • Hi

    how to move database in DAG you can find here:

    Exchange 2010 DAG move database

     

    if you have too many logs and you can't make full backup to truncate logs, you can enable circurllar logging for this database. Then wait until all logs will be truncated, then disable circullar logging and try to move database to new location.

     

    Regards

    Remigiusz

    Monday, September 24, 2012 2:48 PM
  • Hi

    You can dismount the database, move/robocopy the log files and then run this command to update AD (there is no need to use ADSIedit):

    Move-DatabasePath –identity <NAME> –logFolderPath <path> –configurationOnly:$TRUE –verbose

    By the way, if your log files are filling up the disk this means that they are not being truncated (cleaned up) by your backup process.  You need to investigate this otherwise the problem will keep happening.

    Cheers, Steve

    • Marked as answer by Elias Dayeh Monday, September 24, 2012 5:23 PM
    Monday, September 24, 2012 3:09 PM