none
Override Automatic Database Mount Dial

    Question

  • I have a question regarding the database failover functionality in Exchange 2010.  I have noticed that when we want to move the active copy of a mailbox database to another mailbox server, we get a dialog asking whether or not we want to override the automatic database mount dial on that server.  After digging into this a bit, I'm finding information that I'm having a hard time understanding.

    Apparently, the default automatic database mount dial setting in Exchange 2010 SP1 RU2 is 'Good Availability'.  According to the get-help on the set-mailboxserver cmdlet, using this setting (or any setting other than lossless) means that data may be lost during the failover.  Is this accurate?  Does this mean that by default, a mailbox database failover means data loss?  Or, does the dial setting only apply to failovers and not switchovers (eg. when a server goes down vs. an admin moving the active DB) ?

    I have a really hard time believing that the Exchange 2010 product is set to allow data loss right out of the box.  I hope that it's just a misunderstanding on my part.  Any input on this?

    Tuesday, March 15, 2011 3:28 AM

Answers

  • Quote: “data may be lost during the failover.  Is this accurate?”

    Yes, it’s correct for failover, but not for switchover. Please see the example 3 in the “Move-ActiveMailboxDatabase” cmdlet

    James Luo

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Jason Erdmann Monday, March 21, 2011 5:01 PM
    Monday, March 21, 2011 3:37 AM

All replies

  • Anyone have any information on this?  Thanks for the help, I really appreciate it.
    Wednesday, March 16, 2011 2:22 PM
  • Anyone have anything?  Anyone from the Microsoft side?
    Friday, March 18, 2011 2:42 PM
  • Quote: “data may be lost during the failover.  Is this accurate?”

    Yes, it’s correct for failover, but not for switchover. Please see the example 3 in the “Move-ActiveMailboxDatabase” cmdlet

    James Luo

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Jason Erdmann Monday, March 21, 2011 5:01 PM
    Monday, March 21, 2011 3:37 AM
  • Perfect, this is exactly what I needed.  Thanks for the help!
    Monday, March 21, 2011 5:01 PM