none
Move Message with Attachment from one Mailbox to another problem

    Question

  • Hi,

    starting with Exchange 2013 we have following odd thing. 

    (That happens with Outlook 2010 aswell as Outlook 2013). 

    My mailbox has several other mailboxes mounted aswell. (using Full Access at ECP Settings), aswell as one separate Exchange Mailbox with own User/Password. 

    Now, when I have an Email with an attachment (like Word, .jpg, whatever), I used to move it to another mailbox by using "drag & drop". 

    The mail was moved to the mailbox without noticable changes. 

    Starting with Exchange 2013, the Mail is changed into Rich Text. That means, the attachment now appears somewhere within the message, instead as real attachment. Some attachments are also lost, and as the message was moved, the only way to recover it is using our external Email Archive. 

    Is this a bug, or didn't I see any option that results in this odd behaviour?

    Moving to a different folder does work as expected, but not to another mailbox.

    Thanks

    Patrick 

    Wednesday, February 13, 2013 4:08 AM

All replies

  • Hello

    Thank you for your question.

    I am trying to involve someone familiar with this topic to further look at this issue.


    Terence Yu

    TechNet Community Support

    Thursday, February 14, 2013 2:09 AM
    Moderator
  • Thanks for your information. Let me know if there is anything new. 

    Patrick 

    Monday, February 18, 2013 11:19 PM
  • Hi,

    The same behaviour also occurs if you drag and drop a HTML email to the desktop. The MSG file is then displayed as richt text and in some cases (e.g. if the HTML mail contains an embedded Image) the attachment is lost.

    Copying back the MSG to the mailbox does not repair it.

    In my tests a copy to a PST file does not show this conversion, the mail is not converted to RTF.

    Some archiving software vendors store mail items in the MSG format. This currently won't work with Exchange Server 2013 (does not occur for Exchange Server 2007 and 2010). Hopefully CU1 will fix this problem.

    Even if you use MFC MAPI as a reference implementation for storing MSG files in the file system the same problem occurs.

    Thanks,

    Niels

    Thursday, March 14, 2013 12:28 PM
  • CU1 didn't fix this :(

    Any updates on this?

    Sunday, April 07, 2013 9:29 AM
  • Hi,

    We have thee some-same problem.

    Firstly it was alone Exchange 2010 sp3 + Outlook 2010 clients, and user can simply drag'n'drop emails from outlook directly to desktop, then open it - and see the same content as in "parent" message in Outlook (the format of *.msg doesn't changes) - everything ok!

    about a week ago it was Exchange 2013 CU1 (DAG) installed (the same domain), some users was migrated to it and got this trouble: drag message to desktop - open it - message becomed RTF, while "parent" message is HTML - (lost pictures and so on...)

    At the same time the users that still on exchange2010 doesn't have this trouble!

    Please HELP!


    • Edited by DDens Thursday, April 25, 2013 9:11 AM
    Thursday, April 25, 2013 8:59 AM
  • Any further to this? I Have a user who has just been upgraded to Wave 15 (Exchange Online 2013) who is reporting the same issue
    Tuesday, April 30, 2013 6:29 AM
  • Same problem here. Any solution yet?
    Wednesday, June 05, 2013 11:54 AM
  • was searching for a solution to this and only found this un-answered question.

    Same issue here.

    Connected Outlook to two mailboxes on Exchange 2013, drag-and-drop converts the message to RTF (this worked when running the mailboxes on Exchange 2010), forwarding the message to the second/another account seems to work without converting the message to rich text.


    MatsG

    Thursday, June 20, 2013 9:25 AM
  • Unfortunatly after the first message from a moderator, nothing ever happened again. I tried installing all Outlook 2013 Hotfixes, all Exchange 2013 Hotfixes, CU2, no change whatsoever. I just think this thread is forgotten. 

    What i figured out is, if you enable the "Cache" Mode, messages can be moved and won't be changed to RTF, but stays HTML, showing once more, that this is a Bug, as once I disable the Cache Mode, messages and attachments disappear. 

    As a short fix, cache mode might help, but there are other draw backs I'd like to avoid, like if you have the cache Mode for only 1 month (as we run on SSD's, we don't want to waste space of several mailboxes), when you do a search, it won't right search on the server, but you have to extra click it. 

    But anyway... this as a workaround. But please don't mark this as answer, as it's not... 

    Thanks
    Patrick 

    Sunday, July 21, 2013 8:00 PM
  • Hi there,

    Has anyone found a solution to this yet?

    Do we know if Microsoft have acknowledged that the problem exist and/or are looking into this?

    Thanks.


    Rob.

    Monday, July 22, 2013 10:27 AM
  • Hi all,

    Setting 'Use Cached Exchange Mode' on the exchange account in outlook fixed the problem for me. Setting to cached mode also fixed send-as problems I was experiencing in our setup (exchange 2013/outlook 2010).

    Edwin

    Tuesday, July 23, 2013 7:44 AM
  • I have a case open with Microsoft on this issue. Waiting to hear back, will update this when I do.
    Tuesday, July 30, 2013 2:35 PM
  • Any Updates? Same Problem here, Office 365 (wave blue) and Outlook 2013.
    Monday, August 05, 2013 3:41 PM
  • Hi,

    I wonder about Office365, as isn't Cache Mode needed here? At least with Cache Mode I don't have this problem anymore. 

    Patrick

    Monday, August 05, 2013 4:09 PM
  • Hi,

    I have opened a case with Microsoft. Microsoft has closed my case because it's definitively a big bug of Exchange 2013.

    No problem with others versions of Exchange.

    CU2 doesn't fix anything for this issue.

    Now, i think that we need wait for CU3... Or Hotfix...

    Daniel




    • Edited by azylis Tuesday, August 06, 2013 4:05 PM
    Tuesday, August 06, 2013 4:01 PM
  • Thanks for giving us this further info!

    Patrick

    Tuesday, August 06, 2013 4:45 PM
  • Hi Terence,

    Could you, or someone MS, please provide some sort of update on this. We seem to be a few that have this problem.

    It actually breaks functionality of an "Issue tracking system" for one of our customer, making it useless.

    thanks

    /Mats


    MatsG

    Wednesday, August 07, 2013 7:12 AM
  • Is there any news or a confirmed status about this bug? We suffer from the same problems, and think it's strange there's no acknowledgement from Microsoft here or on the knowledge base. Is there a fix or workaround available? Disabling the cache mode on Remote Desktop Session Host servers is not really an option...
    • Edited by verypsb Wednesday, August 14, 2013 5:57 AM
    Wednesday, August 14, 2013 5:54 AM
  • Hi,

    I opened a supportcase with Microsoft a few days ago and they sort-of acknowledge the problem. It was supposed to haevbeen fixed in CU1 but as most of us here we are now on CU2 and still have the problem. I am waiting to here from them this week with there findings. We had issues with scan-to-email from some MFP's as well, that appeared similarly (attachments unreadable) but those are now working with CU2.

    I will post back if I get something useful

    Update 21 aug:

    Got this confirmed from MS support today. It's a known issue, even in Office365, and is scheduled to be fixed in CU3.


    MatsG


    • Edited by MatsG Wednesday, August 21, 2013 12:43 PM
    Wednesday, August 14, 2013 6:42 AM
  • Our user also have this problem.

    Before, she just told me that she found the image inside the email is lost. She showed me the printing that she printed a few days ago. The printing showed that there is really a image inside the email.

    But now, the location which the image is placed in the email is simply just a few "ENTER".

    Then, I found she have a practice that she will move the read email from exchange online to the PST file.

    Also she also mentioned that it is strange as the email format is changed from html to rtf after email moving.

    As we are using Provisioning VDI, we cannot use Cached mode in Outlook. Otherwise, all user will load all email to the cache file every morning.

    It's so worried as I have no idea how much information is lost in our user's pst now.

    Wednesday, August 21, 2013 8:19 AM
  • We are experiencing the same issue. We've Exchange Online (2013) with Outlook 2010 SP2 in place.

    I just opened service request on the Office 365 Support. Let's see the reply.

    Thursday, August 29, 2013 3:15 PM
  • Experiencing the same issue here as well with Exchange Online and Outlook 2010 (SP1 and tried SP2 without any help).  Interested to see this get resolved.
    Friday, September 20, 2013 7:08 PM
  • Hello

    Thank you for your question.

    I am trying to involve someone familiar with this topic to further look at this issue.


    Terence Yu

    TechNet Community Support

    Well, is someone looking into this? The silence on this issue is deafening...

    Friday, October 04, 2013 7:12 AM
  • We have this on one environment too. Exchange 2013 CU2, however another one running CU1 is perfectly fine.

    Going to raise as an issue.

    Friday, October 04, 2013 9:18 AM
  • Hello

    Any updates on this?

    We are currently migrationg from exchange 2007 to exchange 2013 and

    we have the same problem here. When we disable the cache mode, all html emails

    are being convertet from html to richtext when a email is moved from the inbox to antoher store.

    In our case a Personal Folder (pst file)

    Tuesday, October 08, 2013 10:02 AM
  • Hello Terence,

    Who did you involve? we still have the same issue for over months now.

    Hope to hear soon from Microsoft

    Regards

    Wednesday, October 16, 2013 12:34 PM
  • We are experiencing this same issue. A user is moving email that have attachments into a .pst file and they are occasionally being converted to RTF. Some of the attachments have become corrupted because of this.
    Monday, November 04, 2013 8:10 PM
  • We have observed the same issue. This issue is probably described in http://support.microsoft.com/kb/2862739/EN-US and it seems that this issue is not fixed until now :(
    Wednesday, November 13, 2013 8:52 AM
  • Based on some research we have decided to create a workaround as all mails got converted from HTML to Rich Text when moving from User Mailbox to a PST(Archive).

    We have built an add-in for end-users to archive based on the following Outlook-VBA


    Option Explicit
    
    Sub MoveToFolder()
    
        Dim objApp As Outlook.Application
        Dim strPath As String
        Dim objNS As NameSpace
        Dim objFolder As Outlook.MAPIFolder
        Dim olCurrExplorer As Outlook.Explorer
        Dim olCurrSelection As Outlook.Selection
        Dim olCurrMailItem As MailItem
        Dim m As Integer
        
     'pick destination folder
     Set objApp = CreateObject("Outlook.Application")
     Set objNS = objApp.GetNamespace("MAPI")
     Set objFolder = objNS.PickFolder
     
     'get selected mails
     Set objNS = objApp.GetNamespace("MAPI")
     Set olCurrExplorer = objApp.ActiveExplorer
     Set olCurrSelection = olCurrExplorer.Selection
    
     For m = 1 To olCurrSelection.Count
        Set olCurrMailItem = olCurrSelection.item(m)
        On Error Resume Next
        olCurrMailItem.Move objFolder
        If Err.Number <> 0 Then
          With olCurrMailItem
            ' due this week flag
            .MarkAsTask olMarkThisWeek
            ' sets a specific due date
            .TaskDueDate = Now + 3
            .FlagRequest = "Call "
            .Save
            .FlagStatus = olFlagComplete
          End With
          olCurrMailItem.Move objFolder
         End If
     Next m
    
    End Sub
    
    

    for us it was important to have the mails still in HTML Formats as some customers are sending embedded images in the mail-body which are removed when the mail where converted to Rich Text.

    For people who doesn't care in which format an mail gets archived another workaround is to Flag the Message with an follow up action, then unflag (complete the follow up) and users are able to move the messages but still they would be converted from HTML to Rich Text.

    Strange enough that with a simple VBA move event the message will stay in HTML Format we are happy to found a solution and maybe someone else can use it.

    Thursday, November 14, 2013 11:18 AM
  • I installed CU 3 today and: Nothing changed! As described in http://support.microsoft.com/kb/2892464/en-us, CU 3 does not (explicitly) fix KB2862739. What a pity! :(
    Tuesday, November 26, 2013 3:27 PM
  • it should be solved in the SP1 (next CU release) which is expected beginning next year
    Wednesday, November 27, 2013 8:25 AM
  • I know this is not a solution, but at least a workaround:

    To change the message back to HTML (so that the attachment is listed 'separately' again), open the mail and click "Action" - "Edit Message" (Outlook 2013).  Then select the "Format Text" tab at the top, and select HTML.

    Your attachment should appear above your message body again.

    As I said, at least a workaround until Exchange SP1 is released, which is hopefully within the next 2 months!

    Wednesday, January 29, 2014 1:03 PM
  • Hi,

    when trying to convert an archived mail back to html, the workaround does not work for me.

    tested this with outlook 2010 & 2013

    doesn´t matter if i move the message back to inbox (from archive) after or before changing to html, nothing works  :(

    any proposal to me?

    using Exchange 2013 CU3

    with Outlook 2010/2013 ONLINE mode configured by GPO, in VDI Environment

    best regards

    Stefan


    • Edited by Stefan Esch Wednesday, February 12, 2014 1:35 PM
    Wednesday, February 12, 2014 1:14 PM
  • Hi,

    when trying to convert an archived mail back to html, the workaround does not work for me.

    tested this with outlook 2010 & 2013

    doesn´t matter if i move the message back to inbox (from archive) after or before changing to html, nothing works  :(

    any proposal to me?

    using Exchange 2013 CU3

    with Outlook 2010/2013 ONLINE mode configured by GPO, in VDI Environment

    best regards

    Stefan


    Hi Stefan,

    you will loose the format if its once converted to rich text have you tried my VBA Code?

    Its not the best code but its working.

    Monday, February 17, 2014 12:31 PM
  • Hi,

    did not tried your vba, but thanks for the feedback.

    just noticed the SP1 information about this problem here, seems that they fixed it

    http://support.microsoft.com/kb/2860242

    who tried first  ??  :)

    best regards

    Stefan

    Wednesday, February 26, 2014 12:39 PM
  • Hi everyone,

    SP1 fixed the HTML2RTF issue on our systems. Great!

    Greetings, George

    Thursday, February 27, 2014 2:51 PM