none
Maximum email size set in Exchange 2010, but still cannot send/receive large emails/attachments

    Question

  • I had a problem with a user sending or receiving an email with a 12 MB attachment.  I have Globally set the max size to 20 MB, and even set this user's maximum to 20 MB, but she still cannot send or receive emails with large attachments.  I recently moved all mail servers over to Exchange 2010, and the old Exchange 2003 server is off line.  We had no problem with attachment size with the old server.

    Could it be that there is still an issue related to the Exchange 2003 server?

     


    David Napolitan
    Monday, February 14, 2011 4:46 PM

Answers

  • Ok, a 19MB message sent across the Internet can actually inflate up to 30% in size due to content conversion.  Having said that, Exchange 2010 uses the X-MS-Exchange-Organization-OriginalSize header to track the original size of the message and should allow the lower of the 2 values (original size versus converted size) Regardless, if you want to allow 20 MB messages, you may want consider raising the allowed limits to account for the overhead.

    Also, if there are SMTP gateways that accept messages for your domain other than Exchange, ensure they are using the same limits as well.

     

    Monday, February 14, 2011 8:14 PM
    Moderator

All replies

  • Did you go through all the possiblities?

    http://technet.microsoft.com/en-us/library/bb124345.aspx

    Understanding Message Size Limits

     

    What client and protocol are sending the messages?

    Does this happen for all messages ( Internal versus internal > External and vice versa) ?

    Post the exact NDR.

    What size are the messages that bounce?

     

     

    Monday, February 14, 2011 6:04 PM
    Moderator
  • I tried to go through the article.  It is a bit confusing.  I have set 20 MB as the limit for Global send and receive, and the Send and Receive connectors are set to 20 MB.  The user sent a 19 MB attachment to me within the domain, and I returned it successfully.  She also sent thee same attachment to an outside address successfully.  When I returned the message from the outside, it was rejected.  Here is the test of the message on my gmail account:

    Technical details of permanent failure:
    Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 552 552 5.3.4 Message size exceeds fixed maximum message size (state 18).  She is using Exchange 2010 using the Outlook 2007 client.  I am using Exchange 2010 with an Outlook 2010 client.


    David Napolitan
    Monday, February 14, 2011 7:54 PM
  • Ok, a 19MB message sent across the Internet can actually inflate up to 30% in size due to content conversion.  Having said that, Exchange 2010 uses the X-MS-Exchange-Organization-OriginalSize header to track the original size of the message and should allow the lower of the 2 values (original size versus converted size) Regardless, if you want to allow 20 MB messages, you may want consider raising the allowed limits to account for the overhead.

    Also, if there are SMTP gateways that accept messages for your domain other than Exchange, ensure they are using the same limits as well.

     

    Monday, February 14, 2011 8:14 PM
    Moderator
  • OK, I'll try a 12 mb attachment.  There are no other SMTP servers.
    David Napolitan
    Monday, February 14, 2011 8:24 PM
  • Did it go through?

     

    Wednesday, February 16, 2011 4:03 PM
    Moderator
  • Did you find the answer, as as I seem to be experiencing similar issues with receiving mail with large attachments.

    Same setup Exchange Server 2010 with 2007 clients.

    Have set every limit possible (as far as I can see) to 100MB in EMC and the global limits via ADSI to the same.

    Rebooted both exchange servers and now starting to pull my hair out.

    NDR says:

    Technical details of permanent failure:
    Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 552 552 5.3.4 Message size exceeds fixed maximum message size (state 17).

    Any help would be greatly appreciated

    • Proposed as answer by Todgers Wednesday, June 27, 2012 8:13 AM
    • Unproposed as answer by Todgers Wednesday, June 27, 2012 8:17 AM
    Tuesday, June 26, 2012 8:39 PM
  • Found it!

    For us it was our Forefront server and the default connector limit in Exchange

    From the server > MMC > Exchange > Edge Transport > Server > Receive Connectors > Properties (Default setting is 10MB)

    I can now start replacing the hair I pulled out.

    Thanks

    • Proposed as answer by Todgers Wednesday, June 27, 2012 8:17 AM
    Wednesday, June 27, 2012 8:17 AM
  • There is one more twist. Your solution lets you receive large mails, however the changes should be applied to  the send connector as well. With these you may send and receive from domains outside your domain.However, you should also specify transportation rules (for intra-domain mails):

    Exchange > Organisation conf. > Hub transport > Global settings > Properties (Default setting is 10MB)

    The receive connector is in Exchange 2010 at:

    Exchange > Server conf. > Hub transport > Recieve Connector > Properties (Default setting is 10MB)

    And send connector in Exchange 2010 at:

    Exchange > Organisation conf. > Hub transport > Send Connector > Properties (Default setting is 10MB)



    Friday, January 11, 2013 11:44 AM