none
Outlook 2003 Free/Busy issues after migrating to Exchange 2010

    Question

  • I've got an interesting one here that is hopefully a quick fix.  After migrating to Exchange 2010 and moving the PF replicas to their new E2K10 server, users on Outlook 2003 cannot see the Free/Busy info for Resources (conf. rooms) that are into next year.  We can, however, see the Free/Busy via Webmail and Outlook 2007.  It seems very sporatic too.  On my Outlook, I can see one of the Resources Free/Busy, but not another (whereas prior I could not see either one of them beyond Dec. 2010).  Could this be RPC Encryption on the system folders?  If so, how do I remove it?  When I do a Get-RPCClientAccess, the encryption is denoted as False for the all the servers w/ PF and Mailboxes.
    Karl
    Tuesday, November 16, 2010 9:37 PM

Answers

  • Update (8/3/2012): Looking at the recent posts here, it seems like the issue has resurfaced sometime around E2010 SP2 release, if that's what you have found to be true then please call in and report it so that it can be investigated further. These type of regressions happen sometimes as part of the software update process and we do work to address these issues when reported by our customers. At this time, I don't see any request for a fix already opened on this issue, but when I'll see that, I'll update the post. If anyone here calls in, do let me know the support case number for tracking. Thanks!

    --------------------------------------------

    Update (3/18/2011): As confirmed by MVP Walter below, this issue can be resolved by applying a fix included in Exchange 2010 SP1 RU4 Update. See KB: http://support.microsoft.com/kb/2535105 for more details.

    ----------------------------------------------------

    This is a known issue & let me provide a brief description of the issue for clarification here. This is being investigated for a fix in Exchange 2010. There is no ETA available for a fix at this moment.

    Issue: Outlook 2003 fails to retrieve the extended Free Busy info (usually for 12 months) of other users when connecting to Exchange 2010 SP1. Outlook 2003 displays only 2 months (default setting) of Free Busy info. If someone has 12 months of Free Busy info published, 2 months are displayed properly, next 10 months are displayed as ‘Free’, rest appears as hash marks (‘no info available’). This is a problem especially when trying to book heavily utilized resources (like Conf. Rooms).

    Workarounds are to use Outlook 2007/Outlook 2010 or Exchange 2010 OWA.


    Sr. Program Manager, Product Quality, Exchange Client Access Server

    Friday, March 18, 2011 1:11 AM
    Moderator

All replies

  • OK, even more interesting. If you wait 5-10 minutes, the Free/Busy Schedule eventually populates. Huh?
    Karl
    Tuesday, November 16, 2010 10:02 PM
  • You can update the Outlook 2003 user profile with RPC encryption for a test.

     

    1. In Control Panel, open the Mail item.

    2. Click Show Profiles.

    3. Select your profile, and then click Properties.

    4. Click E-mail Accounts.

    5. Select View or change existing e-mail accounts, and then click Next.

    6. Select the Microsoft Exchange Server account, and then click Change.

    7. In the dialog box that contains your mailbox server and user name, click More Settings.

    8. In the Microsoft Exchange Server dialog box, click the Security tab.

    9. Click to select the Encrypt data between Microsoft Office Outlook and Microsoft Exchange Server check box, and then click OK.

    10. Click Next, and then click Finish.

    11. Click Close, and then click OK.

     

    For more information, please refer to the following article:

     

    http://support.microsoft.com/kb/2006508

     

    Does Free and Busy display normally?

     

    Thanks.


    Novak Wu-MSFT
    Thursday, November 18, 2010 7:45 AM
  • This is a bit more of a bug/issue than I expected.  Been working with MS PSS for over a week now and they have even recreated the problem (they think).  Will post the solution (if there is one) after we are done.


    Karl
    Tuesday, November 23, 2010 10:07 PM
  • Have you also looked at the following KB?

    Users who use Outlook 2003 cannot publish their free/busy data in Exchange Server 2010 or in Exchange Server 2007

    http://support.microsoft.com/kb/945602

     


    MCITP: Enterprise Messaging Administrator 2007/2010 | MCITP: Server Administrator | MCTS: Windows Server 2008 Applications Infrastructure, Configuring | MCP | MCDST
    Tuesday, November 23, 2010 10:31 PM
  • Hi Karl,

     

    Thank you for your update and I understand that you have contacted our Phone Support. If there is any update or solution, please share it to us.

     

    Thanks.


    Novak Wu-MSFT
    Wednesday, November 24, 2010 2:02 AM
  • We found out this is a "feature" after 30 + hours of phone support.  Outlook 2003 with Exchange 2010 is hard coded to reveal only 2 months of data.  There was thought to be a work around, but nothing has worked for us yet.  I will update when I have something working.


    Karl
    Wednesday, December 29, 2010 8:58 PM
  • HI,

     

    I am having similiar issue.  outlook 2003 users are intermittently seeing free/busy of other exchange 2010 free/busy schedule.  free/busy shows up for a while, than disappears.  all users are in exchange 2010.  users using outlook 2003 can not see Mac users free/busy schedule period.

     

    tried Novak's and Tom V's suggestions, that didn't work either.  This does not occur on outlook anywhere, outlook 2007 or outlook 2010.

    we are on exchange 2010 RU2.  windows 2008 R2.

     

    raymond

     

     

    Saturday, January 01, 2011 6:20 PM
  • Hi Karl,

    We're ramping up with our migration and currently have to maintain Outlook 2003 with E2K10. Has this issue been resolved for you? What was the work-around, if any? Is this documented somewhere online, as it would be a major show-stopper for us and it would be beneficial to be able to reference this, as it may push the management to sign off on the Outlook 2K7 upgrade.

    Thanks in advance!

    Wednesday, February 09, 2011 3:23 PM
  • Are you using the latest service pack for Office 2003?  It's up to SP3 now. Also are your users in Cached mode?  There have been many reports of issues with OL2003 in Online mode using Exchange 2010 due to Ex2010's lack of UDP notification support. (which is being added back in for RU3.)  I haven't heard of this causing issues with F/B lookups.  The work around is to use cached mode for OL2003, which does not require the UDP notification feature.

    If it is merely a matter of setting up the clients to publish more of the f/b info from the public folders, here is a GPO article that will help you set the OL clients to publish greater than 2 months f/b: http://msexchangeteam.com/archive/2004/06/10/152698.aspx

    I have also experienced corruption in the Schedule+ system folder in individual f/b data messages, to resolve these we had to find the corrupt messages using MFCMAPI to browse the system folder until we find f/b data that cannot be opened.  Delete the f/b message from the the system folder and then force the client to republish and everything works again.

    Wednesday, February 09, 2011 3:53 PM
  • Hi Cynep - here is what I recently received from Microsoft...there are some work arounds, but they are not working for us.  However, they have been for others.

    "At this time the CDCR (Critical Design Change Request) has been filed with the Product Group. Currently, this will be scored by the Product Group according to cost/risk. If accepted based on the scoring, it will then be assigned to an Owner. Whether or not this is rejected or accepted to fix will depend on how it is scored. Most likely, if accepted, it will be targeted for Exchange 2010 sp2 because it is a “new feature” for Exchange 2010.

    Just to clarify – the bug originally submitted was rejected for reason “By Design.” The server has no way of telling what the Client is set for Number of Months published. The default number of months is 2 or 62 days and that is why it was determined that this is an expected result based on the current design.  Keep in mind, this does not change the fact that we are still attempting to have this corrected. It is just a matter of a different type of request with the Product Group.

     Summary:

    ========

    The number of months for Free/busy publish has been extended. Outlook 2003 users are unable to consistently view free/busy data beyond 2 months. Configuration changes have been put in place as follows. Please ensure these are in place:

     1.       Group Policy which controls the publishing of free/busy data from the client side. Number of months the client will publish free/busy months will be determined by your business. Publish Interval - please set to update every 10 minutes as this seems to reduce the impact for end users.

     2.       FBPublishMonths – configured on the Exchange 2010 sp1 Mailbox servers, under the following key:

    Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Excdo\Parameters
    DWORD: FBPublishMonths
    Value data: The period, in months, for which you want to publish Free/Busy information. If this value is set to zero, no data will be published.

     3.       Microsoft.Exchange.RPCClientAccess.Service.exe configuration file - \Program Files\Microsoft\Exchange\v14\Bin folder  – locate the line “</appSettings>”   -  <add key=" MaximumQueryIntervalDays " value="365" />” (without quotes) and restart of Microsoft Exchange RPC Client Access service. This is done on all Exchange 2010 sp1 CAS AND Mailbox servers.

     4.       Web.config\Program Files\Microsoft\Exchange\v14\ClientAccess\ExchWeb\Ews folder  - locate the line “</appSettings>,” just above this line add the following – “<add key="MaximumQueryIntervalDays" value="365" />” (without the quotes) and recycle the MSExchangeSErvicesAppPool in IIS Manager. This is done on all Exchange 2010 sp1 CAS servers.

     Workaround:

    ===========

    We understand that with the above configuration changes in place, you may still see inconsistent behavior for the Outlook 2003 users. Please be advised that using OWA or Outlook 2007/2010, the users should be able to view the extended free/busy data as expected."


    Karl
    Wednesday, February 09, 2011 4:12 PM
  • CC_JD, it is a much larger problem than Outlook.  It is the way in which legacy Outlook clients access the Public Folders, in particular F/B.  In E2K10, it was hard coded to only show 2 months of F/B info for the way in which legacy clients access public folders (Outlook 2007 and 2010 use EWS).  The inconsistancies with this is a result of Outlook 2003 (or later) actually publishing x amount of months based on the GPO setting; however, E2K10 eventually updates the F/B for only 2 months.  An example: if you create a meeting and are viewing F/B info, as people modify their calendar (add/accept/create/delete) meetings, their F/B will be published per the GPO until E2K reminds the client that it can only publish 2 months.  See the threads above for more clarification...especially the one I just noted to Cynep.


    Karl
    Wednesday, February 09, 2011 4:29 PM
  • Karl,

    Thanks for your quick reply and insight - very helpful. We'll be testing this scenario/work-around in our lab, meanwhile we're treating this as an open risk/issue.

    Hopefully we'll see some additional insight from Microsoft regarding this "feature" and potential remediation thereof.

    Cheers!

    Wednesday, February 09, 2011 5:13 PM
  • Karl,

    If it's not too much trouble, could you check to see if same issue applies when looking at calendar few months back? How far back can you go before you can no longer see past events?

    Thanks again!

    Wednesday, February 09, 2011 5:21 PM
  • It is the same issue...sometimes it will show you the current month (e.g. Feb) and the next month, or sometimes you can go back one month ( I think it depends on where you are currently in the month).  Right now, I can only see all of Feb and all of March (most common scenerio) with a few exceptions from a few users who have probably updeated their calendars recently - their's I can see as specified by the GPO (only for a shortime though...they will litterally vanish before your eyes if you leave the scheduling window open long enough). 
    Karl
    Wednesday, February 09, 2011 6:51 PM
  • Karl,

    Again, thanks for your feedback. So, if you look at your own calendar (assuming your config is also affected), are you able to see *your own* calendar from say 6 months or a year ago? This is one of the "biggies" for us - as many users expect to be able to look at their events in calendar for up to one year of past events. I know that viewing someone else's calendar may be problematic, however, your own should be visible. Can you please advise?

    thanks so much!

    Cheers!

    Wednesday, February 09, 2011 11:40 PM
  • Yes, you can view your own F/B info just fine
    Karl
    Friday, February 11, 2011 9:08 PM
  • Update (8/3/2012): Looking at the recent posts here, it seems like the issue has resurfaced sometime around E2010 SP2 release, if that's what you have found to be true then please call in and report it so that it can be investigated further. These type of regressions happen sometimes as part of the software update process and we do work to address these issues when reported by our customers. At this time, I don't see any request for a fix already opened on this issue, but when I'll see that, I'll update the post. If anyone here calls in, do let me know the support case number for tracking. Thanks!

    --------------------------------------------

    Update (3/18/2011): As confirmed by MVP Walter below, this issue can be resolved by applying a fix included in Exchange 2010 SP1 RU4 Update. See KB: http://support.microsoft.com/kb/2535105 for more details.

    ----------------------------------------------------

    This is a known issue & let me provide a brief description of the issue for clarification here. This is being investigated for a fix in Exchange 2010. There is no ETA available for a fix at this moment.

    Issue: Outlook 2003 fails to retrieve the extended Free Busy info (usually for 12 months) of other users when connecting to Exchange 2010 SP1. Outlook 2003 displays only 2 months (default setting) of Free Busy info. If someone has 12 months of Free Busy info published, 2 months are displayed properly, next 10 months are displayed as ‘Free’, rest appears as hash marks (‘no info available’). This is a problem especially when trying to book heavily utilized resources (like Conf. Rooms).

    Workarounds are to use Outlook 2007/Outlook 2010 or Exchange 2010 OWA.


    Sr. Program Manager, Product Quality, Exchange Client Access Server

    Friday, March 18, 2011 1:11 AM
    Moderator
  • HI,

     

    I am having similiar issue.  outlook 2003 users are intermittently seeing free/busy of other exchange 2010 free/busy schedule.  free/busy shows up for a while, than disappears.  all users are in exchange 2010.  users using outlook 2003 can not see Mac users free/busy schedule period.

     

    tried Novak's and Tom V's suggestions, that didn't work either.  This does not occur on outlook anywhere, outlook 2007 or outlook 2010.

    we are on exchange 2010 RU2.  windows 2008 R2.

     

    raymond

     

     


    I think we have similar issues on our end to you Raymond. It is not time related. Outlook 2003 SP3 users (in cached mode) intermittently are unable to view other user's availability. Short term fix is to run the /cleanfreebusy switch on the user's profile and the availability will show again. Give it a day or so and the availability cannot be viewed again. We are on Ex2010 RTM Update Rollup 4. Has to be something public folder related because OLK 2007 and 2010 users do not have the problem.

    Desperately seeking a fix to this because we have basically tried everything on this page (deleting the FB data in PF for the user, republishing, setting OLK to publish only 2 months)

    Tuesday, March 22, 2011 6:35 AM
  • Has this issue been resolved yet?  We are seeing the same issue with Outlook 2003 and Exchange 2010 SP1 RU3.
    Friday, June 03, 2011 5:43 PM
  • I received an email stating it was being developed and was going to be part of RU5 - not sure when that will come out though.
    Karl
    Monday, June 06, 2011 1:48 PM
  • Hi,

    the Problem is solved with Rollup 4 for Exchange 2010 Sp1 and the following KB-article: http://support.microsoft.com/default.aspx?scid=kb;en-US;2535105

    hth


    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.com/blogs/wstein/
    Thursday, July 28, 2011 11:23 AM
  • I realize that the issue appears to be resolved with RU4.  We are using Outlook 2003 and Exchange 2010 SP2 and we are currently experience the same issue of only being able to view free busy information for 2 months only.   The free busy information sometimes appears for users but then disappears

    Thursday, February 02, 2012 3:59 PM
  • Actually - I'd really like to know that as well - I have this issue at SP1 RU 3 - wondering if I should go with RU4 to fix it (assuming it does) and skip SP2...
    Thursday, February 02, 2012 9:19 PM
  • Did it work with Rollup 5?  I'm curious to know if SP2 broke it again.


    Karl
    Friday, February 03, 2012 5:19 PM
  •  

    Sorry to beat a dead horse but a few questions…

    • The KB article listed seems a bit vague and doesn’t mention anything about 12 month scheduling – is that the correct fix and has anyone tried using it instead of RU4?
    • Has anyone else seen this issue after applying SP2?

    I have this issue popping up now and I’m trying to decide on the best course of action:

    RU4, RU5, RU6 or going straight to SP2…

    I’m Exchange 2010 (SP1 RU3) and Outlook 2003 – 2003 support seems a bit sketchy and I’m worried about adding new problems in while fixing this calendaring issue.

    Thanks…

    Tuesday, February 07, 2012 6:00 PM
  • Definitely go to Rollup 5 (skip 4) - I was on the original emails from MS for the debug of this issue and we got a recall on Rollup 4 and a follow up email that Rollup 5 was the real fix. 

    We have not deployed SP2 yet; however it is on my near horizon so we can disable the auto mapping feature easily, but I'm not certain if SP2 breaks the Rollup 5 fix for Free/Busy as I alluded to above.


    Karl

    Wednesday, February 08, 2012 3:55 PM
  • Issue: Outlook 2003 fails to retrieve the extended Free Busy info (usually for 12 months) of other users when connecting to Exchange 2010 SP1. Outlook 2003 displays only 2 months (default setting) of Free Busy info. If someone has 12 months of Free Busy info published, 2 months are displayed properly, next 10 months are displayed as ‘Free’, rest appears as hash marks (‘no info available’). This is a problem especially when trying to book heavily utilized resources (like Conf. Rooms).

    I have exactly this issue with SP2 installed. Is it possible that the problem was fixed in SP1 RU4 and exist in SP2 again?

    Is there any solution to this?

    We're currently planning for Outlook 2010 rollout but this will be at april or may at the earliest.

    Kind regards

    Thorsten

    Thursday, February 09, 2012 1:06 PM
  • Definitely go to Rollup 5 (skip 4) - I was on the original emails from MS for the debug of this issue and we got a recall on Rollup 4 and a follow up email that Rollup 5 was the real fix. 

    We have not deployed SP2 yet; however it is on my near horizon so we can disable the auto mapping feature easily, but I'm not certain if SP2 breaks the Rollup 5 fix for Free/Busy as I alluded to above.


    Karl


    Thanks Karl - I think I'll go will RU5 for now - I see two posts for SP2 people with the issue. Maybe RU1 for SP2 will fix it again.....
    Friday, February 10, 2012 5:49 PM
  • Here is the TechNet article on how to publish extended Free/Busy information.

    http://technet.microsoft.com/en-us/library/hh529936.aspx

    Monday, February 13, 2012 2:54 PM
  • Here is the TechNet article on how to publish extended Free/Busy information.

    http://technet.microsoft.com/en-us/library/hh529936.aspx


    Thanks Nathan....
    Monday, February 13, 2012 10:09 PM
  • For those of you having this issue with Exchange 2010 SP2 like I am,   RU1 for SP2 was just released a few days ago and apparently it's suppose to address this issue.   We have not tried it in our environment yet but are planning to.

    http://support.microsoft.com/kb/2645995

    Thursday, February 23, 2012 5:59 PM
  •  

    We went from SP1 RU3 to SP2 RU1 on Friday night…(and made the reg change as per TechNet article)

    Checked calendars immediately after the upgrade – no joy, still only showing 2 months in Outlook…

    Checked again on Monday morning – a little better, some of the resource calendars where showing up normally, but not all.

    Went into the calendars themselves and changed the calendar update time to 5 minutes and ran /cleanfreebusy to see if it would help. Seems to have cleared up the rooms I ran it on…

    So I’m not sure if it’s fixed or not – the problem was fairly random before so just checking my machine is not a good test – I’m waiting to see if people start calling in again.

    Tuesday, February 28, 2012 5:08 PM
  •  

    Not fixed for us with SP2 RU1…..

    Wednesday, February 29, 2012 7:07 PM
  • The problem is not fixed in SP2 RU1. We are actually trying to apply this registry key to see if it's change something.

    To change the amount of Free/Busy information that is displayed for mailboxes

    1. Start Registry Editor.

    2. Expand the following subkey:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft

    3. Right-click Microsoft, point to New, and then click Key.

    4. Type Excdo, and then press ENTER to name the new key.

    5. Right-click Excdo, point to New, and then click Key.

    6. Type Parameters, and then press ENTER to name the new subkey.

    7. Right-click Parameters, point to New, and then click DWORD (32-bit) Value.

    8. Type FBPublishMonths, and then press ENTER to name the new value.

    9. Right-click FBPublishMonths, and then click Modify.

    10. Click Decimal. Then, in the Value data box, type the number of months for which you want to publish Free/Busy information. For example, if you want to publish Free/Busy data for four months, type 4 in the Value data box.

    11. Click OK, and then exit Registry Editor.

    12. Restart the IIS Admin service and the Microsoft Exchange System Attendant service. To do this, type the following commands at a command prompt, and then press ENTER after each command:

      iisreset

      net stop msexchangesa && net start msexchangesa

    I will let you know if it is working.

    Best regards

    Anthony

    Tuesday, March 06, 2012 10:34 AM
  •  

    We tried that registry change after we applied SP2 RU1 and it did not work for us…

    Tuesday, March 06, 2012 4:04 PM
  • We are currently running SP2, no RU1.  Have tried the registry change without success.  We are now ready to start migrating mailboxes to Exch2010 but we wont be upgrading office for another 6 months.  We will have to delay migrating mailboxes until there is a fix for this as the F/B is heavily used within our org.

    Thursday, March 15, 2012 12:36 PM
  • We also implemented RU1 for SP2 last night and so far it doesn't look like it made any difference to the free/busy, still only publishing 2 months.  We also implemented the registry key as mentioned above a couple of months ago.

    Thursday, March 22, 2012 3:49 PM
  • Guys, I'm having exactly the same issue on SP2 RU2. What I have done as an interim solution was set the "Default Public Folder Database" to an existing Exchange 2003 PF database and that works fine.

    Wednesday, May 30, 2012 8:36 AM
  • I don't suppose there's any indications that the newly released SP2 RU3 addresses this issue?

    Bingdaddy, for what you had hoped was a quick fix....not so much. Looks like we will be keeping an Exchange 2003 PF server around for awhile.


    Friday, June 01, 2012 1:57 PM
  • Is there an update to this issue?  I am running Exchange 2010 SP2 and experiencing the problem with Outlook 2003 clients.

    From the recent posts it does not appear that RU1 for SP2 will address this.

    • Proposed as answer by relief Tuesday, June 26, 2012 11:38 PM
    • Unproposed as answer by relief Tuesday, June 26, 2012 11:38 PM
    Monday, June 18, 2012 7:41 PM
  • For my case, I have an Exchange 2003 cluster with two public folder databases. After looking through the replication setting in both Exchange 2003 PF databases I found that one PF DB has itself and the Exchange 2010 PF DB as replicas. Once itself was replaced by the other Ex2003 PF databases, the problem was resolved!
    Tuesday, June 26, 2012 11:42 PM
  • Is there still no solution for this issue? We updated our Exchange 2010 to SP2 and after that it seems like we got this problem back with free/busy not showing after 2 month in Outlook 2003. /Petra
    Friday, July 13, 2012 8:10 AM
  • Hi,

    Whe have the same issue, installed Exchange SP2 Rollup 3. but that did not solve the problem

    Friday, July 20, 2012 7:21 AM
  • Hi all,

    we figured the same behavior at several customer sites, is it going to be fixed in RU4 for SP2?

    Regards

    Andreas

    Tuesday, August 28, 2012 7:27 AM
  • Hi M. Amir,

    We are experiencing the same issue here with Exchange 2010 SP2 RU4. I already opened a case at TechSupport. They could not solve the problem and now closed the case, saying it is a known bug, but it will never be fixed, because it only affects Outlook 2003 clients, and they are already in “extended support lifecycle”. In my opinion, it is a bug in Exchange Server 2010, not in Outlook 2003. And basically Outlook 2003 is supported with Exchange 2010, so it has to work! Do you see another possibility to bring MS to fix the problem?

    Regards

    Fabian

    Thursday, October 11, 2012 3:54 PM
  • Try this:

    Open Regedit and go to:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\ParametersSystem

    On the Edit menu, point to New, and then click Dword Value.

    Type DisableAvailabilityServiceCalls, and then press Enter. Add a value of '1' and click OK.

    Restart Outlook. Doesn't require any Exchange services to restart. Note that the other FBPublishMonths registry key needs to be in place.

    Credit to julientr2 for this.

    • Proposed as answer by officerbrobee Thursday, August 01, 2013 12:50 PM
    Thursday, August 01, 2013 12:27 PM