none
Can send email but not receive

    Question

  • I can send email fine apparently from my domain, but when someone tries to send me an email they get a bounced email stating:

    ----------------------------------------------------------------------
    This is the mail system at host smtprelay01.hostedemail.com.

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to postmaster.

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The mail system

    <rscasb@ourdomainname.com>: host
    ourdomainname.com.s5b1.psmtp.com[64.18.4.13] said: 554 No relaying
    allowed - psmtp (in reply to RCPT TO command)
    ----------------------------------------------------------------------

    When I ping mail.ourdomainname.com it pings our external IP

    My A record is:
    mail x.x.x.x (where x.x.x.x is our IP address)
    CNAMES
       
       
       
    imap imap.secureserver.net
    MX
    Priority 0, Host @, x.x.x.x (where x.x.x.x is our IP address)
         
    Priority 30, Host @, ourdomainname.com.s5b1.psmtp.com

    I should add this is a new install of Exchange 2007, so there may be a setting I overlooked.  I assumed it would be the Receive Connectors, but it all looks good to me.
    • Edited by repnescasb Friday, July 31, 2009 8:54 PM
    Friday, July 31, 2009 8:46 PM

Answers

  • Hi,

    Please make sure the following things are configured:

    - accepted domains, domains listed here will be accepted by the mailserver
    - receive connector, which accept anonymous mail, the default connectors won't accept mail from externally

    Regards,

    Johan
    blog: www.johanveldhuis.nl
    • Marked as answer by Mike Shen Monday, August 10, 2009 2:23 AM
    Sunday, August 02, 2009 8:56 PM