none
Outlook 2010 stopped retaining address autocomplete data

    Question

  • I know that this has been asked before and I apologize in advance for opening up the topic again. None of the answers I've found have brought much clarity to the issue.

    My problem is simply that, for a certain user (who of course happens to be the executive director), Outlook 2010 no longer retains address autocomplete information. It used to work but doesn't anymore. And naturally, he really likes this feature and we look really stupid for not being able to get it working for him again. He is a standard domain user on a Windows 2008R2 domain, and we are running Exchange 2010 SP1.

    I understand that Outlook 2010 no longer uses .nk2 files, but rather stores the data in some hidden "thing" in the user's mailbox on the server. I've read that this "thing" is either a hidden file, a hidden folder or a hidden message. I have no idea which, nor how or even if it is possible to examine it. I've also read that data is read from this hidden mailbox "thing" on Outlook startup, into the local AppData "Stream_Autocomplete_blahblahblah.dat" file, and that as new entries are added they somehow get saved back to the hidden server "thing" as well as the new Suggested Contacts folder. Beyond that, the exact details to me are pure voodoo and I have not found documentation of how it all really works.

    We've tried creating a new mail profile for him on his own machine. We've tried creating mail profiles for him on other machines. Settings in Outlook have been double and triple checked. In every case, autocomplete data is retained for the duration of a single Outlook session but the size of the local "Stream_Autocomplete_blahblahblah.dat" file remains zero bytes. After Outlook restarts, the accumulated autocomplete data is lost. Other users with Outlook 2010 don't have the issue.

    Anyone have any ideas, or at least sharing the pain? I really don't want to rebuild his mailbox from scratch just for this, but that is kind of looking like the next step. Thanks alot.

    Tuesday, September 28, 2010 4:30 PM

Answers

  • A solution to this issue has been reached. It all revolves around the Stream_Autocomplete file. We renamed the existing, zero-byte file that would not update with new entries, then copied a different Stream_Autocomplete file with valid data to the location and renamed it with the same guid-ending that the zero-byte file had. Upon restarting Outlook 2010, we tested adding new entries by composing and sending dummy messages. These new auto-complete entries then persisted across Outlook restarts.

    Details of the behavior of this mechanism as we observed it are as follows:

    When new contacts are encountered by composing and sending a message, they are added to both Suggested Contacts and the Stream_Autocomplete data file. While Suggested Contacts are updated immediately, the Stream_Autocomplete file is not updated until Outlook exits. This data must then also be copied to the mysterious "hidden location" in the user's mailbox on the server, because the Stream_Autocomplete data file updates itself automatically when the same user logs on to a different machine and mail profile, presumably from the server copy.

    I can say with some conviction, after observing changes in the file size of Stream_Autocomplete and the behavior of the mechanism under different circumstances, that there is no link between Suggested Contacts and Stream_Autocomplete other than when a new contact is first encountered by sending a message and then added to both locations. If a single entry is deleted from the autocomplete cache, the same entry (if it exists) is not deleted from Suggested Contacts, and vice-versa. Furthermore, clicking Empty Auto-Complete List in Outlook Mail Options completely deletes the Stream_Autocomplete file, while Suggested Contacts remains intact. If the option to Use Auto-Complete List is still enabled, a brand new Stream_Autocomplete data file is generated the next time Outlook exits, with a different guid ending than the one that was deleted. In retrospect it is quite possible that simply emptying the auto-complete list might have solved our original issue, since it generates a fresh new Stream_Autocomplete data file.

    In conclusion, it's my opinion that Suggested Contacts is being erroneously depicted as one in the same as the auto-complete cache in many articles, blogs and forums describing the way the new mechaism works in Outlook 2010. In our observation, Suggested Contacts is NOT the mailbox storage location for the auto-complete cache, nor is it any kind of "window" into the cache. Entries exist in both places only because they are initially added to both by composing a message to a new, unknown contact. After that, entries can be independently deleted from either place and there is no further synchronization between them. Therefore, any issues with auto-complete not working in Outlook 2010 need to focus on what's going on with the Stream_Autocomplete data file, not Suggested Contacts.

    • Marked as answer by cyborganic Friday, October 01, 2010 6:43 PM
    Friday, October 01, 2010 6:43 PM
  • I had this issue with one client for days now, searching another Microsoft blog.  When I found this solution, all I did was click the "Empty AutoComplete List", close and reopen Outlook and the function started to work again.  No other solution worked, including creation of a new Profile.  I am not able to locate the stream_autocomple.dat file, even on my machine.  Can anyone provide me with the complete path?

    Thanks,

    Pags99


    RDPagniniSr
    • Marked as answer by cyborganic Wednesday, November 02, 2011 9:50 PM
    Friday, April 08, 2011 8:27 PM
  • I had a client with a corrupt Stream_Autocomplete data file that was not retaining data and had tried many solutions. The only one that worked was to find a working Stream_Autocomplete data file and replace the corrupt one with this.

    This Answer worked for me.

    To solve the problem I done the Following:

    1. Copied the name of the clients  Stream_Autocomplete data file to a text file.
    2. Deleted the clients  Stream_Autocomplete data file
    3. Copied the  Stream_Autocomplete data file from another users workstation
    4. Pasted the  Stream_Autocomplete  data file into the clients roaming folder
    5. Renamed the new  Stream_Autocomplete data file with the name of the previous file that had been deleted
    6. Disconnected the network and sent an email to the appropriate contacts
    7. Delete that email and close outlook
    9. Reconnected the network
    8. Open outlook and the email addresses will still be stored in the new data file.

    Note: the stream data file is found at C:\Users\%userprofile%\AppData\Local\Microsoft\Outlook\RoamCache
    Note2 : the clients autocomplete is populated with the other users data and should be cleared

    • Marked as answer by cyborganic Wednesday, August 29, 2012 10:39 PM
    Thursday, August 16, 2012 2:31 AM
  • the complete path is C:\Users\%userprofile%\AppData\Local\Microsoft\Outlook\RoamCache

    • Marked as answer by cyborganic Friday, January 06, 2012 11:58 PM
    Friday, April 22, 2011 10:03 PM
  • Started in again on the issue this morning.  I've now found the following to be true.

    After clearing the autocomplete cache and watching it remove the Stream_Autocomplete<guid>.dat file. I fired up a new email put my entire global address book into the To: field.  Exited out and did not save the message.  Exited Outlook.  Reopened Outlook, autocomplete does NOT work, and Stream_Autocomplete<guid>.dat is not recreated on that exit.  I also tried to save the email as a draft to see if that would trigger the file creation, this also did not work.

    Now, what did work is actually sending emails.  I actually sent to 3 test addresses.  Exited, noted that the Stream_Autocomplete<guid>.dat file was created.  Opened Outlook and the 3 test addresses I entered appeared as autocomplete addresses.  Attempting again after the file was created and known to be working to just add my GAL to the To: field and exiting out and not saving the email, exiting outlook and reopening it, still none of these addresses were saved, ONLY the ones I sent to.  I also attempted to send myself some emails from two other test addresses, senders are also not included in any autocomplete functionality.

    So I'll have to argue with what I've read on how this file is SUPPOSED to work.  It only retains people you've actually sent to, that's it.

    • Proposed as answer by atomicant_au Wednesday, August 03, 2011 2:09 AM
    • Unproposed as answer by atomicant_au Wednesday, August 03, 2011 2:10 AM
    • Marked as answer by cyborganic Friday, January 06, 2012 11:59 PM
    Thursday, April 28, 2011 2:56 PM
  • Hi Guys I have come across this issue and the person that said you have to actually send the email to get it to add the address to a newly created file is correct. I ended up using NK2edit to import all my address book back into the stream_autocomplete dat file. I know the program is called nk2edit but it works fine with the outlook 2010 version and update th dat file.

    Procedure

    close Outlook
    Delete stream_autocomplete dat file (make a backup just in case)
    Reopen outlook send one test email (check the dat file increases in size)
    Cloce outlook
    Run NK2edit import you outlook contacts from any address book you like
    save and overwrite exisiting dat file
    Open outlook and use a fully populated autocomplete list.

    Sohail

    • Marked as answer by cyborganic Wednesday, November 02, 2011 9:49 PM
    Thursday, October 13, 2011 1:58 PM
  • 1.Close Outlook

    2. Delete stream_autocomplete dat file (make a backup just in case) File is located

     C:\Users\%userprofile%\AppData\Local\Microsoft\Outlook\RoamCache

    3. Close outlook

    4. Run NK2edit program import you outlook contacts from any address book you like.

    5. if on a domain it will pull your global address book.

    6. Save and overwrite existing dat file

    7. Open outlook and use a fully populated auto complete list.

    Sohail

    Folks this should be stickied as being a  Fix

    download NK2edit program from a trusted site

    In the users profile follow the steps above. i added some information

    • Marked as answer by cyborganic Friday, March 09, 2012 5:04 PM
    Thursday, March 08, 2012 9:44 PM
  • I had the exact same issue with a user.  I sent an email with the instructions listed below and it resolved the issue.  

    To do this in Outlook 2010:

    1.        Go to File à Options à Mail
    2.        On the Mail screen, scroll down about ¾ to the bottom.
    3.        Click the “Empty Auto-Complete List” button.  Also, ensure that the box is checked to use the Auto-Complete List.
    4.        Close and reopen Outlook and test it again.

    Thanks for doing the leg work on this.

    • Marked as answer by cyborganic Wednesday, August 29, 2012 10:39 PM
    Tuesday, August 14, 2012 4:43 PM
  • Try this to populate your Autocomplete list.

    Create a mail account (POP) with an invalid SMTP server sending address.
    Create the email with the GAL in the To box and send it via the fake email account so that it actually cant go anywhere.

    Outlook should now think it has been sent and add all the addresses in the GAL to the Autocomplete list.
    I have a network with 2003 2007 and 2010 Outlook and was very confused for a while.

    2007 Outlook will update just by adding an address to the To field, 2010 wont until its sent, or thinks its sent!

    • Marked as answer by cyborganic Friday, January 06, 2012 11:59 PM
    Wednesday, August 03, 2011 2:15 AM
  •  

    I had the same problem after reloading one user’s laptop (Win7 32-bit) tried and searched for days for a solution that work

    What I did, I sent one to mail using his account so I can get a new Autocomplete file, and then I copied the naming for the new AutoComplete and renamed the old AutoComplete using the newly created one. Now I have the old AutoComplete with the naming of the new one, then I simply copied it to the Roaming Folder (C:\Users\%userprofile%\AppData\Local\Microsoft\Outlook\RoamCache) overwriting the new one.

    It’s like how we use to copy the .NK2 on Outlook 2007.

    • Proposed as answer by Zwakele Monday, February 20, 2012 11:26 AM
    • Marked as answer by cyborganic Friday, March 09, 2012 5:04 PM
    Monday, February 20, 2012 11:25 AM

All replies

  • It is a folder, called "Suggested Contacts". It isn't hidden at all. If you choose the Folder View you will be able to see it.

    Cached mode? If so I would say the information isn't being sent back to the server for sync.

    Does the problem follow the user to another machine?

    Simon.


    Simon Butler, Exchange MVP. http://blog.sembee.co.uk , http://exbpa.com/
    Wednesday, September 29, 2010 12:04 AM
  • Simon, thank you for your response. Yes I am aware of the Suggested Contacts folder and how to view its contents. There seems to be some ambiguity among various sources I've searched, whether Suggested Contacts and the autocomplete cache are one in the same, or whether autocomplete is a separate, hidden mechanism that draws from Suggested Contacts. I've seen it described both ways.

    For the user in question, Suggested Contacts is populated with entries. Ctrl+K name lookup works and will return matching entries from Suggested Contacts, just not autocomplete. New entries continue to be added to Suggested Contacts. The problem follows the user to other machines with independently configured mail profiles, both in cached mode and live mode. Autocomplete works fine for other users running Outlook 2010, so it is not system-wide.

    It's just a weird thing. Thanks again for giving it some brain cycles.

    Wednesday, September 29, 2010 6:34 PM
  • Hi cyborganic,

    Is there any chance the user disable the Autocomplete in Outlook 2010?

    File->Options->Mail->Send messages->Use Auto-Complete List to suggest names....


    Frank Wang
    • Proposed as answer by MoGerTang Wednesday, January 30, 2013 7:22 AM
    Friday, October 01, 2010 9:25 AM
  • Hi Frank, no sorry, that isn't it. I've double-checked that the option is enabled in Outlook 2010.

    My hunch now is that the mechanism that synchronizes between Suggested Contacts and the Stream Autocomplete file is somehow broken for this user. I'm going to try using the mailbox import and export tools to bring the user's mailbox contents into a new account to find out if the problem follows. Will report back.

    Friday, October 01, 2010 3:59 PM
  • A solution to this issue has been reached. It all revolves around the Stream_Autocomplete file. We renamed the existing, zero-byte file that would not update with new entries, then copied a different Stream_Autocomplete file with valid data to the location and renamed it with the same guid-ending that the zero-byte file had. Upon restarting Outlook 2010, we tested adding new entries by composing and sending dummy messages. These new auto-complete entries then persisted across Outlook restarts.

    Details of the behavior of this mechanism as we observed it are as follows:

    When new contacts are encountered by composing and sending a message, they are added to both Suggested Contacts and the Stream_Autocomplete data file. While Suggested Contacts are updated immediately, the Stream_Autocomplete file is not updated until Outlook exits. This data must then also be copied to the mysterious "hidden location" in the user's mailbox on the server, because the Stream_Autocomplete data file updates itself automatically when the same user logs on to a different machine and mail profile, presumably from the server copy.

    I can say with some conviction, after observing changes in the file size of Stream_Autocomplete and the behavior of the mechanism under different circumstances, that there is no link between Suggested Contacts and Stream_Autocomplete other than when a new contact is first encountered by sending a message and then added to both locations. If a single entry is deleted from the autocomplete cache, the same entry (if it exists) is not deleted from Suggested Contacts, and vice-versa. Furthermore, clicking Empty Auto-Complete List in Outlook Mail Options completely deletes the Stream_Autocomplete file, while Suggested Contacts remains intact. If the option to Use Auto-Complete List is still enabled, a brand new Stream_Autocomplete data file is generated the next time Outlook exits, with a different guid ending than the one that was deleted. In retrospect it is quite possible that simply emptying the auto-complete list might have solved our original issue, since it generates a fresh new Stream_Autocomplete data file.

    In conclusion, it's my opinion that Suggested Contacts is being erroneously depicted as one in the same as the auto-complete cache in many articles, blogs and forums describing the way the new mechaism works in Outlook 2010. In our observation, Suggested Contacts is NOT the mailbox storage location for the auto-complete cache, nor is it any kind of "window" into the cache. Entries exist in both places only because they are initially added to both by composing a message to a new, unknown contact. After that, entries can be independently deleted from either place and there is no further synchronization between them. Therefore, any issues with auto-complete not working in Outlook 2010 need to focus on what's going on with the Stream_Autocomplete data file, not Suggested Contacts.

    • Marked as answer by cyborganic Friday, October 01, 2010 6:43 PM
    Friday, October 01, 2010 6:43 PM

  • So here's a twist...

    I have the same "autocomplete not saving/sticking after outlook is closed" problem on two machines but only half of the problem.  Both machines can remove pre-existing autocomplete entries using the little "x" next to the suggestion and the removal sticks when outlook is closed.  (You can actually watch the Stream_Autocomplete file decrease in size when outlook is closed.)  However, any newly resolved autocomplete address entries don't save when outlook is closed (The Stream_Autocomplete file does not change.).  Neither computer has any problems at all resolving names from contacts or the GAB and both have autocomplete enabled.  If I delete or rename the Stream_Autocomplete file, the next time Outlook is opened a new one is generated (I'm assuming populated from exchange?) with any removed entries still removed. 

    Computer 1 is Win 7 x64 / Clean install of Office 2010 fully updated / ForFront CS / exchange setup (cached) / iTunes NOT installed.
    Computer 2 is Win 7 x64 / Upgrade install of Office 2010 from 2007, fully updated / ForFront CS / exchange setup (non-cached) / iTunes installed.

    I've tried turning autocomplete on/off, clearing the autocomplete cache, uninstalling/reinstalling office, renaming/deleting the Stream_Autocomplete.dat file, disabling/re-enabling add-ins, uninstalling office updates.  Nothing has changed the behavior at all.  Both of these computers appear to have worked at some point but then stopped working.

    So, in short, they can add and remove autocomplete entries all day long but when outlook is closed, removed entries stick but new entries don't.  What gives?  If outlook can remove existing autocomplete entries, why then can it not add new entries?

    Thanks in advance for any suggestions!
    P.S. Exchange server is 2k7.

    Saturday, November 13, 2010 9:57 PM
  • I have users experiencing the exact same problems mentioned above.

    Auto-complete only works from session to session.

    The problem seems to follow the user from computer to computer.

    We used NK2edit to add their suggested contacts to the cache file and that has kick started it working again.

    • Proposed as answer by David_DPS Thursday, December 09, 2010 3:30 AM
    Wednesday, November 17, 2010 9:22 PM
  • I was able to get the autocomplete to work for a one of my users having this issue

    Moved all the files from AppData/Local and AppData/Roaming to the desktop

    Created new profile in Mail Control Panel

    Once Outlook started, autocomplete was pulling names, even though this was the first use of this profile.

    Thursday, December 16, 2010 10:22 PM
  • Any consensus yet on what the solution to this problem is? It looks like just touching the "stream_autocomplete .dat" file kickstarts things, whether that be with NK2edit or by moving the file and creating a new profile. I'm guessing Microosft has no clues yet.
    Russ Valentine
    Monday, January 10, 2011 11:39 PM
  • I just want to say that this solution worked GREAT!  I've been putting up with this issue for weeks while casually searching for an answer.  Simply used the Empty Auto Complete, which deleted the Stream_Autocomplete file, closed Outlook, restarted, typed an address, closed again, and the autocomplete worked as normal.  THANKS!  This wasn't a big enough problem to make me want to rebuild but it sure is nice to have it back.
    Friday, February 04, 2011 8:31 PM
  • Marvellous, I would just like to state my appreciation of this solution.  I had the same problem as described by cyborganic and it was solved by gathering a valid Stream_Autocomplete file and renaming it.  The Outlook client then updated happily and whats more it solved it on any other machine that that user used Outlook on.

     

    Matt

     

    Tuesday, February 08, 2011 1:19 AM
  • I had the same problem on Outlook 2010 32 bit. Used nk2edit to add from mailbox recipients. Then saved the *.nk2 replace * with outlook profile name eg. Outlook.nk2 and save it to AppData\Local\Microsoft\Outlook. Now open outlook with switch Outlook.exe /importnk2. Autocomplete should work again and the *.nk2 file can be deleted.
    Thursday, February 10, 2011 12:29 AM
  • Thank you, Cyborganic. Deleting that file from %userprofile%\appdata\local\microsoft\outlook\roamcache worked for me too, although miine wasn't 0 kb. It was 80 kb and apparently preventing Outlook from closing properly as well.
    • Proposed as answer by Todd George Monday, May 20, 2013 8:56 PM
    • Unproposed as answer by Todd George Monday, May 20, 2013 8:56 PM
    Friday, February 11, 2011 7:41 PM
  • Simply emptying the auto-complete list worked for me.

    Thanks for the info.

    Friday, February 11, 2011 9:43 PM
  • I have been struggling with this for weeks now. 

    Tried the simple proceedure of 1.  Empty Auto Complete; 2. Exit Outlook; 3. Restart Outlook; 4. Start new message and enter e-mail address; 5.  Exit Outlook again, and it WORKS.  So simple, but it works.   I will not try to determine why it works, it just does.  

    Thanks, Thanks, and more Thanks

    Wednesday, February 16, 2011 10:10 AM
  • I've tried to find a solutiong for this for about 40 minutes now and it all came down to what you're saying here, a corrupt Stream_Autocomplete.

    What I did to solve it (crude translation to english) was open outlook 2010, file -> settings -> Mail -> Send Mail -> Empty Auto Complete List.

    I then closed outlook and made sure no outlook.exe process was running.

    Then I got the old nk2 file the user had (since we always back these up before installation of new OS, which in this case was from XP with Office 2007 til Win 7 Office 2010) and placed this file in the C:\Users\[Username]\Appdata\Roaming\Microsoft\Outlook folder and made sure the name was the same as the profile for the outlook user and with the .NK2 extention.

    Then i ran "outlook.exe /importnk2" from the Start -> search feild.

    Checked tat auto complete worked, closed outlook and checked again.

     

    Voila

     


    Lidahl
    Thursday, February 17, 2011 9:46 AM
  • I had this issue with one client for days now, searching another Microsoft blog.  When I found this solution, all I did was click the "Empty AutoComplete List", close and reopen Outlook and the function started to work again.  No other solution worked, including creation of a new Profile.  I am not able to locate the stream_autocomple.dat file, even on my machine.  Can anyone provide me with the complete path?

    Thanks,

    Pags99


    RDPagniniSr
    • Marked as answer by cyborganic Wednesday, November 02, 2011 9:50 PM
    Friday, April 08, 2011 8:27 PM
  • the complete path is C:\Users\%userprofile%\AppData\Local\Microsoft\Outlook\RoamCache

    • Marked as answer by cyborganic Friday, January 06, 2012 11:58 PM
    Friday, April 22, 2011 10:03 PM
  • Thank you... Cleared auto complete and deleted stream_autocomplete.  Now I see the file size and date updating properly when I close Outlook.  Now I just have to re-compile  two years worth of auto complete data.  Sucks that MS had to change the way auto completes where saved but of course they can never leave well enough alone :)
    Tuesday, April 26, 2011 10:21 PM
  • So I've done about every "fix" under the sun for this issue.  I've tried copying another user's NK2 file over and importing it, this worked, but any new entries were not retained, it created a .dat file and only included what was in the NK2 file. 

    I've tried clearing the autocomplete a couple different ways, via command line as well as the GUI, both of which removed the .dat file, but upon restarting outlook and trying to enter in an address, then closing it to create a new .dat file, none is created at exit. 

    I've tried uninstalling Outlook 2010, I've tried repairing it, I've tried running the PST repair tool.

    I don't know how many hours I've spent on this, but this is ridiculous as we never had this issue with Outlook 2007.  If anyone else has any other suggestions, please let me know.

    Wednesday, April 27, 2011 11:30 PM
  • Started in again on the issue this morning.  I've now found the following to be true.

    After clearing the autocomplete cache and watching it remove the Stream_Autocomplete<guid>.dat file. I fired up a new email put my entire global address book into the To: field.  Exited out and did not save the message.  Exited Outlook.  Reopened Outlook, autocomplete does NOT work, and Stream_Autocomplete<guid>.dat is not recreated on that exit.  I also tried to save the email as a draft to see if that would trigger the file creation, this also did not work.

    Now, what did work is actually sending emails.  I actually sent to 3 test addresses.  Exited, noted that the Stream_Autocomplete<guid>.dat file was created.  Opened Outlook and the 3 test addresses I entered appeared as autocomplete addresses.  Attempting again after the file was created and known to be working to just add my GAL to the To: field and exiting out and not saving the email, exiting outlook and reopening it, still none of these addresses were saved, ONLY the ones I sent to.  I also attempted to send myself some emails from two other test addresses, senders are also not included in any autocomplete functionality.

    So I'll have to argue with what I've read on how this file is SUPPOSED to work.  It only retains people you've actually sent to, that's it.

    • Proposed as answer by atomicant_au Wednesday, August 03, 2011 2:09 AM
    • Unproposed as answer by atomicant_au Wednesday, August 03, 2011 2:10 AM
    • Marked as answer by cyborganic Friday, January 06, 2012 11:59 PM
    Thursday, April 28, 2011 2:56 PM
  • I now as well have an end user with this same exact issue. Fresh clean install of Windows 7 64bit on a new HP ProBook 4720s. Fresh clean install of Office 2010 and eerytime he closes out of Outlook and reopens Outlook, the entries are gone except for a couple.

    Is there a fix yet?

    Friday, May 06, 2011 3:04 PM
  • My problem is the same.  Win 7 64-bit, Outlook 2010 as part of the Office Professional Suite.

    Auto complete has worked without a problem until a few days ago.  It just stopped working.  No prior problems, updates, or any other issue, it just stopped working.

    I've tried every fix listed on this page with no effect.  I've even tried re-installing just to see if that helps.  Nothing.

    Is there an actual solution out there?  And why hasn't Microsoft addressed this issue.  It seems to me that it's happening to more people than should be expected from a minor glitch. 

    So, is a there a fix out there that works?


    Friday, July 29, 2011 4:45 PM
  • This solution has worked for me as well. Thanks Pags99!

    Saturday, July 30, 2011 1:09 PM
  • THIS WORKS PERFECTLY!!! Sorry for the caps, just finally resolved the issue with this very simple solution after dealing with this problem for weeks!!! Thanks to PCLee23!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    Saturday, July 30, 2011 9:56 PM
  • Try this to populate your Autocomplete list.

    Create a mail account (POP) with an invalid SMTP server sending address.
    Create the email with the GAL in the To box and send it via the fake email account so that it actually cant go anywhere.

    Outlook should now think it has been sent and add all the addresses in the GAL to the Autocomplete list.
    I have a network with 2003 2007 and 2010 Outlook and was very confused for a while.

    2007 Outlook will update just by adding an address to the To field, 2010 wont until its sent, or thinks its sent!

    • Marked as answer by cyborganic Friday, January 06, 2012 11:59 PM
    Wednesday, August 03, 2011 2:15 AM
  • I agree that works perfect, but it solves only one incident, but problem is not solved. Because it repeats again in my case after week or month. That is the problem. The question is - what causes that, how to prevent it again in future? Ok, I can every time Empty Auto-Complete list, but it maddens. How to restore that lost list? Any ideas?
    Thursday, August 04, 2011 7:11 AM
  • I have two users of 25 with this problem.  We did the clear autocomplete and removed the roamcache.  This solution worked for 5 days, user #1 now reports his nicknames are gone again.

    Seems like it is just a matter of time before the remaining 23 users are affected.

    All 25 users have Win7 32bit, Office 2010, and we use Exchange 2003.  Remaining 300+ users still on XP - Office 2007.  Replacing machines daily.  UGH!!!

    When/if this hits our CEO, all hell will break loose and she will demand to get Bill Gates on the phone. 

    Looking for a permanent solution.  Microsoft are you listening?


    Wednesday, August 10, 2011 4:23 PM
  • I am in the same position as dmac_CA.   2 of my users are afflicted by the Autocomplete disappearing for no apparent reason.   One of them is the president of my company and he NEVER puts people into his contacts, just relies on the auto-complete.   I opened a ticket w/ my corporate office, who forwarded it on to Microsoft Online services, whom hosts our email, and their solution was to reset the autocomplete cache.   This is not acceptable.   I am about to recommend that my users stop using Outlook and Microsoft online and just forward their exchange accounts to their gmail accounts.   This is absolutely ridiculous. 
    Wednesday, August 17, 2011 7:06 PM
  • Let's all agree that Outlook 2010 autocomplete/autosuggest is flakey.

    One of the first things to check for is iTunes.

    There are known issues with the iTunes add-ins corrupting PST files and keeping Outlook from closing properly.

    Whatever the prettiness of their hardware, when it comes to Windows software, the boys from Cupertino can't code their way out of a paper bag.

    If your users are having to use Ctrl-Alt-Del and the task manager to kill Outlook, you are going to have problems.

    That is the first question to ask--"Have you used Task Manager to kill Outlook?"  If the answer is "yes," you have your immediate cause.

    Now, you have to hunt down what is hanging Outlook.

    Turn off ALL add-ins to start with, and turn them back on selectively, until you've identified the evil.

    As I said, iTunes is evil.  Definitely turn off all Apple-related Outlook add-ins to start


    Nick
    Tuesday, August 30, 2011 3:31 PM
  • i also face this problem for few of my users. after test and try for more than 2days i found the solution for this issue, where actually is very simple and easy. what you need to do is create new personal folder and set as default (replacing the current personal folder) after that start move email in current personal folder to new default personal folder till finish, remove the personal and restart the outlook. problem is SOLVE..

     

    Tuesday, September 06, 2011 7:33 AM
  • The problem was, the .pst file was not stored in the typical location user/appdata/local/microsoft/outlook so I moved the .pst file to that location and it works like a charm!

    The Micro Geek!

    09/18/11


    Sunday, September 18, 2011 2:30 PM
  • I had the same problem... File, Options, Mail, Send, Empty Auto Complete, closed Outlook, restarted, typed an address, closed again, restarted Outlook and there it is.  Perfect.. Thanks!

     

    Sunday, September 25, 2011 6:56 AM
  • Perhaps a more simple way to populate your Autocomplete list after you have emptied it:

    Compose a mass email with every contact in the BCC field (i recommend the BCC field just in case you accidently send this you wont be revealing everyone's email address).  Do this by clicking on the BCC button and shift-rightclick all of the names.  Now, before you hit the send button, make sure that you are disconnected from all wired and wireless networks.  Now hit send. The message will go to your draft folder.  To Outlook this is the same as sending the message.  Next, Delete the message from the draft folder so that it doesn't send when you restore your network connection.  This should put every contact back on your autocomplete list and it only takes a minute to do.

    Wednesday, September 28, 2011 1:47 AM
  • Same issue with one of my Office 2010 Home and Business Outlook users.

    Tried all the fixes suggested here.

    Eventually had to create a new profile with clean PST files and then import from the old PST files.

    Definitely one Microsoft need to get fixed!!!

    Thursday, October 06, 2011 3:55 PM
  • Hi Guys I have come across this issue and the person that said you have to actually send the email to get it to add the address to a newly created file is correct. I ended up using NK2edit to import all my address book back into the stream_autocomplete dat file. I know the program is called nk2edit but it works fine with the outlook 2010 version and update th dat file.

    Procedure

    close Outlook
    Delete stream_autocomplete dat file (make a backup just in case)
    Reopen outlook send one test email (check the dat file increases in size)
    Cloce outlook
    Run NK2edit import you outlook contacts from any address book you like
    save and overwrite exisiting dat file
    Open outlook and use a fully populated autocomplete list.

    Sohail

    • Marked as answer by cyborganic Wednesday, November 02, 2011 9:49 PM
    Thursday, October 13, 2011 1:58 PM
  • This worked like a charm! 
    Wednesday, October 26, 2011 1:05 AM
  • sullym6,

     

    your procedure works perfect.

    Make sure you are under: C:\Users\(yourname)\AppData\Local\Microsoft\Outlook\RoamCache

    It fixed my problem.

     

    Peter

    Thursday, October 27, 2011 8:58 PM
  • uak... tried File, Options, Mail, Send, Empty Auto Complete, but it REALLY did what it says it deleted the Autocomplete list !! its all gone...

    Any suggestions how to get it all back ?

    please...

    Monday, November 28, 2011 10:04 AM
  • Yes, it worked for me. You just have to re-build the list from scretch.
    Thursday, December 01, 2011 4:50 AM
  • Has anyone noticed that, along with losing auto-complete, rules are also lost (such as what is junk mail, what should automatically go to which folder, etc.)?  Can anyone point to the connection between the two, which might suggest a way to overcome the problem?
    Tuesday, December 06, 2011 3:36 PM
  • Having little to lose, I did the same as PCLee23 did...and I lost everything I've been building up for weeks. The challenge is, it doesn't even remember things I did the SAME DAY some of the time, and other times, it auto-completes.  Strangely, sometimes it's the very same person to whom I sent an original or reply email.  That makes no sense to me at all. 

    I hoped that just emptying the Auto Complete file would help.  Let me caution those of you considering this deceptively easy option: it may not work. 

    I can only think it's one of my add-ins. Although I have only added in consciously two things (InfusionSoft and TimeTrade), it loads 12 when I turn it on. 

    I am so weary of trying to solve this problem of the auto-complete!  Surely there's an answer somewhere in the world!

    Friday, December 30, 2011 1:11 AM
  • Yes, this happened to me when I deleted (per above ideas) my Autocomplete file, too.  Prior to that, though, I noticed that even though one obnoxious address was clearly listed in my Blocked Senders list, Outlook still merrily delivered dozens of messages from that wordpress email anyway every day (new user registration notifications - spammers coming at me from a half dozen WP sites). 

    Perhaps now it will work properly and not break again!  It does seem evident that one must rebuild the entire Autocomplete file after deleting it, though, which will take months to accomplish in my case.  Groan!

     

    Friday, December 30, 2011 1:21 AM
  • I all,

    I had the same issue.
    I solved that by using this command

    run:
    Outlook.exe /CleanAutoCompleteCache

    Now, Outlook can learn new contacts now

    Julien

    • Proposed as answer by Zwakele Monday, February 20, 2012 11:21 AM
    • Unproposed as answer by Zwakele Monday, February 20, 2012 11:21 AM
    Thursday, February 09, 2012 12:49 PM
  •  

    I had the same problem after reloading one user’s laptop (Win7 32-bit) tried and searched for days for a solution that work

    What I did, I sent one to mail using his account so I can get a new Autocomplete file, and then I copied the naming for the new AutoComplete and renamed the old AutoComplete using the newly created one. Now I have the old AutoComplete with the naming of the new one, then I simply copied it to the Roaming Folder (C:\Users\%userprofile%\AppData\Local\Microsoft\Outlook\RoamCache) overwriting the new one.

    It’s like how we use to copy the .NK2 on Outlook 2007.

    • Proposed as answer by Zwakele Monday, February 20, 2012 11:26 AM
    • Marked as answer by cyborganic Friday, March 09, 2012 5:04 PM
    Monday, February 20, 2012 11:25 AM
  • Have got to the point where i have got the auto complete to work (by deleting the auto stream file) and now need to repopulate my list.  Creating a 'To all' message and deleting it won't work, only sending the message will save the addresses.

    Tried this trick (add an account with a bogus SMTP Server) but can't get it to work - when you change the SMTP server address on an account Outlook tests the connection by sending a test message so an invalid address will fail the sending test, meaning Outlook won't save the address change :(


    • Edited by Da Swede Friday, February 24, 2012 12:32 PM
    Friday, February 24, 2012 10:56 AM
  • 1.Close Outlook

    2. Delete stream_autocomplete dat file (make a backup just in case) File is located

     C:\Users\%userprofile%\AppData\Local\Microsoft\Outlook\RoamCache

    3. Close outlook

    4. Run NK2edit program import you outlook contacts from any address book you like.

    5. if on a domain it will pull your global address book.

    6. Save and overwrite existing dat file

    7. Open outlook and use a fully populated auto complete list.

    Sohail

    Folks this should be stickied as being a  Fix

    download NK2edit program from a trusted site

    In the users profile follow the steps above. i added some information

    • Marked as answer by cyborganic Friday, March 09, 2012 5:04 PM
    Thursday, March 08, 2012 9:44 PM
  • Hi all

    just resolved this issue very quickly what i done was download a nk2 editor, then ran it, it opens in the location on the nk2 file that is being used, i then done "Open" and went to the original outlook NK2 file and opened it, then done a select all and copy.

    closed the nk2 editor and reopened it and its now back to the location its using, then simply paste the missing email addresses into this file and all email addresses are there and working like a charm :)

    what i dont understand is why the location of outlook nk2 file changed working one time ok next day all addresses were lost and outlook was reading the "Auto complete" bit in the RoamCache folder.

    but it now working so took 5 mins to resolve, you can get the NK2 editor from download.com

    Cheers all


    Tuesday, March 20, 2012 1:39 PM
  • What we did was the following we went to the settings and cleared the autocomplete list. saved it, turned it off, saved it, and turned it back on. This worked without dealing with profiles.
    Tuesday, May 08, 2012 6:17 AM
  • excellent - thanks ELHooligan 
    Thursday, May 10, 2012 10:46 PM
  • Many many thanks. Tried all sorts of far more complex solutions, none of which worked, and  now at last I have a really useful feature restored :-)

    Thursday, July 12, 2012 3:40 PM
  • I have a few users that are having the same problem and the fix of just deleting the stream_autocomplete file doesn't do anything for me.  The problem is that if I open an Outlook session, there are no entries in Autocomplete.  If the users sends a mail to someone, it updates and works great.  Works great until they exit Outlook and it seems to destroy the list.  The next time they open Outlook (when they come in for work the next day), they have to start all over with no one in the autocomplete list.  It resets itself when you exit Outlook.

    I've tried deleting it, emptying it with the UI, and nothing works.  We are exiting Outlook cleanly.  Does anyone have a problem with the list being cleared upon exiting Outlook?

    Friday, July 20, 2012 2:19 PM
  • The Deep North - Yes, I have one user who is experiencing the same exact issue.  Autocomplete works during a single session, but upon closing out and starting up a new session. all autocompleted addresses disappear.  I've checked the user's stream_autocomplete file and it's at 0 KB.  Have attempted the same troubleshooting techniques to no avail.

    Monday, July 23, 2012 5:12 PM
  • I tried a few of the suggestions here, unfortunately none of them fixed the issue. I ended up trying a different approach to the suggestion of copying the Stream_Autocomplete_XXXXXX.dat File.

    Started by copying the Stream_Autocomplete_XXXXXX.dat File on to a safe place (Better safe than sorry).

    While Outlook was running, I emptied the Autocomplete List by going to File – Options – Mail – Send messages and clicking in the “Empty Auto-Complete List” button, also while in there, Unchecked the “Use Auto-Complete List to suggest names when typing in the To, Cc, and Bcc lines” check box, then clicked Ok. I happened to have the window open where the Stream_Autocomplete.dat file was, and it disappeared right after I went through the above procedure. Last, I closed Outlook.

    Opened Outlook again and went to File – Options – Mail – Send messages and checked the “Use Auto-Complete List to suggest names when typing in the To, Cc, and Bcc lines” check box. This created a new Stream_Autocomplete.dat file.

    I tested the auto complete by creating emails and closing Outlook and it worked.

    Thank you all for your postings, they make a difference.


    GP

    Tuesday, July 31, 2012 10:04 PM
  • I had the exact same issue with a user.  I sent an email with the instructions listed below and it resolved the issue.  

    To do this in Outlook 2010:

    1.        Go to File à Options à Mail
    2.        On the Mail screen, scroll down about ¾ to the bottom.
    3.        Click the “Empty Auto-Complete List” button.  Also, ensure that the box is checked to use the Auto-Complete List.
    4.        Close and reopen Outlook and test it again.

    Thanks for doing the leg work on this.

    • Marked as answer by cyborganic Wednesday, August 29, 2012 10:39 PM
    Tuesday, August 14, 2012 4:43 PM
  • I had a client with a corrupt Stream_Autocomplete data file that was not retaining data and had tried many solutions. The only one that worked was to find a working Stream_Autocomplete data file and replace the corrupt one with this.

    This Answer worked for me.

    To solve the problem I done the Following:

    1. Copied the name of the clients  Stream_Autocomplete data file to a text file.
    2. Deleted the clients  Stream_Autocomplete data file
    3. Copied the  Stream_Autocomplete data file from another users workstation
    4. Pasted the  Stream_Autocomplete  data file into the clients roaming folder
    5. Renamed the new  Stream_Autocomplete data file with the name of the previous file that had been deleted
    6. Disconnected the network and sent an email to the appropriate contacts
    7. Delete that email and close outlook
    9. Reconnected the network
    8. Open outlook and the email addresses will still be stored in the new data file.

    Note: the stream data file is found at C:\Users\%userprofile%\AppData\Local\Microsoft\Outlook\RoamCache
    Note2 : the clients autocomplete is populated with the other users data and should be cleared

    • Marked as answer by cyborganic Wednesday, August 29, 2012 10:39 PM
    Thursday, August 16, 2012 2:31 AM
  • try this: http://www.msoutlook.info/question/509. usefull if yo use iTunes. it's an add-on that you must remove.

    Thursday, September 13, 2012 8:12 AM
  • Thanks for the solutions!

    What solved it for me was clearing the auto cache file>options>mail>send messages>clear auto cacheThan I repopulated the auto cache using outlook.exe /importnk2

    Worked like a charm!

    Thursday, September 13, 2012 3:41 PM
  • This was the only Solution that worked out for me. Impressive.

    Eben

    Friday, September 28, 2012 12:53 PM
  • After much aggravation trying the normal to resolve, replacing the stream_autocomplete worked.

    Thursday, October 25, 2012 2:52 PM
  • It did not work in my case.    I have a user that i have tried every fix mentioned and still the same issues persist.

    Autocomplete fails to save addresses on closing/shutdown.

    Windows 7 - 64 bit machine running Office 2010 32 bit (64 bit office is not recommended).   Fully populated Stream_Autocomplete_xxx.dat file,  yet still no autocomplete entries.

    Entries build all day, but after shutdown, reopening outlook, no more auto complete entries.

    Monday, April 08, 2013 1:20 PM
  • Yes, i have the same issue with one user, and was actually able to "break" it on another Outlook profile by trying some of the steps mentioned above.    What broke it was the clearing auto complete cache, which then deleted the Stream_Autocomplete_XXX.dat file.  Restoring this file served no purpose as autocomplete now fails on every exit of Outlook.

    Outlook is always shutting down properly, no Itunes, no other add ins for Outlook.   Tried Nk2edit and saved a new stream_autocomplete.dat file with a fully populated GAB, still no success.    Stream Autocomplete file is there, and has data but Outlook does not have a clue there are any auto addresses.

    MS Support is useless as they offer nothing more than the same options people describe here, but in some cases none of these work at all.

    I have done everything possible, recreated profiles, reimaged machine, reinstalled Outlook 2010, etc.  Same issues everytime.

    To me it seems like it is a problem with synching between the users MAPI file on the Exchange server and the Outlook OST on the user's machine.

    That is the only thing I can think of to have this problem occur daily.

    Monday, April 08, 2013 1:26 PM
  • I've noticed some discrepancies in the behavior of the Stream_Autocomplete file and for one user could not get back their autocomplete entries - nk2edit said the file was corrupt.
    For other peoples benefit however I was able to bring these back again after emptying Auto Complete Cache in Options > Mail:
    Create new Outlook message > options > delay delivery > do not deliver before: tomorrow > click the To.. button > select suggested Contacts in the dropdown address book > select all > To > OK > Send.
    Then delete the temporary message from the outbox.

    Tuesday, May 07, 2013 2:30 AM
  • Thanks for posting the detailed observations of your issue Cyborganic. I was searching for an answer for one of my users who had the same issue and was also being misdirected by many well meaning people who were thinking there was a connectionbetween the Stream_Autocomplete file and the Suggested Contacts folder and many people who had similar (but unrelated) issues who had solutions for problems that didnt quite fit my users symptoms. Your detailed observations enabled me to zero in and know that our issues were the same and your solutions were worth the time to try.

    I did, and they worked so thanks!

    Nevada Jack

    Tuesday, June 18, 2013 8:07 PM
  • Simply using the empty auto complete option worked for me, thank you.  I didn't even realise that option was there and had mucked about for ages with totally incorrect solutions talking about hidden mail folders, suggested contacts etc.

    re items being added to autocomplete list, its true they only get added after an email is sent.  And i've also noticed if you get a delivery failure message that email address is removed from the list.  which is pretty neat.

    Thursday, July 04, 2013 11:43 AM
  • A better option than creating a dummy pop mail account, is to click options tab > delay delivery for a day > 'send' the message to people in suggested contacts list etc. Then once it has been 'sent' and addresses updated to AutoComplete / Stream_Autocomplete file, delete the email from outbox.

    This is what I've done several times to remedy this.

    However for me, currently the AutoComplete addresses are lost on restarting outlook. This is the same whether on a local PC with outlook 2013 or another remote desktop server with outlook 2010 but only for this same user.

    Makes me think something in exchange or AD is the culprit..?

    Tuesday, July 09, 2013 12:35 AM
  • I solved the issue in my Outlook 2013 (had it also previously on Outlook 2010) by  using NK2 edit to import from suggested contacts and save as nk2 file. 
    Friday, October 11, 2013 1:44 PM
  • Thank you very much! It works for me (Win7 64b, Outlook 2010, Exchange) when all the other solutions didn't work.

    It was an easy solution, but worth to get the idea!

    I'll finaly get back to productive work!

    Tuesday, October 22, 2013 12:43 PM
  • Have the same issue with a user after upgrading MS Office 2010 std to Professional Pro.

    OS is Win 7 64bit.

    My problem is I can replicate the issues down to making a new nk2 file and importing it,

    but Outlook is NOT creating a new stream_autocomplete file on exit, so autocomplete is still only working from session to session.

    Atm i made a workaround with a simple shortcut running outlook /importnk2 with a fully populated nk2 file from our internal network, but that is off cause missing every personal contact out of our company's mail scope that the users have.

    Tuesday, October 29, 2013 1:02 PM
  • Hi All,

       I know it's an old thread but Outlook 2010 is still out there and being supported.  I work for an ISP and I had a user call me about this the other day - Outlook 2010, autocomplete not working.

      Doing the various delete file tricks only got autocomplete to start working in an existing session.  I had to have the user go to Control Panel, rename the existing user, create a new user account and login as that new account before Outlook started working properly.  Of course I had to show her how to copy the files out of the old profile to the new one.  (the old user had a couple GB of data on his desktop)

      The problem started when an employee left the company and they gave his computer to the replacement employee.  But instead of creating a new account on the machine they just tried renaming the existing account.  This is in a workgroup-style network not a domain.  But I think the same problem would have happened on a domain.

      I think the takeaway here is that what is causing the problem in the first place is screwed up permissions in the filesystem.  For the folks who can fix it with the clear autocomplete history button, when they delete the stream file and recreate it using that, the stream file gets created with the correct inherited permissions.  But if the profile is really screwed up then the inherited permissions are garbage so you can delete and recreate the stream file all day long and it won't fix the problem.

      And if the machine is really, really scotched then creating a new user profile will get trashed permissions.

      I would take exception with the people who claim they reinstalled windows and it didn't fix the problem.  In my world there is only ONE way to reinstall Windows - plug in a USB hard disk, copy user data files to it, boot off the CD, then DELETE ALL PARTITIONS on the disk and let the installer partition and format.  Yes that includes the manufacturers "recovery partitions" which are useless wastes of space most times. then copy the files from the USB disk back to the new system once you have installed the obligatory 130 patches (win7) or 326 patches (XP) I know a lot of techs try the shortcut of just renaming the windows directory and reinstalling windows in the existing filesystem - do this at your peril, folks!!!  Inherited permissions ahead - There Be Dragons!

    Thursday, November 28, 2013 12:54 AM
  • WORKED FOR ME: I grabbed a DAT file from a user that I would consider busy in outlook. Descent file size of 300KB told me she had populated it with lots of emails. I overwrote the newly created DAT file.

    _____________________________________________________________________________

    Before any of that I unchecked autocomplete under settings and deleted the auto....dat file from path above. I turned back on auto complete and let it generate the file again. And overwrote this with the large DAT file from another user. 

    MARK THIS .... Very useful solution.

    _______________________________________________________________________________

    This will be the first thing I look for when I migrate any users over to either exchange server or a new PC etc.

    Tuesday, December 10, 2013 3:39 PM