none
Outlook 2010 Clean Up Conversation button greyed out

    Question

  • Outlook 2010 RTM, in cached exchange mode with Exchange Server 2007.  I've set conversation view in all folders (takes some getting used to but I like it).  But in all folders and for all conversations, the Clean Up button in the Home tab Delete group is greyed out.   In Options, the "Cleaned-up items" folder had been blank, so I created a new one and set it to that; no change.  None of the messages are categorized, flagged, or digitally-signed.  Any ideas?  Thanks.

    - L

    Friday, June 04, 2010 8:20 PM

All replies

  • I'm seeing the same thing. Exchange is at 2007. Just upgrade Office from 2007 to 2010.
    Monday, June 07, 2010 11:45 PM
  • Same thing here. I see it is grayed out on non-cached profiles. My cached profile has the option on. 
    • Proposed as answer by Rob Murdoch Tuesday, March 22, 2011 12:55 PM
    Wednesday, June 09, 2010 9:18 PM
  • FYI - one of my coworkers is seeing the same thing, but another one of my peers has both 'Ignore' and 'Clean-up' buttons enabled.?. Same network, same GPO, same install/upgrade process to 2010, same backend...

    Needless to say, we envy him right now.

    Thursday, June 10, 2010 6:58 AM
  • I "found" it. Office devs are a sharp bunch. Hover over the "Clean up" button and wait....   it'll tell you why it's not working.

    For me, it was because I wasn't in cached mode. I'm not sure why that was; I upgraded from 2007, where I was in cached mode. In any case, I went to Cached mode and both "Ignore" and "Clean up" are working. :)

    Thursday, June 10, 2010 7:40 AM
  • Glad that worked for you, but I've been in Cached Exchange mode the whole time.  Just for grins I disabled that, restarted Outlook, and saw the hover message you describe.  Back into C.E. mode, the message goes away but otherwise no difference.  I think it's a bug.  Ironic that it's one of Outlook 2010's highly touted new features.   Microsoft?

    - L. 

    UPDATE: After a while (I think after I re-enabled Archiving, if that makes any sense), the Clean Up feature now works, both via the ribbon button and via the context menu for the folder.  So I think the problem is when upgrading from Outlook 2007 to Outlook 2010, in Cached Exchange Mode, Clean Up is not enabled.  Disable Cached Exchange Mode, restart Outlook, re-enable C.E. mode, restart Outlook.  Then it works.  I think.  Feel free to confirm or refute.  Thanks.

    • Edited by Langhorne Thursday, June 10, 2010 7:24 PM Update
    • Proposed as answer by Rob Murdoch Tuesday, March 22, 2011 12:57 PM
    Thursday, June 10, 2010 4:59 PM
  • I'm having this issue with a user who has "clean up" available for her profile but she's got another email account configured on her outlook and not able to use the clean up feature for that other mailbox. She's in cached exchange mode.

    any idea?

    Monday, February 18, 2013 6:13 PM