none
unknown schema extension error reported by ExBPA

    Question

  • I recently installed Exchange 2007 Servers (with SP2) on Windows Server 2008 x64 (with SP2) in my Exchange test lab. After installing the Exchange servers, I ran Exchange BPA 2.8 which found the following critical errors:
    Active Directory: The Exchange schema extensions are from an unknown version. Schema version detected is 11116
    Domain: AD Domain has an unrecognized Exchange signature. Current DomainPrep version: 11221
    Explanation given was that an eval copy of the software was used to make these changes and that an RTM version should be used instead.
    I then went to our volume licensing site and downloaded what I think is the RTM version of Exchange 2007 SP1 and reran setup /ps,
    setup /AD and setup /pd however the values do not change and I keep getting the errors when running BPA.

    Is it okay to manually modify these values using adsiedit?

    Saturday, November 14, 2009 2:38 PM

Answers

  • Sure you are using the latest ExBpa updates?  Sounds like you have an old copy that doesnt recognize the schema updates. If you run this from the EMC toolbox, be sure to check for the latest updates and that the update is successful.

    The latest ExBpa Config is 12.12.0.0.

    You can check this under Microsoft\Exchange Server\Bin\en\ExBPA.Config.xml and look for the Configuration ConfigVersion tag. You can also check the config version in the about dialog box in ExBpa.


    Do not modify any schema values. 2007 SP2 version is 14622. ( the value you reference is SP1)  See also:  http://www.cgoosen.com/2009/09/how-to-determine-your-ad-and-exchange-schema-version/
    • Marked as answer by Mkhan1135 Saturday, November 14, 2009 4:39 PM
    Saturday, November 14, 2009 3:41 PM

All replies

  • Sure you are using the latest ExBpa updates?  Sounds like you have an old copy that doesnt recognize the schema updates. If you run this from the EMC toolbox, be sure to check for the latest updates and that the update is successful.

    The latest ExBpa Config is 12.12.0.0.

    You can check this under Microsoft\Exchange Server\Bin\en\ExBPA.Config.xml and look for the Configuration ConfigVersion tag. You can also check the config version in the about dialog box in ExBpa.


    Do not modify any schema values. 2007 SP2 version is 14622. ( the value you reference is SP1)  See also:  http://www.cgoosen.com/2009/09/how-to-determine-your-ad-and-exchange-schema-version/
    • Marked as answer by Mkhan1135 Saturday, November 14, 2009 4:39 PM
    Saturday, November 14, 2009 3:41 PM
  • That did it.

    I checked the version of ExBPA (prior to update) and it was:
    application version: 2.8.7926.0
    Config file version: 2.11.17.0

    Then I did an update to ExBPA and I am now running:
    application version: 2.8.7926.0
    Config file version: 2.11.18.0

    This time the scan did not report any Active Directory related error.

    Thanks a lot..
    Saturday, November 14, 2009 4:39 PM
  • I have ExBPA Config File 2.11.18.0

    And still get the error :

    "The Exchange schema extensions are from an unknown version. Schema version detected is 14622"

    After sucessfully running all the Preps from E2K7 SP2 binaries.

    I guess because of this : http://www.cgoosen.com/2009/09/how-to-determine-your-ad-and-exchange-schema-version/ 
    14622
    Exchange Server 2007 SP2

    It's not an error to worry about ?

    Any ideas, it would be nice to get a clean ExBPA run

    Cheers,
    LM
    Friday, February 19, 2010 12:34 PM