none
Microsoft Outlook 2010 The delegates settings were not saved correctly. Cannot activate Send-on-behalf-of list. You do not have sufficient permission to perform this operation on this object.

    Question

  • I am trying to assign delegation to a user and I receive the following message.

    The delegates settings were not saved correctly.  Cannot activate Send-on-behalf-of list.  You do not have sufficient permission to perform this operation on this object.

    We are using 2010 for the server and client.  There are only specific mailboxes that this is happening for after being migrated from Lotus Notes.  The user can use their mailfile fine however it is just the delegation that appears corrupted somehow.  I'm not sure how to fix this.  I have checked the access through the security tab in ad and that looks fine.

    Any help would be appreciated.

    Monday, June 21, 2010 3:53 PM

Answers

All replies

  • Setting this registry key http://support.microsoft.com/kb/950794/en-us, (I didn't apply any patches, am running Outlook 2010 RTM) resolved the issue for me. The article is for Outlook 2007, so you have to create the entry in HKEY_CURRENT_USER\Software\Microsoft\Office\14.0 instead of 12.0 
    Monday, June 21, 2010 4:25 PM
  • Thank you that worked great.
    Wednesday, July 21, 2010 4:37 PM
  • Setting this registry key http://support.microsoft.com/kb/950794/en-us, (I didn't apply any patches, am running Outlook 2010 RTM) resolved the issue for me. The article is for Outlook 2007, so you have to create the entry in HKEY_CURRENT_USER\Software\Microsoft\Office\14.0 instead of 12.0 

    I tried this, so now I don't get this error message, but it closes the delegates box and does nothing.

    It doesn't work for me :(

     

    Any suggestions?


    Treadstone
    Wednesday, May 18, 2011 6:09 PM
  • Do you have the latest updates for Outlook installed?
    Wednesday, May 18, 2011 6:28 PM
  • I used Outlook 2007 instead, and got it to work with that.

    Thanks


    Treadstone
    Wednesday, May 18, 2011 9:52 PM
  • Bumping an old thread but I just had this issue and resolved it without the registry workaround, and it may be useful for someone else who gets this problem.

    We also had migrated from Lotus Notes. First thing that I notice was I could delegate access to my mailbox fine and I never had a mailbox on Notes.

    Quick answer is in the migration the process seems to bring across some legacy groups that have permission to SOB. Having manually trying to add a user to SOB via EMC it would fail, in the end you need to clear down SOB so its set to no one. Then the user(s) can work through the delegate wizard.

    • Proposed as answer by Theelk Wednesday, November 30, 2011 1:30 PM
    Wednesday, November 30, 2011 1:30 PM
  • I have a Citrix invironment and the users do not have outlook on their local machines. So where do you edit the registry. Do you edit the registry on the Exchange server or the three Citrix servers that the end users remote into?

    By the way I saw an older atricle that said to run a Hotfix but that also did not say where to run it.


    Matthew Stringham
    Friday, January 20, 2012 4:02 PM
  • Quick answer is in the migration the process seems to bring across some legacy groups that have permission to SOB. Having manually trying to add a user to SOB via EMC it would fail, in the end you need to clear down SOB so its set to no one. Then the user(s) can work through the delegate wizard.

    Any answer to your last part. As I also did a Migration from Exchange 2003 to 2010. Some of the users work fine and some get the same error message. Not sure if thats related or not.

    What do you mean by (SOB) I hopes it not what my wife calls me. Anyway how do you set it to no one?

     


    Matthew Stringham
    Friday, January 20, 2012 4:10 PM
  • Yes, the root cause is a far more effective solution so that administratively it always works as expected and I don't have to implement a custom registry key to each user on every possible desktop they might use.  How/where do you clear the SOB list so it is set to no one?

    I know a SOB but I'm not sure we are talking about the same one. ;-)  Please define acronymns. - Send on Behalf aka SOB


    Dale Unroe

    Thursday, March 15, 2012 11:43 AM
  • I realize this is an old post but felt I needed to respond to help my fellow brethren out.  I had the same issue "The delegates settings were not saved correctly.  Cannot activate Send-on-behalf-of list.  You do not have sufficient permission to perform this operation on this object." 

    I tried the resolutions posted here and on other sites and none worked.  I was able to resolve this however.  What caused the problem for me was a user that was previously delegated access to the mailbox had been hidden from the global address list because they are no longer employed with the company.  I removed the hidden user from the delegation list and then added the new delegate and the issue was fixed!!   

    Friday, July 27, 2012 11:42 PM
  • Hi guys,

    I am having the exact same problem but with just one user in our AD.
    He was unable to add/remove users from the delegation but was able to change the permissions for the existing users.

    I also notices that there was a user in the delegation list which was hidden from the global address list so I removed it in AD Computers and Users in the Exchange delivery options. The user still has the problem to add or remove users from the delegation list and even now if I add or remove users directly on the ADs user account he will not see the changes in his Outlook also not on a different machine with a clean outlook profile. I guess, the AD account is somehow corrupted.
    We are still using Exchange 2003 but Outlook 2010 (same problem occurred also on outlook 2003 and 2007).

    I tried all that with my own user account and everything is fine.

    Any suggestions where to look and what tools to use to analyse AD integrity?

    Thanks a lot!

    David

    • Proposed as answer by sunilsh2011 Wednesday, August 22, 2012 4:06 PM
    Monday, August 06, 2012 1:18 PM
  • I did some more digging and I solved it.

    This would be the solution:

    In Active Directory Users and Computers

    -Click on VIEW
    -Click on ADVANCE FEATURES  (this is important otherwise you won't see
    the complete list in the next steps)
    -Click on the USERS container
    -Find the problem user's account
    -Right mouse the account and click on PROPERTIES
    -Click on the SECURITY tab
    -In the top box, click on the SELF account
    -In the bottom portion of the screen make sure the READ PERSONAL
    INFORMATION  & WRITE PERSONAL INFORMATION  should both be checked for
    ALLOW

    If you can compare the permissions for 'SELF' with another user you probably should set them accordingly to be safe. I noticed that for the user where setting delegates (SOB) did not work, more than those 2 permissions were missing.

    Good luck!

    David

    • Proposed as answer by EXCH2010AE-Admin Wednesday, January 09, 2013 4:55 PM
    • Unproposed as answer by EXCH2010AE-Admin Wednesday, January 09, 2013 4:56 PM
    • Proposed as answer by SalladDazed Tuesday, June 11, 2013 12:36 PM
    Monday, August 06, 2012 6:09 PM
  • Nothing Worked for me. If everything else fails try going to ADSI Edit follow the Mailbox Container path look for name of the Mailbox right Click on Attribute Editor Scroll down to Public Delegates then select unwanted Delegates and remove.

    Good Luck this worked for me!

    Wednesday, January 09, 2013 5:02 PM
  • FixIt did not work--didn't understand why I would go to the local system registry for an issue with AD permissions.  Adding the two permissions above in AD for the user in question on the Exchange 2003 server fixed the problem immediately for me.
    Tuesday, June 11, 2013 12:37 PM
  • I was able to resolve the issue by doing the following.  Keep in mind we are in mid migration of exchange 2003 to exchange 2010.

    Okay, so I’ll fill you in on everything that I did to resolve an issue that we were working on before.

    Error:

    The Delegates settings were not saved correctly.  Cannot activate send-on-behalf-of list.

    You do not have sufficient permission to perform this operation on this object.

    Troubleshooting:

    • Further troubleshooting
    • Every user that has delegate access have active accounts and are not disabled
    • Every user that has delegate access does not have any email addresses hidden from the GAL
    • Granted resource account self full control like the other resource accounts within the Security tab in AD
    • Both resource account and user accounts are on similar servers
    • Relogged resource account, still the same error
    • User group for a public folder that is added as a delegate was not a universal group within Exchange 2010
    • Convert user group within recipient configuration to universal group within the Exchange 2010 Management Console, delegates are now able to be added to the mailbox
    Wednesday, August 28, 2013 6:50 PM
  • Thanks it worked for me. I was having same issue. After removing old user it allow me to delegates new user.
    Thursday, August 21, 2014 6:09 PM