none
Exchange Management Tools installation on Windows 7 x64

    Question

  • I can't install Exchange 2010 MT on Windows 7 x64 Enterprise and have no problem installing on Vista x64 Enterprise but not on Windows 7 x64. I get an ExSetupUI.exe stop working error if I try the wizard installation and trying the unattended installation with setup.com /R:MT i get the ExSetup.exe stop working error. I already installed II6 management components and .NET 3.5 an all the updates availables.

    Any tips? Thanks.

    Thursday, May 20, 2010 11:21 AM

Answers

  • I just finish download and try and get the same error.

    I try on a new machine that just arrive with W7x64 and no error, so the problem is with my installation in particular...

    • Marked as answer by Frank.Wang Friday, May 28, 2010 1:12 AM
    Thursday, May 27, 2010 12:15 PM

All replies

  • What happens when you try?  What is the exact error message?
    --
    Ed Crowley MVP
    "There are seldom good technological solutions to behavioral problems."
    .
    "Sebastian Valdes" wrote in message news:7505a119-6023-4436-8bb0-74f780a0385e...

    I can't install Exchange 2010 MT on Windows 7 x64 Enterprise and have no problem installing on Vista x64 Enterprise but not on Windows 7 x64. I get an ExSetupUI.exe stop working error if I try the wizard installation and trying the unattended installation with setup.com /R:MT i get the ExSetup.exe stop working error. I already installed II6 management components and .NET 3.5 an all the updates availables.

    Any tips? Thanks.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Friday, May 21, 2010 1:01 AM
  • Hi,

    Did you run the setup directly from the executables or attach the executable as an ISO?

    Please also try to run the setup as administrator.

    And did you run the setup file first time on this Windows 7 client? In other words, did you install Exchange 2007 management tool on the client ago?


    Frank Wang
    Friday, May 21, 2010 6:01 AM
  • Hi Sebastian,

    Any updates?


    Frank Wang
    Monday, May 24, 2010 1:56 AM
  • Did you verify prr-requisite for Windows 7.

    Install the Windows 7 operating system prerequisites for the Exchange management tools

    1. Install the necessary operating system components:
      1. Open the Windows Control Panel, and then open the Programs and Features applet.
      2. In the Tasks area, click Turn Windows features on or off.
      3. Select Microsoft .NET Framework 3.5.1.
      4. Expand Internet Information Services, expand Web Management Tools, and then expand IIS 6 Management Compatibility.
      5. Select the check box for IIS 6 Management Console and then click OK.

    http://technet.microsoft.com/en-us/library/bb691354.aspx#EMT7

     


    Anil
    Monday, May 24, 2010 3:13 AM
  • Hi,

    How about your question? Any updates?


    Frank Wang
    Wednesday, May 26, 2010 1:36 AM
  • Sorry the delay, we are moving our mailboxes from the old EX2003 servers to the new EX2010 DAG and that keeps me busy.

    Frank Wang, the prerequisites are meet as the document says. And I try to install from DVD (burned from the ISO) and from the decompressed ISO, and all ways get the same error allways running as Administrator, in fact I have disabled de UAC.

    Just for the record, I'm installing Exchange 2010 EMC not 2007.

     

    Wednesday, May 26, 2010 11:10 AM
  • In case someone want to see the error window:

    http://img263.imageshack.us/img263/8517/exsetupui.jpg

    Wednesday, May 26, 2010 11:22 AM
  • Hi Sebastian,

    Suggest you download the Exchange 2010 setup file to Windows 7 client directly, then extract the Exchange2010-x64.exe and run the setup.exe.

    Sometimes ISO issue may cause the error.

    Exchange 2010 RTM:

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=05741f65-2a7b-4070-879f-d74208d6171d 


    Frank Wang
    Thursday, May 27, 2010 2:37 AM
  • I just finish download and try and get the same error.

    I try on a new machine that just arrive with W7x64 and no error, so the problem is with my installation in particular...

    • Marked as answer by Frank.Wang Friday, May 28, 2010 1:12 AM
    Thursday, May 27, 2010 12:15 PM
  • I can't install Exchange 2010 MT on Windows 7 x64 Ultimate. Look this:

    ----------

    setup.com /R:TM

    The following server roles will be installed
        Languages
        Management Tools

    Performing Microsoft Exchange Server Prerequisite Check

        Exchange Management Tools Checks ......................... FAILED
         A reboot from a previous installation is pending. Please restart the system and rerun setup.

        Language Pack Checks             ......................... FAILED
         A reboot from a previous installation is pending. Please restart the system and rerun setup.


    The Exchange Server setup operation did not complete. Visit http://support.microsoft.com and enter the Error ID to find more information.

    ----------------

    Then i reboot (sometimes), run the "setup.com ..."  e show me the same error ...

    Yes.. I Installed the Windows 7 operating system prerequisites for the Exchange management tools

    Thursday, July 01, 2010 12:23 AM
  • I am having the same error installing ex2010 mgt tools on my Win7 Enterprise 64bit workstation. the registry keys do not exist on my machine - nothing to clear there. Just get the seame two errors about reboot from previous.
    Tuesday, July 13, 2010 12:58 PM
  • Hi HudsonFAS,

    I can't install Exchange 2010 MT on Windows 7 x64 Ultimate. Look this:

    ----------

    setup.com /R:TM

    The following server roles will be installed
      Languages
      Management Tools

    Performing Microsoft Exchange Server Prerequisite Check

      Exchange Management Tools Checks ......................... FAILED
      A reboot from a previous installation is pending. Please restart the

    system and rerun setup.


      Language Pack Checks             ......................... FAILED
      A reboot from a previous installation is pending. Please restart the

    system and rerun setup.



    The Exchange Server setup operation did not complete. Visit

    http://support.microsoft.com and enter the Error ID to find more
    information.


    ----------------

    Then i reboot (sometimes), run the "setup.com ..."  e show me the same

    error ...


    Yes.. I Installed the Windows 7 operating system prerequisites for the

    Exchange management tools

    Read this blog article:
    http://blog.this.at/post/2008/01/05/Exchange-2007-Service-Pack-1-installation-A-reboot-from-a-previous-installation-is-pending.aspx

    Hopefully it will help you...

    Viele Grüße
    Christian

    Tuesday, July 13, 2010 1:09 PM
  • just in case anyone is googleing this here is a batch file to install this and the pre reqs too.

    ---------------------------------------

    @echo off
    dism /online /enable-feature /featurename:NetFx3
    dism /online /enable-feature /featurename:IIS-WebServerRole
    dism /online /enable-feature /featurename:IIS-WebServerManagementTools
    dism /online /enable-feature /featurename:IIS-IIS6ManagementCompatibility
    dism /online /enable-feature /featurename:IIS-Metabase
    dism /online /enable-feature /featurename:IIS-LegacySnapIn
    dism /online /enable-feature /featurename:NetFx3
    setup.com /r:MT

    --------------------------------------

    Tuesday, May 07, 2013 9:39 AM