none
Public Folders not showing up in Outlook

    Question

  • We have Exchange 2010 SP1 UR5, Outlook 2007. 

    I can see the public folders fine in the Exchange Public Folder Tool. The Public Folder is specified in the mailbox database property's Client Settings.

    The Public Folder database file and logs are in the correct place and the PF db is mounted.

     The only thing that happened recently is that the DAG failed over mailboxes yesterday. But the pf db stayed on the same server.

    I have closed and re-opened Outlook several times. Many other users are reporting the issue as well.

    Any other ideas?
    Thanks

    Wednesday, April 18, 2012 6:33 PM

Answers

  • I did solve this. 

    It turned out that the permissions on the very top level of the public folders changed. The "Default" permission was set to "None". 

    I changed it to "Reviewer" and then everyone could see the public folders. 

    I have no idea how this changed...

    • Marked as answer by Antknee Friday, April 27, 2012 2:59 PM
    Friday, April 27, 2012 2:59 PM

All replies

  • And you can see/access via OWA without issues?

    The server which hosts the PF DB is up and running?


    Sukh

    Wednesday, April 18, 2012 7:33 PM
  • Good call. Yes they are. 

    Thanks

    Wednesday, April 18, 2012 7:35 PM
  • Can you hold the CTRL key and then right-click the Outlook icon in the system tray, Under connection status is everything connected?

    Sukh

    Wednesday, April 18, 2012 7:39 PM
  • Actually it is showing that Public Folders are connected to a mailbox server that does not host the public folders... How does that happen??
    Wednesday, April 18, 2012 7:41 PM
  • Can you replicate the PF to the other DAG node or not ?

    Sukh

    Wednesday, April 18, 2012 7:43 PM
  • Haven't tried, currently it is just on one server. I re-checked the database properties and the Client Settings tab still shows the correct pf server. 

    Wonder why my outlook client is connecting to the wrong server... and AD setting?

    Wednesday, April 18, 2012 7:47 PM
  • Having a replica on the other node will work, you can then point your DB to that local relica which gives yousome HA too.

    Sukh

    Wednesday, April 18, 2012 7:50 PM
  • Yeah, I will try it. But I can't get my Outlook client to connect to the right server. 
    Wednesday, April 18, 2012 7:53 PM
  • I should clarify... the server my Outlook is connected to for public folders is an OLD mailbox server, not one of the two new 2010 servers. 
    Wednesday, April 18, 2012 7:59 PM
  • OLD, where is this server now? Decommed? How was it decommed?


    Sukh

    Wednesday, April 18, 2012 8:09 PM
  • No, it is still up, but no users mailboxes are on it. 
    Wednesday, April 18, 2012 8:20 PM
  • Is all the content replicated between the old server and this single 2010 server?

    Is the old server 2003/2007 server?

    What if you create a new OLK profile & a new mailbox on 2010 and test?


    Sukh


    • Edited by Sukh828 Wednesday, April 18, 2012 8:22 PM Also, are all these servers in the same AD site?
    Wednesday, April 18, 2012 8:21 PM
  • Yes, this was all working fine with the 2010 servers prior to today. 
    Wednesday, April 18, 2012 8:24 PM
  • Also, are all these servers in the same AD site?

    I assume if you switch the DB's back to the 2010 server it all works?


    Sukh

    Wednesday, April 18, 2012 8:27 PM
  • Yes, we just have one site. It doesn't work with 2010 server either. IIf I switch it back to that, I get an error in Outlook that Exchange Is Unavailable when I click on public folders. 

    Of course Exchange is available. 

    Wednesday, April 18, 2012 8:29 PM
  • Is the other server 2010 too? Or just the 2?

    Sukh

    Wednesday, April 18, 2012 8:31 PM
  • Hello,

    Did you go to check the default public folder database setting on the mailbox database (which your outlook connect to)?

    If you change the default public folder database to the right public folder database, will this issue occur?

    You can go to check public folder database setting by this way:

    Exchange Management Console->Organization Configuration->Database Management->choose the database (which your mailbox on)->Properties->Client Settings

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support

    Thursday, April 19, 2012 10:22 AM
  • The old server is 2007. It's PF DB is dismounted though.

    It is seeming like a permissions issue to me. Although it looks like nothing has changed to me. Outlook will not recognize the correct PF server. 

    I may just rebuild it.... 

    Thursday, April 19, 2012 11:33 AM
  • Yes, it is set correctly. 
    Thursday, April 19, 2012 11:33 AM
  • Run an ExchBPA against the server and check

    Sukh

    Thursday, April 19, 2012 11:36 AM
  • BPA turned up nothing. 

    I created a second PF DB on the second 2010 server. I then copied over the PF DB from the first server and mounted it in the new PF on the second server. It mounted fine. But I couldn't access it until I re-added my account to the permissions.

    If I have to do this, for all users, is there a quicker way to re-apply permissions? I just see a script that will -re-add users, but you still have to specify all the users. 

    Thanks

    Thursday, April 19, 2012 4:47 PM
  • Hi

    I'm still not clear on what the issue here is with permissions?

    Can you clarify what you think it may be?


    Sukh

    Thursday, April 19, 2012 5:25 PM
  • My account was already in the PF permissions. So I re-added my user account to the new PF server permissions.  Now I can access the PFs. 

    Users still can't, even though their accounts are in the PF permissions.

    This leads me to believe if I re-add their user accounts to the PF permissions, they would be able to access them as well. However, to do that for PF and users would be quite a task to do them one-by-one.

    I am looking for a better way to re-set the permissions on the PF. 

    Thanks

    Thursday, April 19, 2012 5:33 PM
  • Can you try to dismount the PF DB and mount again?

    One way you MAY be able to do this, is by using PFDAVAdmin but you will have to play around with this to export permissions and import again.

    Can you access the PF folders for the problem users using OWA?


    Sukh

    Thursday, April 19, 2012 5:40 PM
  • I have the same issue. I have 3 mail servers part of a DAG and two public folders, one on the second server and one on the 3rd server. the one ont he 3rd server is also the GAL as well. every 3-4 days, users start getting the authentication window, and when they authenticate  outlook connects them to our regional PF databases. in our regional offices we have similar mail setup.  when i ran outlook /rpcdiag it shows that outlook cant connect to the PF database on the 3rd server, although that DB is on line and mounted. I cant find anything in the event viewer logs ....  once i reboot the 3rd server, users once again can connect to the PF on that server once again.
    Friday, April 27, 2012 8:04 AM
  • I did solve this. 

    It turned out that the permissions on the very top level of the public folders changed. The "Default" permission was set to "None". 

    I changed it to "Reviewer" and then everyone could see the public folders. 

    I have no idea how this changed...

    • Marked as answer by Antknee Friday, April 27, 2012 2:59 PM
    Friday, April 27, 2012 2:59 PM