none
550 5.7.1 Relaying denied. error

    Question

  • I just began receiving a relaying denied error on my Exchange 2003 server on SBS 2003 server.  ALL outbound emails generate this error as of about 10 am today.

    email-id on 04/22/2009 14:05

                You do not have permission to send to this recipient.  For assistance, contact your system administrator.

                <domain.com #5.7.1 smtp;550 5.7.1 <recipient@email.com>... Relaying denied. Proper authentication required.>

    Inbound is fine and nothing was modified on the server or exchange server in over a week (updates about 5 days ago).  I contacted the ISP to make sure port 25 was open and I use a smarthost, authsmtp, with no reports of any system irregularities or problems with them.  I can't seem to track down what happened or what is causing this issue.  I have checked several other threads and the KB articles.  I have run the Exchange bpa and all is within normal parameters.  Server restarts and client restarts have been done as well.

    I'm pulling out my hair on this one!  Any suggestions?

    Thanks,
    Greg

    Wednesday, April 22, 2009 6:14 PM

Answers

  • Hi Greg,

     

    1. Would you please let me know your outbound mail flow? Whether the message goes to external recipient through following path:

     

    Client->Exchange Server->Smart Host->Your ISP

     

    2. I suggest you check the message header of the NDR message to check which server generated the NDR message. You can post the header here if you are not sure how to check it.

     

    3. If the NDR message is generated by your Exchange Server, the issue occurs when the Exchange Server deliver the message to your Smarthost, you need to enable the SMTP protocol log on the Virtual Directory for further information. You can also telnet to Smarthost from your Exchange Server to manually check the issue. If the NDR message is generated on the Smarthost, you need to check the SMTP connection between Smarthost and your ISP mail server.

     

    XFOR: Telnet to Port 25 to Test SMTP Communication

    http://support.microsoft.com/kb/153119

     

    Mike

     

    • Marked as answer by Mike Shen Thursday, April 30, 2009 9:06 AM
    Friday, April 24, 2009 3:29 AM
  • Try this on exchange Server


    Step 1:

    Start->Run->cmd

    type

    telnet <Exchange FQDN> <SMTP Port>
    ehlo Microsoft.com
    mail from:Administrator@youremaildomain.com
    rcpt to:validhotmailid@hotmail.com
    data
    this is test email
    .
    quit


    Exchange FQDN = Fully qualified domain name of your exchange
    SMTP Port = 25 (Which is default, unless you guys changed it)
    Administrator@youremaildomain.com = any valid email account which you have in your exchange.
    validhotmailid@hotmail.com = any valid outside email address like abc@gmail.com, xyz@yahoo.com, test@hotmail.com etc where you can loggin and check.

    Step 2:

    Once you have done the above steps, check whether you receive that email or not, if that works there you need to check your network, 3rd party softwares like AV as Mike said or any other hardware spam filter devices which scans your outbound email traffic from your exchange server to internet (maybe at your end or from your ISP end)

    Step 3:

    You can bring another IIS box (Windows xp machine which has IIS and SMTP Domain configured) on which you can relay your exchange email like you do for your ISP.

    Configure IIS to be a Smart Host for Exchange
    http://www.petri.co.il/configure_iis_to_be_a_smart_host_for_exchange.htm

    If you sucessfully able to relay email to the IIS box from exchange then there is nothing wrong on your exchange box. Confirmed! :)
    Arun Kumar | MCSE - 2K3 + Messaging | ITIL-F V3
    Friday, April 24, 2009 5:14 PM

All replies

  • Any updates to AV?

    where are they trying to go out to?

    Have you tested the SMTP connection from Exchange 2003 to the smart host/outbound connection?  http://technet.microsoft.com/en-us/library/bb123686.aspx


    BP
    Wednesday, April 22, 2009 7:23 PM
  • Hi Greg,

     

    1. Would you please let me know your outbound mail flow? Whether the message goes to external recipient through following path:

     

    Client->Exchange Server->Smart Host->Your ISP

     

    2. I suggest you check the message header of the NDR message to check which server generated the NDR message. You can post the header here if you are not sure how to check it.

     

    3. If the NDR message is generated by your Exchange Server, the issue occurs when the Exchange Server deliver the message to your Smarthost, you need to enable the SMTP protocol log on the Virtual Directory for further information. You can also telnet to Smarthost from your Exchange Server to manually check the issue. If the NDR message is generated on the Smarthost, you need to check the SMTP connection between Smarthost and your ISP mail server.

     

    XFOR: Telnet to Port 25 to Test SMTP Communication

    http://support.microsoft.com/kb/153119

     

    Mike

     

    • Marked as answer by Mike Shen Thursday, April 30, 2009 9:06 AM
    Friday, April 24, 2009 3:29 AM
  • Try this on exchange Server


    Step 1:

    Start->Run->cmd

    type

    telnet <Exchange FQDN> <SMTP Port>
    ehlo Microsoft.com
    mail from:Administrator@youremaildomain.com
    rcpt to:validhotmailid@hotmail.com
    data
    this is test email
    .
    quit


    Exchange FQDN = Fully qualified domain name of your exchange
    SMTP Port = 25 (Which is default, unless you guys changed it)
    Administrator@youremaildomain.com = any valid email account which you have in your exchange.
    validhotmailid@hotmail.com = any valid outside email address like abc@gmail.com, xyz@yahoo.com, test@hotmail.com etc where you can loggin and check.

    Step 2:

    Once you have done the above steps, check whether you receive that email or not, if that works there you need to check your network, 3rd party softwares like AV as Mike said or any other hardware spam filter devices which scans your outbound email traffic from your exchange server to internet (maybe at your end or from your ISP end)

    Step 3:

    You can bring another IIS box (Windows xp machine which has IIS and SMTP Domain configured) on which you can relay your exchange email like you do for your ISP.

    Configure IIS to be a Smart Host for Exchange
    http://www.petri.co.il/configure_iis_to_be_a_smart_host_for_exchange.htm

    If you sucessfully able to relay email to the IIS box from exchange then there is nothing wrong on your exchange box. Confirmed! :)
    Arun Kumar | MCSE - 2K3 + Messaging | ITIL-F V3
    Friday, April 24, 2009 5:14 PM
  • Any update on the issue?


    Arun Kumar | MCSE - 2K3 + Messaging | ITIL-F V3
    Tuesday, April 28, 2009 6:51 AM