none
Error with Daylight Savings Time in Office 2010 and Windows 7

    Question

  • I am having an issue with the recent change to Daylight Savings Time.

     

    Environment:

    Windows 7 Professional - 64 bit

    Office 2010 Professional - 64 bit

    Exchange 2007 (CCR Model) running on Server 2008

    All machines, servers and desktops, are set to the Eastern (GMT-5) time zone with the "change to DST" button un-ticked. The time shows correctly on all machines and did NOT change when DST occurred.

     

    I live in the Cayman Islands which is on Eastern Standard Time year round (we do not switch to DST).

     

    Since the shift to DST I have encountered an error where calendar entries are recording incorrectly in an identifiable and repeatable way.  I have screen shots showing the following:

     

    I Double Clicked on 10:am Saturday to create a new ½ hour test appointment called Test 10am

     

    I then “Saved and Closed”

     

    The second screen shot shows the appointment appearing at 11am on the calendar instead of the 10am I set!

     

    The third screen shot  shows the appointment re-opened (double clicked) and now showing 9am as the start time! (again recall  I set it to 10am)

     

    I then close and re-open outlook and the appointment is now at 10am (where it belongs) however..

     

    The fourth screen shot still shows 9:am as the start time in the item description.

     

    Looking at my calendar from another machine (a terminal server running server 2008 R2 with office 2007 installed) the next screen shot shows the appointment recorded at the correct 10am time but inside the appointment states also  9-9:30.

     

    All Machines (terminal server, my windows 7, all exchange servers) are set identically to eastern Time (GMT-5) with the option to auto switch to DST turned off so there should be no time zone adjustment from machine to machine.

     

    This issue is repeatable 100% of the time and  is ONLY affecting users using Windows 7 and Office 2010.  Users on Office 2007 and XP are fine.  The only semi working solution is to set the  time zone on the windows 7/2010 machines to Bogotá (GMT-5) which is a time zone that does not have a DST option.  However even this solution only half fixes the problem.  IE any appointments I create, appear properly in the 2007 users calendars, but ones they create where I am invited, are reflected 1 hour earlier than they actually are scheduled.

     

    It would seem my only option is to change ALL users to Bogotá (over 250 machines, not a pleasant task especially if I have to run the time zone change wizard on each one!)  However this is an unacceptable solution as we do not live in Bogotá, and invites sent to outside contacts will reflect this time zone which can be very confusing to clients.

     

    This issue has stalled my plans to roll out Win 7 and Office 2010.

     

     

    Any Ideas?

    Monday, March 28, 2011 6:14 PM

Answers

All replies

  • Environment:

    Windows 7 Ultimate SP1 - 32 bit

    Office 2010 Professional - 32 bit

    I have a similar issue with similar behavior.  I am in a DST area (Virginia) and first started to notice the same behavior you noted before the DST changeover on March 13 for appointments that were scheduled for after the 13th. Now that DST time has passed, I am seeing a slightly different behavior though related to what I believe is the same root cause of Office 2010 using a different TZ mechanism than Office 2003. My corporate counterparts in China and the UK are reporting that my entries are showing up as off by 1 hour in their scheduling. This did not occur in Office 2003 and Win 7. My Win7 is an upgrade from Windows Vista, not a fresh install.


    JNC
    Tuesday, March 29, 2011 9:17 PM
  • Hi,

     

    Since everything is working fine in Windows XP, we can eliminate the Exchange cause. Please understand that we only discuss the Exchange issue on the pure Exchange product environment in this forum, I suggest you create a new thread in the Windows 7 forum.

     

    For your reference, I have enclosed the Windows 7 forum link below:

     

    http://social.technet.microsoft.com/Forums/en/category/w7itpro

     

    Thanks.

    Novak


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, April 01, 2011 2:06 AM
  •  Hi Novak

    I can't imagine for a moment that the folks on the Win 7 forum will even give this issue the (no pun intended) time of day!  I had already posted this first on the Outlook 2010 forum and they washed their hands saying it was an exchange issue.

    Granted I have not tested the issue with 2007 running under win 7 (I guess we will schedule some time to do that) but I think the issue from a win 7 standpoint will be...."if the clock is appearing correctly (it is) then the time zone is operating fine".  As this issue only involves Outlook and Exchange, the Win 7 group should, and I believe will, rightly dismiss the post.

    Rgds

    Scott

     

    Monday, April 04, 2011 5:11 PM
  • Hello Guys,

    I am in the same spot with you and it seems this is a very serioius problem.

    I described my case on two threads as "Questions".

    It seems the problem happens when W7 and Outlook are involved even with clients that are XP.

    We have the time shift whereever an Outlook 2010 client is involved even when I cancel the DST on both XP and W7 client.

    I tried a few combinations (with or without DST enabled) and it did not help. It seems that the meeting is recorded OK as per the time stamp on the meeting display but the display on the calendar is shifted 1 hour.

    Iwill be glad to have a solution since in the existing state Outlook 2010 in not useable and we will postpone the deployment and go back to 2007.

    So far NO REACTION from Microsoft.

    I wonder how it is possible to face such a problem with a product that runs for a year.

    Maybe people are using the product only at home...

    Regards,

    Marcel


    Monday, April 04, 2011 5:43 PM
  • Update:

    The problem is still ongoing, I have contacted my Microsoft Partner and told them that my planned upgrade for 170+ desktops to both Win 7 and Office 2010 was on hold until I had a resolution.

    I'm sure there is no direct correlation, however Microsoft have opened a problem ticket and assigned some resources to finding a solution.  So far no luck as they are providing the 'just change to Bogotá" option which is unacceptable but at least they are talking to me.  I will post further updates as I have them.

    FYI I have installed a user with Win-7 and Office 2007 and they have no issues.  I think we can therefore rule out Windows 7 as the problem and focus on 2010.

    I have also contacted several of my colleagues in the Island and all of them reported the same issue.  They all changed to Bogotá as a workaround, but of course this is not a fix.

     

    Monday, April 18, 2011 7:30 PM
  • Have a similar problem here. Changing Time Zones in Outlook, in this case from Berlin to Soeul and then back to Berlin, unchecks the Automatically Adjust for Daylight Savings Time in the system clock and everything is one hour out. Ticket to MS on its way.

    Tuesday, May 03, 2011 8:02 AM
  • On an other thread I analyzed the combinations possible between W7 vs XP with Office 2007 vs Office 2010.

    The shift seems to happen only when one of the "partners" to a meeting is W7 AND Office 2010.

    All other combinations work Ok.

    The test was done with DST OFF and in the same zone for all machines.

    No relevant ideas so far from MS moderators.

     

    Regads

     

    Marcel


    Marcel
    Tuesday, May 03, 2011 7:04 PM
  • Further Update:

    MS has opened a problem ticket for me free of charge (due to the pending sale I am sure!) and I am working through the various levels of support.  I have successfully demo'd the issue to them and have been escalated to product support.  We have agreed that my issue will not be considered closed until the following is met:

     Issue Definition: Users are from a time zone which does not observe DST. But the timings on the calendar events show timings as per DST which is an hour off. Multiple users are affected

    Scope Agreement: Once the calendar events show correct timings utilizing our official time zone designation which is Eastern Time (GMT -5) with DST unchecked , without selecting a different time zone that does not observe DST then we can consider this issue as resolved.

    I will update this post with any results.

    Wednesday, May 11, 2011 6:03 PM
  • Hi Scott,

    I am glad Microsoft has opened a ticket for the problem.

    Am am amazed at how much time it took to understatnd there is a problem.

    I am following my threads every week or so and hope for the best.

     

    Thanks

     

    Marcel


    Marcel
    Saturday, May 28, 2011 5:44 PM
  • Update June 8th, 2011

    Microsoft have confirmed that there is a reproducible bug and it has now been added to the development team project list for investigation and resolution.  Thy have assured me that they understand the suggested workaround of using an incorrect time zone is unacceptable and that a fix is required.

    Of course we can expect this process to take some time.

    I questioned whether it would in fact be addressed as Office 2014 is just around the corner and are they still patching 2010? Again I was assured that updates, patches, and an SP1 are still scheduled for the product.

    So my open ticket has been archived (not closed) (although I wonder if there is a difference!) and they tell me that I will be automatically notified when the fix is available.

    Since I am jsut one tiny 170 user voice, I will attempt to contact other businesses on the Island to report the problem thru thier sales reps and try to get a larger impacted community voice. 

    I told MS I would switch to Lotus Notes before I would switch to Bogotá as a time zone!

     

    Wednesday, June 08, 2011 4:57 PM
  • Hi Scottt,

    I wonder why is Microsoft maintaining the client forums. Is it because they hope I will help you and you will help me to be less frustrated by the lack of Microsoft intervention when they are really needed?

    In my oppinion, they should monitor those forums on a daily basis. But they do not.

    I see they avoid giving a date for SP1 and also I understan they also will not comment if the problem we are facing will be covered by the SP1.

    Sorry state.

     


    Marcel
    Wednesday, June 15, 2011 5:46 PM
  • Hi everybody!

     

    More than 3 months passed by... and nothing new happens with this awfull bug.

    As a result - in my organization most of the users still work with Office 2007.

    I suppose we shall "jump" to Office 2015....or maybe still use good old 2007 .

     

    Regards to all 


    Marcel
    Friday, September 30, 2011 6:14 PM
  • Hi All,
    just an update as 2012 daylight savings time has rolled over and we are still in the same boat. SP1 for 2010 was released but DID NOT address this issue. Repeated emails to the problem team regarding my "archived" issue have gone unanswered.

    I still have not migrated my 170 users off of 2007 due to this issue but am not particularly
    hopeful that the problem wont resurface in Office 2014 or whatever the next version is called.

    Regards

    Scott

    Wednesday, March 14, 2012 5:42 PM
  • Thanks for your last update,

    I almost stopped following this thread but not long ago I thought to checked SP1.

    Well, since MS did not address this issue, you saved me the trouble.

    We will wait for Office 2015....


    Marcel

    Wednesday, March 14, 2012 6:13 PM
  • If everyone in a location that doesn't use DST, uses a time zone that doesn't support DST, it should work correctly. You will need to use the time zone mover tool to update appointments that were created in the wrong time zone.


    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Thursday, March 15, 2012 11:07 PM
  • Hi Diane,

    I understand that you meen we should use an other location that has identical offset as ours BUT defined as not using DST.

    I do not think our system guys will like that, even if it worked.

    In my oppinion, if it it were so simple - Microsoft would have implemented a solution much sooner.

    I hope you noticed I stressed the fact that the bug appears only when a user has W7 and Office 2010.

    Also that I am using XP with Office 2010 and it is working OK.

    Anyway, we gave up using Office 2010...

    Regards,

    MK


    Marcel

    Friday, March 16, 2012 4:27 PM
  • Yes, I am aware that this problem affects only Windows 7 / Outlook 2010 users. Windows 7 changes how it handles time zones and Outlook 2010 handles time zones a bit differently so that all day events stick to a day. 

    Microsoft recommends using a time zone that does not use DST rather than unchecking the DST option in Windows. http://support.microsoft.com/kb/982987 

    Although Windows XP handles disabling DST, I still recommend using a time zone that does not support DST over unchecking the option.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Friday, March 16, 2012 5:25 PM
  • Hi Diane:

    Yes, Microsoft is not addressing the issue as they have a 'workaround' that involves simply changing to another TZ which does not observer daylight.  However if you read my original post this line:

    It would seem my only option is to change ALL users to Bogotá (over 250 machines, not a pleasant task especially if I have to run the time zone change wizard on each one!)  However this is an unacceptable solution as we do not live in Bogotá, and invites sent to outside contacts will reflect this time zone which can be very confusing to clients.

    ... reflects our unwillingness to appear to outside users as being in Bogata (our only TZ choice).  This unwillingness is due to the financial reputation of that area of the world and our particular industry which cannot be associated with that image in any way no matter how small.

    In any case, a workaround is no excuse for not instituting a fix.  As I see it MS should do one of two things:  Fix the bug (and it IS a bug) or create 47 new time zones that are generic:  i.e. GMT-1. GMT-1.5, GMT -2 etc.

    Regards

    Friday, June 08, 2012 8:19 PM
  • While they should use a generic names, you can edit the time zone in the registry to remove the name or to add your location - the keys are here: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones\. you can push it out using a logon script


    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    • Proposed as answer by kornm Saturday, June 09, 2012 1:16 PM
    • Marked as answer by ScottMacLaren Tuesday, July 10, 2012 9:41 PM
    Friday, June 08, 2012 11:24 PM
  • Hi Scott,

    I do not know what our System department did to our servers (with or without MS help)  but:

    1/ I am using Office 2010 with SP1 and DST ON

    2/ The problem seems to have been solved.

    I will cross check again.


    Marcel

    Saturday, June 09, 2012 1:20 PM
  • Hi Diane

    Thank you for your feedback. With the information you provided I was able to find a working solution. Unfortunately changing the name did not seem to work as well as I had hoped as the old name would still creep in. But the idea was spot on! I simply created a NEW time zone called Cayman Islands and set it up with the same settings as Bogota'. I used the TZEDIT tool found here: http://www.softshape.com/cham/manual/tzedit.htm to create the time zone.

    I then created a script to push this to all my desktops overnight, and manually added the hive on the relevant servers. Tests internal and external show what I would expect to see even across Time Zones. The fact that my "Cayman Islands" zone is not on outside computers does not appear to be an issue as it is seems to Use TZ information sent and not an internal reference based on a name. (as I would expect)

    So a big thank you, and go ahead and take the rest of the day off!

    Scott


    Tuesday, July 10, 2012 9:40 PM
  • Thanks for sharing how you fixed it - I know it will help others facing the same problem.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Wednesday, July 11, 2012 1:45 AM
  • Diane: I am not as sophisticated. I am just 6 users.  Please tell me how to solve this problem. I am using W7 64bit,  Outlook 2010, and Windows Live (hotmail) calendar. 

    All time zones in my PC and in Windows Live  are set correctly.  When I share a calendar with someone (whose computer and windows live calendar are also set to the correct time zones), I still have a problem with the time being switched. The correct time zones for all are Central Time Zone (US) and the incorrect time zone being shown on the shared hotmail calendar is Pacific Time Zone (US).  Again, the hotmail calendar shows the correct time zone when I log in BUT it shows an incorrect time zone for everyone else when they look at the online calendar!  If you have an answer that works, please email me at keenbutcher @ hotmail . com.  Thank you.

    Monday, August 27, 2012 2:12 AM
  • Scott: I am not as sophisticated. I am just 6 users.  Please tell me how to solve this problem. I am using W7 64bit,  Outlook 2010, and Windows Live (hotmail) calendar. 

    All time zones in my PC and in Windows Live  are set correctly.  When I share a calendar with someone (whose computer and windows live calendar are also set to the correct time zones), I still have a problem with the time being switched. The correct time zones for all are Central Time Zone (US) and the incorrect time zone being shown on the shared hotmail calendar is Pacific Time Zone (US).  Again, the hotmail calendar shows the correct time zone when I log in BUT it shows an incorrect time zone for everyone else when they look at the online calendar!  If you have an answer that works, please email me at keenbutcher @ hotmail . com.  Thank you.

    Monday, August 27, 2012 2:12 AM
  • Log into Hotmail.com - click on your name on the right side and choose Account Settings. Click the link for personal information. The time zone setting is near the bottom - every user needs to verify it is set to CST.


    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Monday, August 27, 2012 2:36 AM
  • Outlook 2010 has DST ending on October 27, which is incorrect, it is November 3rd, any ideas?
    Tuesday, October 15, 2013 4:26 PM
  • Outlook uses the DST settings of the computer's time zone.  What OS are you using? There is a time zone update for Windows xp; if i recall correctly, windows 7 has the updated zones by default.

    http://www.slipstick.com/outlook/calendar/daylight-saving-time-updates/



    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Thursday, October 17, 2013 1:33 AM