none
Outlook Instant Search does not work with the additional mailboxes in online mode

    Question

  • Hello,

     

    I have a Windows 2008 R2 Remote Desktop server with the Office 2007 installed, and a Exchange 2007 server with a typical mailbox size of 3-7 Gb. All software is fully updated.

    The problem is that Outlook Instant Search works only with the user's mailbox, not with the additionally attached ones. When user tries to search something in the additional mailbox, Outlook slows down for a lot of time, e.g. a couple of minutes, never reacting to anything except cancelling the query to Exchange server.

    Here is what I have already tried and/or found:

    - I’ve used the test-exchangesearch commandlet, and it returned success for all the mailboxes;

    - I didn’t believe test-exchangesearch and rebuilt all the Exchange database search index;

    - Then I've found that the search doesn’t work for any mailbox additionally attached, but it will work for the same mailbox made primary. For example, say, we have users A and B, and A have B's mailbox additionally attached while B have A's mailbox attached. In this configuration, the user A can search instantly in his mailbox, but not B's, and the user B can search instantly in his mailbox, but not in the A's.

    - This is most probably not a Windows Desktop Search issue since Outlook 2007 on Remote Desktop servers works in online mode only, so WDS doesn’t index its data;

    - When an Outlook slowdown occurs, Exchange often start to consume a lot of disk resources. This indicates that Outlook possibly queries Exchange to use Exchange Store Search (which is substring-based and unindexed) for the additional mailboxes instead of using Exchange Search (which uses index).

    Unfortunately, I cannot upgrade Office to 2010 (which can use Exchange cached mode in RDS, as far as I know). Maybe there is the way to solve this problem using other ways?

     

    Any help will be greatly appreciated, and many thanks in advance.

    Thursday, May 12, 2011 10:29 PM

Answers

  • Hi,

     

     

    Could you please try the following methods?

    Method one:

    1.Click “Start”àClick “Run”à Type “gpedit.msc” and press OK

    2. Expand Computer ConfigurationàAdministrator templatesàwindows componentsàclick “Search”

    3. Double Click on “Enable indexing of online delegate mailboxes” option

    4. Select “Enabled” and click “ok” to close “Local Group Policy Editor”

    5. Click “Start”àClick “Run”à Type “gpupdate /force” and press OK

    6. Restart Microsoft Outlook

    Method two:

    Press  “CTRL+SHIFT+F” to use advanced search.

     

    More information:

    Outlook 2007 and search in additional mailboxes

    How can one search in a additional mailbox in Outlook 2007


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Antony4 Monday, May 16, 2011 8:24 AM
    • Unmarked as answer by Antony4 Monday, May 16, 2011 3:55 PM
    • Marked as answer by Antony4 Monday, May 16, 2011 4:05 PM
    Monday, May 16, 2011 7:02 AM

All replies

  • Check the article to rebuild the Search Index manually.
    http://technet.microsoft.com/en-us/library/aa995966(EXCHG.80).aspx

    I hope you have full permission on Additional Mailbox!
    If search is working fine for your own mailbox that means there is no issue with Search Index.

    Was it working fine before? 
    What is the service pack on Exchange? 


    Gulab | MCTS-MCITP Messaging: 2010 | MCTS-MCITP Messaging: 2007 | MCC 2011 | Skype: Gulab.Mallah
    Friday, May 13, 2011 5:42 AM
  • Hello Gulab and thank you for your reply.

     

    I have already tried to rebuild the search index manually, and it didn't help.

    The users who use additional mailboxes have full permissions on them.

    I don't know if it was working before, since we have just made the Remote Desktop server.

    We use Exchange 2007 SP3 fully updated via Microsoft Update. Our Outlook 2007 clients are fully updated as well.

     

    Friday, May 13, 2011 6:46 AM
  • Hi,

     

     

    Could you please try the following methods?

    Method one:

    1.Click “Start”àClick “Run”à Type “gpedit.msc” and press OK

    2. Expand Computer ConfigurationàAdministrator templatesàwindows componentsàclick “Search”

    3. Double Click on “Enable indexing of online delegate mailboxes” option

    4. Select “Enabled” and click “ok” to close “Local Group Policy Editor”

    5. Click “Start”àClick “Run”à Type “gpupdate /force” and press OK

    6. Restart Microsoft Outlook

    Method two:

    Press  “CTRL+SHIFT+F” to use advanced search.

     

    More information:

    Outlook 2007 and search in additional mailboxes

    How can one search in a additional mailbox in Outlook 2007


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Antony4 Monday, May 16, 2011 8:24 AM
    • Unmarked as answer by Antony4 Monday, May 16, 2011 3:55 PM
    • Marked as answer by Antony4 Monday, May 16, 2011 4:05 PM
    Monday, May 16, 2011 7:02 AM
  • Hi Jerome,

     

    many thanks to you, this setting did exactly what I need. The search in additional mailboxes takes now 1-3 secs for a mailbox of 10K mail.

     

    Thank you again!


    Monday, May 16, 2011 8:24 AM
  • Hi Jerome,

     

    I tried the above but it did not work for me.  Would you happen to know a method for people on large business networks?  Our IT guys have been trying to figure this out with no luck.  This is a feature I use all the time all day and would appreciate it if you can give it a shot.

    Thank you in advance!

     

    Tuesday, November 29, 2011 9:57 PM
  • This also is the trick for Outlook 2010 and 2012, thank you!
    Thursday, July 04, 2013 8:33 AM