none
Outlook OOF & https://remote.mydomain.co.uk/EWS/Exchange.asmx

    Question

  • Done a Outlook AutoDiscover test (by holding down CTRL Key & right-clicking Outlook icon in the system tray)

    What should I get I navigate to "https://remote.mydomain.co.uk/EWS/Exchange.asmx"

    I get a login, type in my username & password then a page

    To test this service, you will need to create a client and use it to call the service. You can do this using the svcutil.exe tool from the command line with the following syntax:

    svcutil.exe https://vexch.ad.mydomain.co.uk:444/EWS/Services.wsdl 

    and some C# & VB code ... I'm a bit lost now!

    vexch is the host name and ad.mydomain.co.uk is the windows domain name

    NB: port 444 is not open on the router and vexch.ad.mydomain.co.uk si NOT named on the SSL cert


    • Edited by bhrt60 Monday, November 25, 2013 10:47 PM
    Sunday, November 24, 2013 10:44 PM

Answers

All replies

  • Hi,

    It seems like the EWS authentication was off, please open it to have a try.

    Found a similar thread for your reference:

    EWS not working in Exchange 2013

    http://social.technet.microsoft.com/Forums/exchange/en-US/869a1a02-2e6a-44d3-8be1-a098d6eb965b/ews-not-working-in-exchange-2013

     

    Hope it is helpful

     

    Thanks

    Mavis


    Mavis Huang
    TechNet Community Support

    Tuesday, November 26, 2013 7:44 AM
  • Hi,

    It seems like the EWS authentication was off, please open it to have a try.

    Found a similar thread for your reference:

    EWS not working in Exchange 2013

    http://social.technet.microsoft.com/Forums/exchange/en-US/869a1a02-2e6a-44d3-8be1-a098d6eb965b/ews-not-working-in-exchange-2013

     

    Hope it is helpful

     

    Thanks

    Mavis


    Mavis Huang
    TechNet Community Support

    >>It turns out that the expected behavior is to see that page. The EWS authentication was off, once corrected everything was functioning correctly, thanks

    Thank you. I'm a bit thick when it comes to Exchange 2013 - still finding my way around it...

    is there way to check status of EWS authentication?

    where do I turn on EWS authentication ?

     


    • Edited by bhrt60 Tuesday, November 26, 2013 8:10 AM
    Tuesday, November 26, 2013 8:03 AM
  • Hi,

    Sorry for the late reply.

    To double confirm this issue, please run following command to verify the status of Authentication:

    Get-WebServicesVirtualDirectory | FL

    Normal result as pic below:

    If our WSSecurityAuthentication is False, please run following command to turn it on:

    Set-WebServicesVirtualDirectory -Identity "EWS (Default Web Site)" -WSSecurityAuthentication $true

     

    More details in the following article:

    Set-WebServicesVirtualDirectory

    http://technet.microsoft.com/en-us/library/aa997233(v=exchg.150).aspx

     

    Hope it is helpful

     

    Thanks

    Mavis


    Mavis Huang
    TechNet Community Support


    Thursday, November 28, 2013 5:51 AM
  • Hi,

    Sorry for the late reply.

    To double confirm this issue, please run following command to verify the status of Authentication:

    Get-WebServicesVirtualDirectory | FL

    Normal result as pic below:

    If our WSSecurityAuthentication is False, please run following command to turn it on:

    Set-WebServicesVirtualDirectory -Identity "EWS (Default Web Site)" -WSSecurityAuthentication $true

     

    More details in the following article:

    Set-WebServicesVirtualDirectory

    http://technet.microsoft.com/en-us/library/aa997233(v=exchg.150).aspx

     

    Hope it is helpful

     

    Thanks

    Mavis


    Mavis Huang
    TechNet Community Support


    Hi, sorry just noticed your reply.
    I've trying to make sure system is stable as currently company is very busy.
    but I would love to quieten the 'moaners' regarding Out Of the Office & Calender sharing
    (for which they have to use OWA! currently)

    Unfortunately ! - the value is TRUE

    Should Basic Authentication also be True??

    Internal and external URL both point to https://remote.mydomain.co.uk/owa/EWS/Exchange.asmx

    Monday, December 09, 2013 10:57 AM