none
Unable to get rid of Mailbox Full

    Question

  • Yesterday I migrated the first mailbox (my own) from Exchange 2007 to Exchange 2010.

    I was not aware that mailbox quota is now a database property, and my mailbox is 255MB above default limit. So I got a Mailbox Full warning after restarting my Outlook 2010 client, fair enough.

    First thing I did was raising the limits on the database - same warning. Next thing was removing all quota from my account, still no luck.

    Since yesterday I have unmounted and mounted the database, restarted all client access and mailbox servers (2 members of a DAG), migrated my mailbox back to 2007, migrated again to 2010, rebooted my client PC. Next must be something with chicken blood.

    When I start my Outlook 2010 i get "Mailbox Full - Your mailbox is full, you may not be able to send or receive mail". Fact is that I can still send and receive.

    When I open new mail there is a warning that "Your mailbox will be full after sending this email message. You may not be able to send messages until you remove items from the mailbox." Despite this  the mail and the next one is sending fine.

    This is very annoying, what can I do to make my quota changes for database and/or mailbox apply?

    Ole Thomsen

     

    Saturday, July 24, 2010 7:10 PM

Answers

  • Does Exchange think you are overlimit?

    Check with this PS command:

    Get-MailboxStatistics  <youralias> | fl StorageLimitStatus

    If so, then you have set something wrong somewhere. I would re-check everything.

     

    If it shows you are under limit, then try creating a new Outlook profile, or delete the .ost in Outlook if in cache mode, or set Outlook to online mode or check via OWA and see if you still get warnings.

     ( By the way, you can quickly enforce a send limit by restarting the Info Store service)

    Also check out:

    http://technet.microsoft.com/en-us/library/bb684892(EXCHG.80).aspx

    Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time

     

     

     

    • Marked as answer by Oletho Saturday, July 24, 2010 7:42 PM
    Saturday, July 24, 2010 7:19 PM
    Moderator

All replies

  • Does Exchange think you are overlimit?

    Check with this PS command:

    Get-MailboxStatistics  <youralias> | fl StorageLimitStatus

    If so, then you have set something wrong somewhere. I would re-check everything.

     

    If it shows you are under limit, then try creating a new Outlook profile, or delete the .ost in Outlook if in cache mode, or set Outlook to online mode or check via OWA and see if you still get warnings.

     ( By the way, you can quickly enforce a send limit by restarting the Info Store service)

    Also check out:

    http://technet.microsoft.com/en-us/library/bb684892(EXCHG.80).aspx

    Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time

     

     

     

    • Marked as answer by Oletho Saturday, July 24, 2010 7:42 PM
    Saturday, July 24, 2010 7:19 PM
    Moderator
  • Cached mode seems to be the root of the error.

    Right after posting it occurred to me that OWA had not given any warnings, and I tried starting Outlook 2007 (non-cached) from one of our terminal servers - no warning.

    After that I disabled cached mode on my Outlook 2010 client and the error disappeared. Activating cached mode again on the same .ost brought the warning back.

    Solution was disable cached mode, delete .ost and reenable cached mode. The cache file must somehow have the false quota information stuck.

    Thanks for all input.

    Ole Thomsen

     

    • Proposed as answer by kwacky1 Tuesday, August 16, 2011 4:46 AM
    Saturday, July 24, 2010 7:42 PM
  • Thank you all.

    Cached mode caused the same issue for my client.

     

    Solution was disable cached mode, delete .ost and reenable cached mode

    Thursday, June 16, 2011 6:32 PM
  • Thanks Oletho!!

    Your solution worked perfectly for me!!

    Kurt

     

    Monday, August 15, 2011 2:16 PM
  • Thanks - removing the OST file and allowing it to recreate fixed the issue
    Brian Reid C7 Solutions Ltd (www.c7solutions.com)
    Tuesday, September 06, 2011 1:57 PM
  • I found this same problem with SBS 2011 - I changed the users mailbox quota, rebooted the server, and still Outlook 2010 shows Mailbox oversize limit error.

    I removed cache mode, closed Outlook, started Outlook - noted the error was gone.  Enabled Cache mode.  All is good.

     

    Tim


    Tim Jordan
    Monday, September 19, 2011 8:26 PM
  • For the benefit of others in the same or similar situation:

    I just had the same situation but with some differences. I had a series of Exchange 2007 databases with no limit of any kind specified since it's creation a few years ago. The default limit was 2GB but was removed before user mailboxes were created on the database. The admin specified a limit to some of the databases through the Exchange Mgt console but later, after a few hours, removed it since it was to low, leaving the setting unchecked and the text box cleared.

    Soon after, a large number of clients on that database started reporting that their OUtlook 2010 shows them the "Your mailbox is full" message. In addition, some of them are not able to edit their Junk E-mail settings although they can send and receive just fine but creates panic since the warning indicates that they will not be able to send or receive until corrected. Outlook 2007 clients did not report any issues or warnings as far as I know.

    Since disabling cache mode for a large number of users is not an option, had to find another work around. What I had to do is

    1. Get a report mailbox sizes for the users in that database. I used the 

    Get-Mailbox | Get-MailboxStatistics | ft DisplayName,TotalItemSize,ItemCount

     2. Determine a limit higher than the larger mailbox in that database

    3. Configure the database limits with command

    Set-MailboxDatabase "Server\SG Name\Db Name" -IssueWarningQuota <limit in bytes> -ProhibitSendQuota <limit in bytes> -ProhibitSendReceiveQuota <limit in bytes>

    4. Confirmed from users that the warning is gone and they are able to edit their Junk E-Mail settings again.

    Seems that the setting 'unlimited' on Exchange 2007 databases do not work well with Outlook 2010.

    HTH

    Fred Larracuente

    Wednesday, November 30, 2011 2:22 PM
  • Hello all,

    I'm experiencing this issue after a few tests during our planned office2010 migration

    I find all the Answers proposed unacceptable on a wide area point of view.

    Removing quotas or  unchecking cached mode, deleting ost, and re-enabling cached mode, are out of the way from my point of view (1000+ workstations)

    Isn't a patch available ??? This is defenitely a client issue ...

    Wednesday, February 29, 2012 10:53 AM
  • no updates on this ?
    Wednesday, March 14, 2012 9:26 AM
  • Thanks gang, Northwest traders the cached mode, then OST removal worked for me.  I was lucky though as the computer I ran into this on I was rebuilding anyways however this happended during the import process so I was concerned.  After making changed to that user, (CEO) quota I kept checking his mailbox size in EMC and the import was still working however Outlook still showed the error.  OWA confirmed this.

    Jaeger to solve your issue I would use Group Policy.  Remove quotas with EMC, Load Admin tool pack for Office into GP, and create GPO to disable cached mode.  Use another GPO (Prefrences) to delete all *.ost files.  Changed to cached mode policy after a global GPO update, remove GPO for file deletion.  Might make it much easier as long as you have Group Policy implemeted and nodes chcking in regularly.  If your in the same geo-LAN should work great.

    Friday, May 25, 2012 7:37 AM
  • The Cached mode did not fix the issue for me. I had to go into the permissions for the pst folder and add myself as a user, then change the permissions to Owner.  Restarting Outlook 2010 and tested, and it worked.
    • Proposed as answer by Carole Richard Tuesday, September 25, 2012 8:32 PM
    Tuesday, September 25, 2012 8:32 PM
  • This worked for me - Thank you for the help!!!!


    • Edited by Joe Lagana Friday, November 09, 2012 3:01 PM
    Friday, November 09, 2012 3:00 PM
  • Thanks, this was very helpful.

    "Solution was disable cached mode, delete .ost and reenable cached mode. The cache file must somehow have the false quota information stuck."

    Wednesday, December 05, 2012 7:12 PM