none
The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete - Cant add Outlook accounts

    Question

  • Hi have recently started getting the following error message when setting up new accounts with Outlook 2007:

    The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action.

     

    Outlook then prompts me to enter the username and password, i do so and get message again. This happens on Windows XP Professional and Vista, i cannot setup any accounts for new machines.

    Points to note are that OWA works fine, and previous users who are already setup work fine also. It seems to be limited to setting up new Outlook 2007 accounts.

     

    It can find the username fine. It comes up with green ticks underr the Online Search for your server settings:

     

    Establish Network connection

    Search for chris@mydomain.com server settings

    Long on to server ---------- then it fails with a big red cross at this point


    Recently i did add a second mail server to the network but it was not configured to talk to the other main mail server which was handling all the functions of mail box, CAS, hub transport. I had installed all the same roles on the second server with a view to move it across and retire the old server, the second machine is a different machine name from the main mail server. In summay my servers are:

     

    svr001              Server 2003 R2 Enterprise x64 domain controller

    mail                 Server 2003 R2 Enterprise x64 non-domain controller with exchange 2007 SP1

    mail001            Windows 2008 Enterprise x64 non-domain controller with exchange 2007 SP1


    The main box "mail" has been fine until i recently introduced this new server "mail001" into the network.

    I am really stuck now and would really appreciate any pointers or steps to debug the above.

    Many thanks,

    Chris

    Wednesday, March 19, 2008 11:32 AM

All replies

  • Quick update i removed Exchange from the mail001 box. I then rebooted the DC, and then rebooted mail box. Then it started working again.

     

    This is great in that it works, however i am a bit concerned about migrating my 2003 server box mail server to Windows Server 2008 in case i get the same problems again.

     

    Indeed not sure if its 100% fixed i hope it doesnt come back. Any ideas as to why it would have stopped working?

     

    Kind regards,

     

    Chris

    Wednesday, March 19, 2008 11:42 AM
  • I have the same problem but I'm running one mail server. This problem just started a couple days ago. No changes were made to any server except for adding a BSAdmin on the server so users can check email with their BlackBerry.

     

    I tried a reboot for both servers and I'm still having the same problem.

     

    Anyone know what could be the cause for this? And how to fix it.

     

     

    Wednesday, November 12, 2008 9:57 PM
  • I am having the same trouble.  Nobody seems to know what to do.  My wife and I have the same computer exactly (Windows XP) running Office 2007.  We both connect to the same exchange server at the same company.  I can no longer connect out of the blue and get the above error message and she is connecting just fine.  I am unable to reestablish a connection to the exchange server.  I've tried uninstalling Outlook and still am having a problem.  Please let me know if anyone has found a solution.

    Saturday, November 15, 2008 7:06 PM
  • I'm having the same problem and just spent an hour and a half with Microsoft Tech Support to hear him tell me it's not an Exchange issue but an Outlook issue... something I told them to begin with :-(

     

    Outlook runs and I can get internet email but sharing my calendar and intra office email (i.e. all the Exchange Server actions) are not available to me.

     

     

    Friday, November 21, 2008 3:17 AM
  • I updated the service packs, etc on my xp systems, then it works.
    the problem i am having is with terminal server. almost all the users work well, a few come up without being able to find the domain controller.
    i know they are there because they can logon to the network in house, outside via rdp it dies.
    Mibble
    Thursday, December 18, 2008 8:52 PM
  • I recently reinstalled a PC on my computer network with Vista and Outlool 2007 (I tried XP and Outlook 2003 as well) on got the same messages.  I was able the import the registry key below from a Windows XP machine that had my configuration already installed and its now working perfectly.

    HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\Outlook

    I noticed that a number of subkeys were missing from the fresh installation.

    • Proposed as answer by Barzelan Friday, September 11, 2009 9:14 PM
    Monday, January 05, 2009 6:36 AM
  • what made the most impact, as i was intermittently getting the domain controller could not be found, was to update the system bios and all hardware updates and drivers for the server itself (not microsoft stuff, manufacturer stuff) which made a big difference. so go to your hardware manufacturer and get the updates.
    Mibble
    Monday, January 05, 2009 8:41 PM
  • Another solution maybe to ensure that the System Attendant service is on the Exchange server is running.  This apparently was the problem as confirmed by my System  Engineer who was on vacation at the time I encountered my problems.

    • Proposed as answer by Girgimel Thursday, January 08, 2009 8:12 PM
    Thursday, January 08, 2009 8:11 PM
  • I had an issue where my exhanger server bacame unresponsive. I rebooted the box and started configuring outlook on an XP desktop.

    I also received the message: The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete...

    Thanks, Girgimel. I checked the services on my Exchange 2007 box and the Exchange System Attendant service did not start.

    Once I started the manually, I was able to set up Outlook on the desktop.
    Monday, May 11, 2009 3:37 PM
  • I restarted the POP3, IMAP services on the exchange box and that worked for me.
    • Proposed as answer by Moonshekar Saturday, January 26, 2013 4:07 PM
    Monday, June 01, 2009 7:33 PM
  • That did it for me as well.  Export the keys from the registry of a working box, and configure the new box after importing it.
    Friday, September 11, 2009 9:14 PM
  • I've had this a couple of times.  Usually after I reboot my Exchange server.  Check the primary Exchange server (in case you have more than one) and check Microsoft Exchange services.  Look for Microsoft Exchange Attendant services.  Although it is set for automatic it appears not to be runing.  Simply start this service and your outlook should be able to communicate with the exchange servere again.
    Tuesday, September 15, 2009 10:46 PM
  • Thanks for this Girgimel, worked like a charm!
    Friday, February 12, 2010 2:36 PM
  • Another solution maybe to ensure that the System Attendant service is on the Exchange server is running.  This apparently was the problem as confirmed by my System  Engineer who was on vacation at the time I encountered my problems.

    Thanks for this tip.

    The sytem attendant service was indeed not running. (Exchange 2007, outlook 2007 clients). OWA worked fine, but configuring an existing account was inpossible on a clean client install.
    • Proposed as answer by GraNFaLooN Saturday, March 20, 2010 6:48 AM
    Tuesday, February 16, 2010 2:42 PM
  • I had try in many ways but i found a best solution when you cannot add new account with outlook 2007.

    First i uninstall outlook 2007 and reboot your computer and install outlook 2003

    when install complete try to add new e-mail account with outlook 2003 it never pop-up like "The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete " when you can adding e-mail account with 2003 try to re-install outlook 2007 by upgrade

    Saturday, March 20, 2010 6:52 AM
  • Thanks, this solution worked for me!
    Friday, March 26, 2010 2:03 AM
  • this "fix it" worked for me!

    http://support.microsoft.com/?kbid=319206

    hope to u

    • Proposed as answer by squrany Tuesday, June 01, 2010 9:28 AM
    Saturday, April 10, 2010 2:03 PM
  • One solution I found...don't know if this will work for you.

    On the local box, I removed the MS Office update: KB972363 and then I was able to connect to the account to my Exchange Server.

    Here's the description of this KB from microsoft: http://support.microsoft.com/default.aspx/kb/972363?p=1
    at the bottom are "known issues".

    Tuesday, April 13, 2010 6:42 PM
  • Vote As Helpful

    this "fix it" worked for me!

    http://support.microsoft.com/?kbid=319206

    hope to u

    Tuesday, June 01, 2010 9:28 AM
  • Hi

     

    i had this problem too restarting the Microsoft Exchange System Attendant  Service solved the problem

     

    thanks

     

    • Proposed as answer by daguccio Wednesday, September 01, 2010 3:36 AM
    Tuesday, August 03, 2010 11:02 AM
  • Hey all i just did this and it worked for me.  

    I went into iis manager.  Properties of the exchange web site>  directory security > in the secure commuinications area at the bottom of that windows select edit.  A new window will pop up.  select require secure channel (ssl).  bam!  I can finally get my mail and my webmail.  

    Hope this helps someone. 

    Wednesday, September 01, 2010 3:39 AM
  • If the new account also has a new windows profile the problem might be related to first time use of Microsoft office.

    Open MS Word and if it prompts for a name and initial go ahead and input something, then close word.

    Try creating the outlook profile again.

    I believe this causes a hold up sometimes because MS Outlook uses MS word as it's text editor.

     

    (I know I'm replying to a 2 year old thread but I think this info is helpful as some of the times it is the culprit and others find it an ongoing issue)

    • Edited by DColton Tuesday, October 19, 2010 3:57 PM typo plus minor additional explanation
    Tuesday, October 19, 2010 3:55 PM
  • I was having exactly the same problem. Searched a lot, until I found this forum. We'd had a powercut in the morning, and for some reason a number of Automatic Exchange services hasn't started, Microsoft Excahnge System Attendant and Service Host being two of them. Once they had been started it fixed the problem.

    Rachel

    Wednesday, January 26, 2011 2:02 PM
  • well just make sure you are tyoing the rigth name for the exchange server.

    it will nnot locate the name you are trying to set up because is not pointing to the rigth server name.

    so it look simple but double check your spelling on the server name.

    Friday, February 25, 2011 4:11 PM
  • this "fix it" worked for me!

    http://support.microsoft.com/?kbid=319206

    hope to u


    Ditto that!  Tnx!
    Monday, May 23, 2011 2:26 PM
  • I have a brand new out of the box laptop and am getting this error message... The connection to Microsoft Exhange is unavailable. Outlook must be online or connected to complete this action. I have tried every solution and fix I have found on Microsoft and this site and no joy. Please help...anybody The laptop is Windows 7 and its Outlook 2007
    Leanne at DRS
    Sunday, June 05, 2011 5:58 AM
  • On Sun, 5 Jun 2011 05:58:07 +0000, Leanne at DRS wrote:
     
    >I have a brand new out of the box laptop and am getting this error message... The connection to Microsoft Exhange is unavailable. Outlook must be online or connected to complete this action. I have tried every solution and fix I have found on Microsoft and this site and no joy. Please help...anybody The laptop is Windows 7 and its Outlook 2007
     
    Why not start by contacting your company's helpdesk? They should be
    able to fix you up.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Sunday, June 05, 2011 5:04 PM
  • Tengo el mismo problema reinicie el server y despues de eso en varios equipos de la empresa ya no se conecta el outlook, lo tengo instalado en 80 equipos, algunos estan fuera de dominio, pero la falla es general, les falla a algunos que estan fuera de dominio y a otros que si estan en el dominio ya reinicie el servicio Microsoft Excahnge System Attendant. pero la falla continua

    La solucion que encontre fue configurar RPC sobre Http en el outlook, pero los equipos que estan fuera de dominio marca error de certificado.. asi que el problema continua

    este hilo ya tiene años.. alguien tendra ya alguna respuesta ?

    de antemano gracias

     

     

    Tuesday, June 21, 2011 8:26 PM
  • PrinceDotNet, thanks for sharing that link.  It resolved this same issue for me.
    Monday, June 27, 2011 5:22 PM
  • Just wanted to say that the numerous other registry fixes that are floating around out there (autodiscover, defconnectopts, etc) didn't work for me - this did.  Had a customer upgraded from Office 2003 to 2007 - suddenly no connection to exchange, and couldn't create a new profile (because it won't talk to exchange).  I exported the key from my computer to hers, made a few adjustments, and BINGO - customer has functional outlook.

    Thanks!

    Tuesday, July 19, 2011 1:57 PM
  • It appears that the issue may be the RPC encryption setting.  I have existing user accounts that connect to Exchange 2010 with no problem.  However, several new accounts on the same PC are getting the "unable to connect to server..." message  (I am testing these accounts before I do a forest migration from exch2003 to exch2010).  Come to find out the upgrade to SP1 cause a change in the RPC setting.  When I disabled the requirement for RPC encryption on the CAS server, my new accounts were able to connect to the 2010 exchange server with no problem.  Even though the new accounts had the RPC encryption setting check, it still did not sync with the exchange server RPC encryption setting.  It appears you have to:

    • turn the RPC encryption off on the server,
    • start the Outlook  client to get it connected to the server,
    • then configure the encryption on the client log it off
    • then configure the RPC encryption on the server
    • then reconnect the Outlook client and it should work from then on

    See the following for further info.   

    http://support.microsoft.com/kb/2006508

    Regards


    • Edited by g7quinc Tuesday, August 02, 2011 2:38 PM wrong link
    Tuesday, August 02, 2011 4:23 AM
  • I know this post is over 3 years old, but I encountered the same issue and none of the above resolved it.

    After running a port scan on the computer that was not connecting, I learned that nearly all the ports to this computer have been turned off, especially ports 25 (SMTP), 53 (DNS), 88 (Kerberos), 137 (NetBIOS). After enabling these ports, I was able to connect to Exchange and create an Outlook profile.

    Thursday, August 11, 2011 12:09 PM
  • The FIX IT here http://support.microsoft.com/?kbid=319206 works, but only for a user who's already logged in (if you just run the fix it program and do nothing else). To make it work for all users you'll need to manually edit the registry as it says in the article.

    To force Outlook to use a pre-defined global catalog server, use the following steps to set the following special registry parameter to point to the Fully Qualified Domain Name (FQDN). Doing this over-rides any setting in the MAPI profile.

    1. Click Start, and then click Run.
    2. In the Open box, type regedit.exe, and then click OK.
    3. Locate and then click the following key in the registry:
      HKEY_CURRENT_USER\Software\Microsoft\Exchange\Exchange Provider

      Note You may have to create the registry path.
    4. On the Edit menu, click Add Value, and then add the following registry value:
      Value name: DS Server
      Data type: REG_SZ (string)
      Value data: FQDN of the global catalog server

    This allowed me to roll out a bunch of laptops and not have to worry about running the Fix It for each user.

     update: Sysprep seemed to remove fix. Each time a new user logged into a newly imaged laptop (on domain) same error about Outlook 2007 cannot connect to Exchange. Have tried just about everything, but all I seem to be able to do is run this stupid Fix it each time. Luckily I don't have 1000 machines to setup because then I'd be screwed.




    • Edited by MarcGel Thursday, September 08, 2011 12:02 AM
    Monday, August 15, 2011 10:38 PM
  • Yes! This is it. Simplest fix and the right one!
    Computer > right click > manage > services > (scroll down to) Microsoft Exchange Service Attendant > (right click) start service
    • Proposed as answer by HAL07 Tuesday, October 04, 2011 9:11 AM
    Tuesday, September 06, 2011 2:33 PM
  • Go down the Firewall and try again ;)
    Tuesday, October 04, 2011 3:17 PM
  • I was having the same problem and checked my exchange server but the Microsoft Exchange Service Attendant service WAS started.

    I decided to go ahead and restart the service anyway, and this corrected the problem.

    Thursday, November 03, 2011 2:27 PM
  • How do you check to see if it's turned on? I need like detls on how to find it. n what files they are in thank you. I've never had outlook operating on my comp n I'm trying to set it up but am having alot of trouble so please if some one can help me I will be greatly appreciative  :) Thank you

     

    Sunday, November 06, 2011 8:30 AM
  • I had a fresh install of Office 2010 on a new machine with Win 7 Ultimate, all service packs and updates done, and got this problem. Copying my old profile from my near-death machine worked like a charm. Thanks for the good info.
    Wednesday, January 04, 2012 7:10 AM
  • Please first check your system date and time, Then go for further.......
    Monday, February 20, 2012 12:50 PM
  • Hey I did everything you said until the last step because I can't find Microsoft Exchange Service Attendant under the service folder. What do I do?
    Thursday, March 15, 2012 6:17 PM
  • I have had this problem and tried all the tricks on the internet and the only thing that worked perfectly was the "fix it". 

    http://support.microsoft.com/?kbid=319206

    It changes your Exchange Provider in the registry to the closest global catalog server.  Try it, it works.


    • Edited by Martilynn Tuesday, March 20, 2012 10:03 PM
    Tuesday, March 20, 2012 10:03 PM
  • My fix was a combination of: http://support.microsoft.com/?kbid=319206 and deleting the Outlook folder located in the USER\appdata\local\Microsoft\, it deleted an OST that was in there that SEEMS to have been a part of the problem.

    I have to keep an eye on this issue though. Not the first time I've had this series of errors on a machine here on my network and I'm wondering if I've got a boinked Exchange server that has an issue or two not smoothed out.

    Wednesday, June 13, 2012 3:28 PM
  • Hi guys,

    The same problem happens to me. However I have sucess in access via Outlook Web App and iPhone and the internal network, but always gives the same error when I try to set up an external exchange account in Outlook by creating a new profile. Does anyone can help me solve this issue?

    Thursday, June 21, 2012 9:18 PM
  • princedotnet...your "fix it" did it for me.  great work
    Wednesday, September 11, 2013 10:17 PM
  • Go to Services in Exchange server and run Microsoft address book and it is working...
    Monday, January 06, 2014 6:04 AM
  • I had this problem on a two node Exchange 2010 SP2 RU8 cluster. The clients were on Outlook 2010.

    After I updated to RU8 and did some .Net 4.5.1 patching a started to notice the problem.

    Symptoms:

    1. Could not configure Outlook for anyone in the Organization.
    2. Only the cached Address Book would work for my clients. When Outlook had to fetch an address that was not in their offline address book, Outlook would tell them the connection failed.

     

    The ANSWER for me was simple:

    I found the Service called “Microsoft Exchange Address Book” was not started, even though it was set to Automatic and the server was restarted after the updates. Once I turned on this service everything was rainbows and unicorns.

    Monday, March 17, 2014 4:21 PM