none
Outlook Anywhere from outside

    Question

  • Hello,

    I connect Outlook Anywhere (Exchange 2007) over HTTPS and it works internaly but I cannot manage to make it work once I am outside the company.

    Could you please tell me waht is wrong? Do I need to configure or define something?

    Thanks to all,
    Graig

    • Edited by Graiggoriz Monday, January 18, 2010 3:55 PM
    Monday, January 18, 2010 3:50 PM

All replies

  • Did you configure your firewall/router to forward HTTPS traffic (port 443) to the OWA server?
    Outlook Web Access For PDA , OWA For WAP
    www.owa-pda.com
    email a@t leederbyshire d.0.t c.0.m
    Monday, January 18, 2010 3:53 PM
  • Hi Graig,

     

    If the Outlook Anywhere works internally, I think that the Outlook Anywhere is configured correctly on Exchange server.

     

    Important Note: To ensure Outlook Anywhere works internally, you need to right click the Outlook icon and click Connection Status. For Outlook Anywhere connections, all the Conns should be HTTPs instead of TCP/IP. Otherwise, the Outlook does not connect to Exchange through Outlook Anywhere.

     

    At this time, please check whether the external Client trust the certificate installed on the CAS. You can verify this by access following URL on the external client:

     

    https://outlookanywhereFQDN/rpc/rpcproxy.dll

     

    You should not get any Certificate related warning. Otherwise, you need to solve the certificate issue firstly.

     

    If the certificate is Ok, please refer to the suggestion of Lee to check whether the firewall (or other devices) are configured correctly to proxy HTTPs traffic to CAS server.

     

    ~~~~~~~~~~~~~~~~

    Mike Shen

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please  contact tngfb@microsoft.com 

    ~~~~~~~~~~~~~~~~

     

    Tuesday, January 19, 2010 6:57 AM
  • Hello Mike,

    Just for information we installed SAN cert with multi names:

    True Business ID SAN: 1 FQDN + 3 SANs

    - Mail.myorg.com (FQDN)
    o    Autodsicover.myorg.com (SAN)
    o    Mail.mysecondorg.com (SAN)
    o    Autodiscover.mysecondorg.com (SAN)

    I then first tried your test with https://outlookanywhereFQDN/rpc/rpcproxy.dll

    And got the below result

    <!-- [if gte mso 9]><xml> <w:WordDocument> <w:View>Normal</w:View> <w:Zoom>0</w:Zoom> <w:PunctuationKerning/> <w:ValidateAgainstSchemas/> <w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid> <w:IgnoreMixedContent>false</w:IgnoreMixedContent> <w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText> <w:Compatibility> <w:BreakWrappedTables/> <w:SnapToGridInCell/> <w:WrapTextWithPunct/> <w:UseAsianBreakRules/> <w:DontGrowAutofit/> </w:Compatibility> <w:BrowserLevel>MicrosoftInternetExplorer4</w:BrowserLevel> </w:WordDocument> </xml><![endif]--><!-- [if gte mso 9]><xml> <w:LatentStyles DefLockedState="false" LatentStyleCount="156"> </w:LatentStyles> </xml><![endif]--> <!-- /* Font Definitions */ @font-face {font-family:Wingdings; panose-1:5 0 0 0 0 0 0 0 0 0; mso-font-charset:2; mso-generic-font-family:auto; mso-font-pitch:variable; mso-font-signature:0 268435456 0 0 -2147483648 0;} /* Style Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal {mso-style-parent:""; margin:0in; margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:12.0pt; font-family:"Times New Roman"; mso-fareast-font-family:"Times New Roman";} a:link, span.MsoHyperlink {color:blue; text-decoration:underline; text-underline:single;} a:visited, span.MsoHyperlinkFollowed {color:#606420; text-decoration:underline; text-underline:single;} @page Section1 {size:8.5in 11.0in; margin:1.0in 1.25in 1.0in 1.25in; mso-header-margin:.5in; mso-footer-margin:.5in; mso-paper-source:0;} div.Section1 {page:Section1;} --> <!-- [if gte mso 10]> <style> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;} </style> <![endif]-->

    *Test 1:

    https://mail. Mysecondorg .com/rpc/rpcproxy.dll

    Reaching à https://mail. Mysecondorg .com/CookieAuth.dll?GetLogon?reason=0&formdir=1&curl=Z2Fowa

      And connect to OWA = OK

     

    *Test 2:

     https://mail. Myorg .com/rpc/rpcproxy.dll

    Reaching à https://mail. Myorg .com/CookieAuth.dll?GetLogon?curl=Z2FrpcZ2Frpcproxy.dll&reason=0&formdir=3

     

    Got the below error message:

     

    Webpage cannot be displayed 

    Connexion with the Web server has been closed.

    --------------------------------------------------------------------------------

    Error code 64

    Wednesday, January 20, 2010 9:51 AM
  • Hi..

    Check your outlook anywhere function with this tool: https://www.testexchangeconnectivity.com.
    Get the error an fix it..
    Wednesday, January 20, 2010 11:43 AM
  • Hi,

     

    1. You need to use the external host name which you configured when enable Outlook Anywhere to access the URL from external Outlook client:

     

    https://outlookanywhere/rpc/rpcproxy.dll

     

    Note 1: You need to the ensure the external host name can be resolved to correct IP address.

    Note 2: If you do not get any certificate related error, I think that the Outlook trust the certificate. When access the URL, you should be prompted for authentication. After authentication, you should get a blank page

     

    2. I agree with Endrik, please also use https://www.testexchangeconnectivity.com to test Outlook Anywhere connection issue.

     

    Thanks

    Mike

     

    Thursday, January 21, 2010 3:46 AM