none
Autodiscover keeps changing to Basic Authentication

    Question

  • Hi,

    Every time I configure a customers Outlook I choose NTLM but as soon as autodiscover pops in it changes to Basic Authentication. Doesn't matter how many times I change it back.

    How do I make autodiscover use NTLM as standard?

    Friday, May 04, 2012 2:17 PM

Answers

  • Hi,

    have you tried to configure the Outlook Anywhere protocol on Exchange 2010 Server

    Set-OutlookAnywhere -Name Server01 -ClientAuthenticationMethod NTLM


    regards Thomas Paetzold visit my blog on: http://sus42.wordpress.com

    • Marked as answer by PatricF Tuesday, May 08, 2012 7:58 AM
    Friday, May 04, 2012 8:49 PM

All replies

  • Hi,

    why do you want to use NTLM and perhaps not kerberos. If using an Exchange Proxyserver setting (Outlook anywhere) you are able to secure the datatransfer using SSL. So I thnk the configuration setting basic Austhentification is quite well.


    regards Thomas Paetzold visit my blog on: http://sus42.wordpress.com

    Friday, May 04, 2012 7:56 PM
  • Well Basic Authentication keeps asking for password even if you check the "Save password"-box.. Everywhere I've read it says that Basic does this and NTLM does not.

    I don't care what kind of authentication it is, if it just works it's fine by me!

    But maybe this is different when running multi-tenant, I don't know?

    Friday, May 04, 2012 8:38 PM
  • Hi,

    have you tried to configure the Outlook Anywhere protocol on Exchange 2010 Server

    Set-OutlookAnywhere -Name Server01 -ClientAuthenticationMethod NTLM


    regards Thomas Paetzold visit my blog on: http://sus42.wordpress.com

    • Marked as answer by PatricF Tuesday, May 08, 2012 7:58 AM
    Friday, May 04, 2012 8:49 PM
  • Thanks! I looks like it doesn't change back to Basic anymore. However it didn't fix things that I thought it would, keeps asking for password.. Though it looks like it only asks for password on Outlook 2007, Outlook 2010 works just fine...

    Well I guess I'll have to keep looking.

    Friday, May 04, 2012 9:26 PM
  • Outlook 2007 will keep asking for a password unless the server and password are stored in the windows/cached credtial store. Outlook 2010 is sounds like has stopped, which is good, but surprising really.

    With Outlook Anywhere generally Basic will always cause an auth pop-up, and NTLM will too, unless the client machine is using cached credentials and sending those.

    If your clients are not domain members (and I'll assume they aren't given you are hosting) then pop ups can and happen.

    Have you disabled the msstd: certificate principal name settings too by any chance? That makes it worse.

    Friday, May 04, 2012 9:44 PM
  • Hi PatricF,

    could I help you? If your question is answered it would be nice if you mark it accordingly because this may help others who have got the same or a similar question.

    Thanks a lot in advance.

    Kind regards

     Thomas


    regards Thomas Paetzold visit my blog on: http://sus42.wordpress.com

    Monday, May 07, 2012 8:55 AM