none
Exchange SMTP connectors are invalid

    Question

  • I am getting the Potential network issue "Exchange SMTP connectors are invalid" when I run Fix my network, in sbs 2008. Further the wizard says "Exchange is not configured to communicate over your local network".

    I have been trying to reset these connectors, since currently it is unable to send mail out of the domain.

    I'm trying to understand the basic organization Exchange is using for sbs. It seems there are two send connectors and two receive connectors (one for the local exchange server and one for SBS). It would be great to have a brief explanation of why two are needed for send and receive. Could I run it with just one send and one receive? Can anyone direct me to the default settings for these connectors (for example in a newly installed sbs system) so that I can restore them to working condition?

    If not, I'll be able to provide the details on the settings for all 4 connectors. But at this stage I'm trying to get a general understanding of what the problem is and how to fix.

     

    Sunday, July 25, 2010 7:32 AM

Answers

All replies

  • Hi Jeff,

    This issue may occur if the related Receive connector Authentication
    settings are not correctly configured.

    1. Open the console as Administrator
    2. Expand Server Configuration > Hub Transport > click on Receive
    Connectors and go to properties of the Windows SBS Internet Receive
    connector
    3. Click on Authentication and uncheck everything but Transport Layer
    Security (TLS)
    4. Similarly, change the Authentication method for Default SMTP connector
    to enable TLS, Basic Authentication, Exchange Server authentication, and
    Integrated Windows authentication.

    5. Rerun the wizard.

    Does the issue still occur now?


    Check these articles


    How to Configure Non-Authoritative Accepted Domains in SBS 2008 (Exchange
    2007)
    http://blogs.technet.com/sbs/archive...re-non-authori
    tative-accepted-domains-in-sbs-2008-exchange-2007.aspx

    If you would like to check the wizard logs, please check below article:

    Key Small Business Server 2008 Log Files
    http://blogs.technet.com/sbs/archive...ness-server-20
    08-log-files.aspx

    Hope this helps.

     

    Regards.

    Shafaquat Ali.


    M.C.I.T.P Exchange 2007/2010, M.C.I.T.P Windows Server 2008, M.C.T.S OCS Server 2007 R2, Phone: +923008210320
    Sunday, July 25, 2010 7:42 AM
  • Thanks for responding! I checked the settings you pointed to, but they were already set as you recommended.

    I reviewed the links you sent, but they couldn't be resolved to a particular article (I included both lines of the link, so http://blogs.technet.com/sbs/archive...ness-server-20 is not found - is there something missing at the ... section of the link?).08-log-files.aspx


    if you have any other checks, I eagerly await them.

    Sunday, July 25, 2010 5:32 PM
  • Hi ,

    Sorry link was corrupt  check these ones.

    http://blogs.technet.com/b/sbs/archive/2008/09/25/how-to-configure-non-authoritative-accepted-domains-in-sbs-2008-exchange-2007.aspx

    http://blogs.technet.com/b/sbs/archive/2008/10/01/key-small-business-server-2008-log-files.aspx

     

    I hope this will help

     

    Regards.

    Shafaquat Ali.


    M.C.I.T.P Exchange 2007/2010, M.C.I.T.P Windows Server 2008, M.C.T.S OCS Server 2007 R2, Phone: +923008210320
    Sunday, July 25, 2010 6:09 PM
  • Hi,

     

    I'm getting this message too, although the SMTP mail is arriving through my SBS Internet Receive connector.  I've looked and I don't have a "Default Receive Connector".  I'm guessing this is the issue.  Can anyone please post what the out of the box settings should be for this connector so I can recreate it?

    Friday, February 04, 2011 3:55 PM
  • It seems that "Exchange SMTP connectors are invalid" message is a bug in "Fix my network" wizard. I have spend some hours in investigating the problem and noticed that the only way to avoid that stupid message is to do the following steps:

    1. open exchange console
    2. go to server configuration->hub transport.
    3. remove all receive connectors except "Default [servername]" ( if you miss that you must create it yourself, search the web how to do it)
    4. run "Fix my network" wizard again
    5. when you see "Exchange SMTP connectors are invalid", allow the wizard to repair/reconfigure connectors.
    6. the wizard should now succesfuly recreate missing connectors

    At this moment you should have 3 connectors (if you have Internet Domain Name connected) or 2 connectors if without domain. The fix wizard should not report any invalid connectors from now.

    But when you modify in any way any connector, then our message will apear again. Undoing your changes will not help (this is the bug in wizard), you will see our unwanted message until you allow the wizard to recreate connectors as described above.

    Pay attention that the "Fix my network" wizard has the log file at C:\Program Files\Windows Small Business Server\Logs\fncw.log. Look this file, mayby you will see why your connetors are invalid.

    I hope this help with your strugle with "Fix my network" wizard.

    Saturday, April 02, 2011 6:17 PM
  • I've just completed migration from SBS 2003 to SBS 2011, and as the last step I ran was "Connect to the Internet" wizard when the SBS 2003 was removed from the network. In this wizard there's an options is to change the IP-address of the SBS 2011 server, so I changed the IP-address from the temporary address to a more permanent one.

    But there's obviously is a bug in this  "Connect to the Internet" wizard because both Hub Transport Receive Connector / Default <sbs2011> and Windows SBS Internet Receive <server> pointed to the old server IP-address.

    I've also had to fix several A-records in DNS where the server IP-address hasn't been updated.


    MWebjorn

    Tuesday, October 16, 2012 7:15 PM
  • On Tue, 16 Oct 2012 19:15:20 +0000, MWebjorn wrote:
     
    >I've just completed migration from SBS 2003 to SBS 2011, and as the last step I ran was "Connect to the Internet" wizard when the SBS 2003 was removed from the network. In this wizard there's an options is to change the IP-address of the SBS 2011 server, so I changed the IP-address from the temporary address to a more permanent one.
    >
    >But there's obviously is a bug in this "Connect to the Internet" wizard because both Hub Transport Receive Connector / Default <sbs2011> and Windows SBS Internet Receive <server> pointed to the old server IP-address.
    >
    >I've also had to fix several A-records in DNS where the server IP-address hasn't been updated.
     
    This is a SBS problem, not an Exchange problem.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Tuesday, October 16, 2012 9:42 PM