none
Error removing old partnerships

    Question

  • I was just looking to clean up the Partnership list to just current devices.  I had recently wiped a lost device so was going through everyone.  My account for example has many devices listed as I have tested out many droids & iOS to make sure they work for people.  It will not let me remove the old devices though always instantly errors saying it cannot find the device.  Pic below of GUI error and PS of device partnerships.

    However it shows all the last sync times, etc from when the devices were used.  While I have reset the phones just as a security precaution I'd like to remove previous devices and unused devices from all the users.  I didn't see any other posts on this particular issue or any PS out there to remove old ones either, if anyone knows a way to force it to drop these old partnerships I'd appreciate it.  If anyone knows a way using PS I'd appreciate it even more as it is more efficient than the GUI.


    • Edited by jzenno Tuesday, March 13, 2012 5:59 PM
    Tuesday, March 13, 2012 5:53 PM

Answers

All replies

  • Hi,

    We can try to set HasActiveSyncDevicePartnership to false.

    Please try to remote wipe the device from OWA

    Managing your Active Sync Device from Outlook Web Access in Exchange 2007 SP1

    http://blogs.technet.com/b/exchange/archive/2007/05/30/3402915.aspx

    Besides, I find the following cmdlt from internet for your reference, you may modify the cmdlet a little.

    Get-CASMailbox -ResultSize unlimited -Filter{(HasActiveSyncDevicePartnership -eq $true) -AND (name -notlike "cas_*") -AND (name -notlike "DiscoverysearchMailbox*")} | ForEach {Get-ActiveSyncDeviceStatistics -Mailbox:$_.Identity | Where-Object {$_.LastSuccessSync -le (Get-Date).AddDays("-7")}} | Remove-ActiveSyncDevice


    Xiu Zhang

    TechNet Community Support

    Thursday, March 15, 2012 7:50 AM
  • Hi,

    How is the issue now?


    Xiu Zhang

    TechNet Community Support

    Monday, March 19, 2012 6:32 AM
  • I love how you just self mark it an answer.  Confident aren't we, haha.  I have not had a chance to give it a try, had a rollout for another system to do this weekend so hope to get back to this by the end of week.
    Tuesday, March 20, 2012 4:00 PM
  • Hi,

    As our policy required, we need to close the thread with the possible answer within 7 days if we do not get response from community.

    If the answer is not the right solution to your issue, you can unmark it.

    Also if you get update, welcome to post here.

    Thanks.


    Xiu Zhang

    TechNet Community Support

    Wednesday, March 21, 2012 6:21 AM