none
Cannot directly book a resource for this meeting

    Question

  •  

    Ever since I updgraded Outlook from 2003 to 2007, I am no longer able to add or remove resources to or from meetings I've created in my calendar.  When I either create a new meeting or open the item in my calendar and delete the meeting, upon sending the Meeting or Cancellation Request to the resource, I receive the error, "The object could not be found.  Cannot directly book a resource for this meeting."

     

    I never received this error prior to upgrading to Outlook 2007 and I do have access to book meetings with all resources in my Exchange environment.  I am however able to copy my meetings into the calendar directly.  I have also setup my account on another machine and receive the same problem.  I am the only user running Outlook 2007, everyone else is running Outlook 2003 with no problems.  The following is my environment:

     

    Exchange Server 2003 (version 6.5 build 7638.2 service pack 2)

    Outlook 2007 (version 12.0.6023.5000)

     

    Thursday, October 04, 2007 7:00 PM

All replies

  • I get same problem.  Anyone have any clues??

     

    Saturday, January 05, 2008 1:58 AM
  • I am getting the same problem.. And it's a business critical need to be able to schedule these meetings. So it's really frustrating that I haven't been able to find a fix.

     

    Wednesday, July 02, 2008 6:39 PM
  •  EngrUsr1 wrote:
    I am getting the same problem.. And it's a business critical need to be able to schedule these meetings. So it's really frustrating that I haven't been able to find a fix.

     



    Same problem here!!!
    Friday, September 26, 2008 8:51 AM
  • This suggestion worked for me...

    http://www.experts-exchange.com/Microsoft/Applications/Q_22693331.html

    Monday, September 29, 2008 4:21 PM
  • Well just signed up for the 7-day Free Trial at Exchange-Experts.com to find out that the "fix" was just:
    1) Disable Cached Mode and restart Outlook
    2) Re-enable Cahaced Mode and restart Outlook

    3) Try to book resource again.

     

    And the solution didn't work for me :-(

     

    Kinda confirmed what I already thought; Exchange-Experts isn't worth the cost.  Even the Free Trial ;-)

     

     

     

    Tuesday, October 07, 2008 4:41 PM
  • I had the same issue here. I went into Outlook 2007 and noticed that the permissions to the Calendar folder was set as Default-Free/Busy. I changed the Default to Reviewer and it worked!  I was able to set-up meeting request with a resource.

    • Proposed as answer by Max Edrets Thursday, April 16, 2009 12:45 PM
    Wednesday, February 04, 2009 10:27 PM
  • Had a user with this same problem. One day it worked, a few weeks later it didn't. Tried different things then discovered our  storage group for "Public Folders Database" (we have Public Folders in Outlook) on Exchange 2007 Server Configuration was dismounted. When we mounted Public Folder Database, problem went away.

    Wednesday, March 04, 2009 3:16 PM
  • I had the same issue here. I went into Outlook 2007 and noticed that the permissions to the Calendar folder was set as Default-Free/Busy. I changed the Default to Reviewer and it worked!  I was able to set-up meeting request with a resource.


    Thursday, April 16, 2009 12:51 PM
  • I had the same issue but "Reviewer" permissions did not work for me.  I checked the following permissions. 

    Read: Free/Busy time
    Write: Create Items and Edit Own
    Delete Items: Own
    Other: Folder Visible

    This worked for us.

    Thursday, September 03, 2009 3:18 PM
  • Had a user with this same problem. One day it worked, a few weeks later it didn't. Tried different things then discovered our  storage group for "Public Folders Database" (we have Public Folders in Outlook) on Exchange 2007 Server Configuration was dismounted. When we mounted Public Folder Database, problem went away.



    Just had this problem, this fixed it for me, as well.
    • Proposed as answer by RSchauer77 Friday, January 07, 2011 12:43 AM
    Wednesday, January 27, 2010 2:50 PM
  • Not to sound like Mr Obvious, but a simple reboot of the client workstation has fixed this in all of our cases.
    • Proposed as answer by RSchauer77 Friday, January 07, 2011 12:45 AM
    Friday, January 07, 2011 12:44 AM
  • Well, a reboot did not help in my case.

    I'm using Outlook 2007 with MS Exchange Server.  We finally found the reason: the flag "Use Cached Exchange Mode" in the email account properties was not checked.


    Thursday, July 07, 2011 4:01 PM
  • Hi

    If you are having enough permission to book the room and if you face issue when upgrading to outlook 2007. Instead of using the same outlook profile.

    Recreate the outlook profile, this will refersh your profile configuration and result in receiving new configuration information from server, it will solve all the problems

    Thursday, July 07, 2011 7:35 PM
  • You may want to try running Outlook like this: Outlook.exe /cleanreminders.

    I work at a Help Desk and have had at least 4 instances where a user has called in with this error and using the /cleanreminders switch has corrected it every time.

    Saturday, July 16, 2011 12:16 AM
  • Start, Run, "outlook.exe /cleanfreebusy" fixed the issue for me.
    Thursday, February 16, 2012 8:23 PM
  • Start, Run, "outlook.exe /cleanfreebusy" fixed the issue for me.

    This worked for me..  But, before doing this, Close the outlook form Task manager and do the CleanfreeBusy.

    If this didnt help you, Clear the "Forms and Cache" Manually.

    Will definitely work.

    Monday, May 21, 2012 4:29 PM
  • This worked for me...

    Changed calendar permissions to "Full write access"

    Disabled Cached Exchange, Closed/reopened Outlook

    Enabled Cached Exchange, Closed/reopened Outlook

    She was now able to book her conference room.

    Tuesday, September 17, 2013 12:43 PM