none
Outlook is losing connection to Exchange Server

    Question

  • We are using Outlook versions 2003 and 2007 in cached mode on Exchange servers 2003 and 2007. Some users are complaining that from time to time Outlook is losing the connection to the Exchange Server. Not all users have the same problem. Some users do not experience this problem, some users several times a day. Once outlook is trying the reestablish connection with the Exchange Server, Outlook is blocked for a maximum of 90 seconds.

    We checked the event log on the client machines as well as on our Exchange servers and could not find any event log entries that correspond to this problem. The problem exists for clients that are connected internally (LAN) as well as externally (internet). Additionally, we have the same problem for different customers with seperate networks.

    Does anybody have an idea how to solve this problem?
    Thanks for your help

    Tuesday, September 01, 2009 1:26 PM

All replies

  • Which version of Windows you have with Exchange? This might be possible with SNP feature of Windows 2003 SP2 if it is enable....

    Windows 2003 Scalable Networking pack and its possible effects on Exchange

    • Try installing SNP hotfix available @ http://support.microsoft.com/kb/950224
    • Update all network card firmware and drivers if you find any latest at vendor's website.
    • Also verify that Network speed is configured manually as per the second end router/switch speed configured.

    Amit Tank | MVP – Exchange Server | MCITP: EMA | MCSA: M | http://ExchangeShare.WordPress.com

    Tuesday, September 01, 2009 4:44 PM
  • I think Amit's first suggestion is on target, but I hope you will follow up with your results.  I had Microsoft field engineer strongly suggest I install the hotfix that Amit suggestions.  My servers have not seen any problems, but it is still a good idea to install it.  You can read a bit more about the problem and the fix here:
    http://msexchangeteam.com/archive/2007/07/18/446400.aspx
    http://msexchangeteam.com/archive/2008/03/12/448421.aspx 
    Jim McBee - Blog - http://mostlyexchange.blogspot.com
    Tuesday, September 01, 2009 5:08 PM
  • Thanks for the information. We have Windows 2003 R2 Enterprise Edition SP2 underlying our Exchange Servers. I will read the suggestested material and check if we are up to date.
    Wednesday, September 02, 2009 7:01 AM
  • We have installed the update 948496 for W2K03 Servers that is mentioned in the second article already back October last year. Therefore, the scalable networking pack features should be disabled. Where can I check if the feature is really disabled and how could I enable this feature again.

    Also we have broadcom nic's installed but the driver version is the recommended 3.7.19.0. I may try to install the newest version which should be 12.26.02 according the broadcom homepage.

    I will also check the Network speed settings.

    Wednesday, September 02, 2009 7:36 AM
  • I would also try running the EXBPA to check the health of servers and to find out if there is any issue with firware.

    http://www.microsoft.com/downloads/details.aspx?FamilyID=DBAB201F-4BEE-4943-AC22-E2DDBD258DF3&displaylang=en
    Vinod |CCNA|MCSE 2003 +Messaging|MCTS|ITIL V3|
    Wednesday, September 02, 2009 9:44 AM
  • Are there any Outlook "add-ons" on the machines having the problems that is not on the "working" clients?
    Wednesday, September 02, 2009 2:09 PM
  • Have you tried opening Outlook in safe mode? 
    Are you familiar with running ExMon?  I would run Exmon and review the results.  This will help you to narrow down what on the specific workstations (possible add-ons) is causing the problem. 
    Also, if you perform perfwiz on the exchange server, that may provide some good results.
    Do you have blackberry in your environment?  If so, how many users?  How many exchange mailbox servers?  Is Outlook in Cached mode or online mode? 
    Last but not least, run the ExBPA that will give you a great deal of help.  I would highly suggest running this tool every week or two weeks to keep your exchange environment healthy.

    good luck
    Wednesday, September 02, 2009 2:54 PM
  • Check your domain controllers!  If a DC has undersized memory and exchange is performing look ups against the GC users will see this type of error message.  I have seen this in more than one production environment with DCs that have 1GB of RAM or is a undersize VM and are checked as Global Catalogs.  The way to resolve this is to add more ram, at least two Gigs, or remove the GC role from the DC. 
    SF - MCITP:EMA, MCTS: MOSS 2007, OCS 2007, Exchange 2007
    Wednesday, September 02, 2009 6:40 PM
  • Hi,

    Please check whether huge amounts of RPC are sending to Exchange Server which cause the Exchange performance to be decreased, then the Exchange server send the "back-off" request to the client limit the number of operations that the client performs again the Exchange server.

    For more information, please refer to the below article:
    http://technet.microsoft.com/en-us/library/cc540454.aspx

    Thanks

    Allen
    Thursday, September 03, 2009 8:47 AM
  • First of all, thank you very much for your help. I appreciate all your input very much.

    So far, we have not found a solution but off course it takes a while until we will be able to see the effects. I have used the best practice analyzer as well as the troubleshooting assistant. Both tools gave back several critical issues. For example, maxpagesize is set too high as well as the HeapDecommitFreeBlockThreshold is not set at all. We are changing now the values one at a time in order to see the consequences. As soon as I see some results, I will post it off course.

    Thanks again
    Thursday, September 03, 2009 12:49 PM
  • Is there a recommended time interval to reboot an exchange server? Every month or so?  For example, we reboot our terminal servers with Citrix every night. Our exchange server was not rebooted for the last 103 days...... This might help as well.....

    Thanks for your input
    Thursday, September 03, 2009 3:02 PM
  • Don't you update Exchange and Windows for latest hotfix or updates available every month? If so, you may need to reboot during that time otherwise there isn't any real recommendation to reboot the server at regular interval and mail service is the thing which requires highest uptime in any organization... ;)

    Amit Tank | MVP – Exchange Server | MCITP: EMA | MCSA: M | http://ExchangeShare.WordPress.com

    Thursday, September 03, 2009 3:10 PM
  • I found this post that solved this problem... Just to let everyone knows that the outlook connectivity problem was caused by the enabled PROXY ARP in the pix for Inside interface.  As soon as I disabled the Proxy ARP for the inside interface the problem had disappeared for good.

    It worked for us too.


    Helpful nice guy
    Thursday, April 15, 2010 6:59 PM