none
NDR - Email Address Couldnt Be found

    Question

  • I had 2 users (UserA and UserB) who had their mailbox disabled.  Their email addresses were then added to different user's (UserC) mailbox.  External users can email UserA and UserB and UserC will get the email.  However, when internal user try to email UserA and B, they get an NDR of Email Address Couldnt Be Found.

    I tried updating the GAL but that didn't help.  I've ran into this problem in the past, and usually when the GAL gets regenerated, it fixes the problem.  HOwever, it's been 2 days and I'm still getting the same error. 

    Can someone explain to me what's causing this problem and how I can fix this?

    Wednesday, March 16, 2011 3:10 PM

Answers

  • Sounds like a cache issue.  If the user is using Outlook 2007 have the user delete the Outlook entry to UserA and UserB and have them send from the GAL or delete their NK2 file which houses all the address cache.  If the user is using Cached Mode then it's possible the GAL is not up to date.  Have them uncheck cached mode and download the address book.

    If using Outlook 2010 then again have them repeat the procedures above.  In Outlook 2010 the NK2 file does not exist so they can clear their entire cache by the following:

    Click on File

    Click on Options

    Click on Mail

    Under Send messages click Empty Auto-Complete List

    • Marked as answer by Frank.Wang Wednesday, March 23, 2011 1:05 AM
    Wednesday, March 16, 2011 3:36 PM

All replies

  • Sounds like a cache issue.  If the user is using Outlook 2007 have the user delete the Outlook entry to UserA and UserB and have them send from the GAL or delete their NK2 file which houses all the address cache.  If the user is using Cached Mode then it's possible the GAL is not up to date.  Have them uncheck cached mode and download the address book.

    If using Outlook 2010 then again have them repeat the procedures above.  In Outlook 2010 the NK2 file does not exist so they can clear their entire cache by the following:

    Click on File

    Click on Options

    Click on Mail

    Under Send messages click Empty Auto-Complete List

    • Marked as answer by Frank.Wang Wednesday, March 23, 2011 1:05 AM
    Wednesday, March 16, 2011 3:36 PM
  • Hi pham0329,

    Any updates?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, March 22, 2011 6:26 AM