none
"Cannot open your default e-mail folders." from Outlook client across network

    Question

  • Hi,

    I've successfully installed EX2010 on my Windows 2008 server, and locally everything seems to be working great.  I can run Outlook 2007 directly on the server and it will open mailboxes fine.

    However from a client computer over the network (XP SP3), running Outlook 2003 or Outlook 2007, I get the error saying the Exchange server is unavailable.

    At first I thought it was the Outlook 2003 client since I didn't allow exchange setup to create a public folder database, so I tried upgrading to Outlook 2007, but the same thing happened.

    I've tried switching on encryption in my MAPI profile, and ...   hang on just thought of something...

    ok, I found that the MAPI profile which already existed for Outlook 2003 needed to be blown away and re-created after Outlook 2007 was installed.  Its now all working.  So I'm guessing the 2003 issue was the lack of a public folder database as I first suspected?
    Wednesday, September 02, 2009 11:01 PM

Answers

  • By default outlook 2003 profile is disabled to communicate with Exchange 2010 server over Encrypted RPC so that is the reason it can't connect to exchange server.

    Henrik explained this on his blog here... 


    You can either...

    • Enable RPC encryption in the Outlook 2003 profile. (Recommended...)

    OR
    • Disable the RPC encryption requirement on the Exchange 2010 Client Access server (not recommended, but of course in lab you can...)
              Set-RpcClientAccess –Server –EncryptionRequired $false

    Amit Tank | MVP – Exchange Server | MCITP: EMA | MCSA: M | http://ExchangeShare.WordPress.com

    • Proposed as answer by Amit Tank Thursday, September 03, 2009 5:48 AM
    • Marked as answer by Alan.GimModerator Friday, September 04, 2009 5:33 AM
    Thursday, September 03, 2009 5:47 AM

All replies

  • By default outlook 2003 profile is disabled to communicate with Exchange 2010 server over Encrypted RPC so that is the reason it can't connect to exchange server.

    Henrik explained this on his blog here... 


    You can either...

    • Enable RPC encryption in the Outlook 2003 profile. (Recommended...)

    OR
    • Disable the RPC encryption requirement on the Exchange 2010 Client Access server (not recommended, but of course in lab you can...)
              Set-RpcClientAccess –Server –EncryptionRequired $false

    Amit Tank | MVP – Exchange Server | MCITP: EMA | MCSA: M | http://ExchangeShare.WordPress.com

    • Proposed as answer by Amit Tank Thursday, September 03, 2009 5:48 AM
    • Marked as answer by Alan.GimModerator Friday, September 04, 2009 5:33 AM
    Thursday, September 03, 2009 5:47 AM
  • Thanks, it works well for me :)
    Friday, September 04, 2009 2:41 AM
  • I am having a different, although seemingly related issue. I have tried to force encryption on the 2003 client and have also disable now the encryption requirement and I still get

    "Unable to open your default e-mail folders. The file C:\Documents and Settings\USERNAME.DOMAIN\Local Settings\Application Data\Microsoft\Outlook\outlook.ost cannot be accessed. You must connect to your Microsoft Exchange Server computer at least once before you can use your offline folder file."

    I have tried disabling the 'cached mode' and the error says I am offline and bails out if I choose anything but retry, which asks me to retry. Seems to me I ran into this with Outlook 2K on Exchange 5.5 9-10 years ago... but I don't remember what it was that I did to resolve it. Been googl'ing like crazy to get to the bottom of this.

    CLIENT(S): WinXP SP2 + Office 2003 SP2
    SERVER1: Windows 2K8 SP2, Domain member, Exchange 2010 (Hub/Mailbox/UM)
    SERVER2: Windows 2K8 SP2, Domain member, Exchange 2010 (CAS)
    SERVER3: Windows 2K3 SP2, AD, GC + FSMO master

    I am all ears if you know of a fix or have suggestions...
    • Proposed as answer by Catalic Wednesday, March 07, 2012 6:42 PM
    Wednesday, December 02, 2009 9:32 PM
  • Well, went and uninstalled all of the Exchange roles, reinstalled W2K8 SP2 and reinstalled Exg 2KX. Everything appears to be normal, except when I try and connect a fat client (Outlook 2003):

    "Unable to open your default e-mail folders. You must connect to your Microsoft Exchange Server computer with the current profile before you can syncronize your folders with your offline folder file."

    I do have an issue on the MBX/HUB/UM box when I run ExBPA:

    "The public folder store where the site offline address book is hosted was not detected. The hosting server may be unreachable or the public folder store does not exist. Public folder store: CN=Public Folder Database 1255594704,CN=Databases,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=XXXX,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=XXXX,DC=XXX."

    Related?

    Sean
    Wednesday, December 23, 2009 6:03 PM
  • Sean, I'm getting exactly the same issue , wondering did you managed to get it fixed. Please reply. Thanks
    Tuesday, January 12, 2010 5:32 PM
  • adil, try this post, I finally managed to get the Outlook clients to connect

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/74ede582-fd7a-4b4d-bf06-7fba865c0d73

    Sean
    Tuesday, January 12, 2010 5:48 PM
  • I was getting the "Cannot open your default e-mail folders. You must connect to your Microsoft Exchange Computer with the current profile before you syncronize your folders with your offline folder file." error and I found this post. Added the IP and Name of the Exchenge Server to the Hosts file and the error is gone now.

    http://forums.techarena.in/vista-help/941157.htm
    I fixed this by adding an entry to my hosts file. Outlook could not resolve the hostname it was using for the exchange server.
    If you ever notice, when setting up your Exchange profile, the server IP address or hostname that YOU supply will automatically be replaced by the hostname the exchange server communicates back.
    If this hostname happens to be an internal hostname or otherwise unresovable by Outlook when you thereafter open Outlook for the first time, then you will receive this error.
    In my case, the exchange server was communicating back an internal non-public hostname and so I added an entry for it to the windows\system32\drivers\etc\hosts file. Example:
    192.168.11.14 exchange.intranet.mycompany.com

    Hope it helps,
    Doru

    Doru Sandor, MCDBA/MCSD
    Friday, January 29, 2010 1:25 AM
  • Hi.

    configuring outlook 2003 for exchange 2010 please follow the steps below:

    1. open outlook

    2. specify the exchange server FQDN

    3. dont click on the check name tab > go to more setting >security > put the tick mark on encryption > apply

    4. Now you can click on the "check name" and now it will resolve the name

    Regards

    shivaprasad.V

     

     

    Friday, April 23, 2010 5:41 AM
  • Hi Shiva,

    Thanks for the Solution

    Regards

    MNYash


    • Edited by MNYash Tuesday, December 20, 2011 2:12 PM
    Friday, April 23, 2010 5:48 AM
  • WOW...good stuff. Still applies to this date...of course. Thank you Amit, you should change your first name to Frank...LOL

    Thanks again!

    Donald

    Monday, June 07, 2010 5:09 PM
  • Windows 7 and Outlook 2010 with exchange hosted email.   Had this problem, read all the solutions in this thread and nothing seemed to work.  I disconnected my internet connection, clicked on Outlook and it opened without a problem.  I then reconnected and it found Exchange.  Problem solved.  
    Sunday, February 19, 2012 8:49 AM
  • For what it's worth, at the company I work at we upgraded to a 2010 Exchange Server, and we still have about 200 clients using Office 2003.

    We now have Encryption enabled through Group Policy.  We have manually put most of our users in Cached Exchange Mode as recommended.

    Today a bunch of our users started getting:

    "Unable to open your default e-mail folders.  You must connect to your Microsoft exchange server computer with the current profile before you can synchronize your folders with your offline folder files"

    After a network outage that was resolved.

    Each one I checked had not been in Cached Exchange Mode, but we couldn't get the connection back for anything.  I tried creating a new profile, which usually works when Outlook 2003 disconnects and won't connect again, but it didn't.

    We wound up having to go into Connections (right there next to the Security tab in Amit's screenshot), enable HTTP, then go add our external exchange address/webmail address as the proxy server.

    It would be nice if Microsoft put out a warning, "Don't upgrade to Exchange 2010 without upgrading Office to at least 2007."


    Monday, February 27, 2012 8:51 PM
  • In my case (i.e., CAS/Hub colocated w/dedicated Mailbox server), needed to point outlook 2003 client to CAS server NOT mailbox server.

    akf

    Friday, April 13, 2012 1:48 PM
  • *** Add alternative UPN suffixes to AD Domains and Trusts Properties "UPN" tab ***

    History: We are moving to Exchange 2010, but still use Outlook 2003.  Lots of problems with Outlook refusing to open, with the "Cannot open your default e-mail folders" errors.  You can get some variations on the error message, depending on how you alter settings in the Control Panel "Mail 32-bit" app, which adds to the confusion without adding any useful information.

    The guy who posted about putting the IP address and hostname in the HOSTS file got me to thinking about interactions between Exchange and AD. We use an "external" domain name for Internet email, but the local network domain name is just the initials of the business name.  In Active Directory Domains and Trusts, the Properties (the ONLY property) allows you to add alternative UPN suffixes -- basically, domain names that can alias for the domain that Exchange Server 2010 INSISTS on using. This is similar in concept to adding entries to the HOSTS file, since you can give any number of names to one numeric IP address.

    Anyway, adding both of our UPN suffixes to AD Domains and Trusts fixed it.  I'm adding this Reply to the chain here because the fix is a little obscure, but I found no references to it in any other online documentation or FAQ.

    Friday, May 18, 2012 5:48 PM
  • I'm having similar problems with my (Domain Admin) account with Outlook 2010 and Exchange 2010.  OWA and Outlook 2003 on an XP Pro machine work great.  Email is sent and delivered successfully for these clients.

    Outlook 2010 32-bit on Win 7 machine1:

    "Cannot open your default e-mail folders.  Microsoft exchange is not available.  Either there are network problems or the Exchange server is down for maintenance."

    Outlook 2007 32-bit on Win 7 machine2:

    "Cannot open your default e-mail folders. You must connect to Microsoft Exchange with the current profile before you can synchronize your folders with your offline folder file."

    Outlook 2007 32-bit on Win 7 machine3:

    "Cannot open your default e-mail folders.  You must connect to Microsoft Exchange with the current profile before you can synchronize your folders with your Outlook data file (.ost)."

    Outlook 2010 32-bit on Win 7 laptop1: after 5 minutes of trying to load the Outlook profile

    "Cannot open your default e-mail folders.  You must connect to Microsoft Exchange with the current profile before you can synchronize your folders with your Outlook data file (.ost)."

    All four machines can ping the Exchange server.  The hosts files have been edited to contain the IP and Exchange server name.  Other authenticated users on the domain can log into Outlook on these machines.  I've deleted .ost files, I've deleted and recreated windows and Outlook profiles.  I've uninstalled\reinstalled and attempted to repair Office.  I done the "Outlook /resetnavpane" as many people on help sites have suggested - still no luck.

    No one else on the domain is reporting problems, therefore the Exchange server is running properly, but it hasn't been rebooted for a couple months.  Could there be something amiss with my account on the Exchange server that won't let me run Outlook on a Win 7 machine?

    Wednesday, August 22, 2012 11:29 PM
  • I was having the same problem with exchange 2010 for a single user resolved it my moving the user's mailbox to another database if you do not have another exchange server cerate a mailbox DB and move the mailbox there.


    patrik

    Tuesday, October 16, 2012 12:20 PM
  • What worked for me was creating a new mail profile.
    Thursday, January 10, 2013 8:35 PM
  • Had this problem with an Exchange 2003 server and Outlook 2007 clients. We enabled the TCP/IP chimney features and it worked.
    Tuesday, January 22, 2013 6:35 PM