none
Outlook gives an error for Proxy Server Certificate.

    Question

  • Hi,

    I am getting an error message when I started the Outlook. The message is as follows,

    There is a problem with the proxy server's security certificate. The name on the security certificate is invalid or does not match the name of the target site mail.abc-company.com.

    Outlook is unable to connect to the proxy server.(Error Code 10)

    I Use TMG 2010 as my proxy server for the internet and I need some help on this one to fix this.

    Can someone tll me how to fix this issue?

    Thanks

    Yosh,


    --------------------------------------------------------------------------------- YOSHIKA04 ------------------------------------------------------------------------------
    Friday, March 25, 2011 5:23 AM

Answers

  • Hello,

     

    Firstly, I would like to ask whether the symptom occurs on an Internal Outlook client or an external Outlook client.

     

    If it occurs on an External Outlook client, I think we are using Outlook Anywhere and we have to add the “mail.abc-company.com” to the domain names in the certificate.

     

    If the error occurs on Internal Outlook, we can workaround this issue by turning off “Outlook Anywhere” by:

     

    1. On a problematic Client, open Outlook.

    2. Click Tools >> Account settings.

    3. Double click the profile name and click More Settings.

    4. On the Connection tab, uncheck on “Connect to Microsoft Exchange using HTTP”.

    5. Save the changes and restart the Outlook to check this issue.

     

    Thanks,

    Simon

    • Marked as answer by Serena Li Sunday, April 03, 2011 3:44 PM
    Monday, March 28, 2011 1:48 AM
    Moderator

All replies

  • You need a valid certificate on both the Exchange server and on the TMG server.  How you accomplish that depends on your version of Exchange, and you didn't share that with us.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Friday, March 25, 2011 2:01 PM
  • Use the whitepaper here it's very straight forward with step by step instructions.

    Publishing Exchange Server 2010 with Forefront Unified Access Gateway 2010 and Forefront Threat Management Gateway 2010

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=894bab3e-c910-4c97-ab22-59e91421e022&displaylang=en


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Sunday, March 27, 2011 8:16 PM
  • Hello,

     

    Firstly, I would like to ask whether the symptom occurs on an Internal Outlook client or an external Outlook client.

     

    If it occurs on an External Outlook client, I think we are using Outlook Anywhere and we have to add the “mail.abc-company.com” to the domain names in the certificate.

     

    If the error occurs on Internal Outlook, we can workaround this issue by turning off “Outlook Anywhere” by:

     

    1. On a problematic Client, open Outlook.

    2. Click Tools >> Account settings.

    3. Double click the profile name and click More Settings.

    4. On the Connection tab, uncheck on “Connect to Microsoft Exchange using HTTP”.

    5. Save the changes and restart the Outlook to check this issue.

     

    Thanks,

    Simon

    • Marked as answer by Serena Li Sunday, April 03, 2011 3:44 PM
    Monday, March 28, 2011 1:48 AM
    Moderator
  • Hope you have resolved your issue. I encountered the same issue when I started using MS Outlook 2010. Seems like this proxy server problem is a Microsoft standard out-of-the-box feature.

    There are two certificates involved: 1) Root CA certificate, and 2) the server certificate. Please see the attached images. Install the Root CA into the Trusted Root Certification Authorities store. Install the server certifcate into the Trusted Publishers store.

    Then follow what Simon Wu suggests below.

     

     

     

     

    Wednesday, September 14, 2011 4:32 PM
  • Thank you Abel for your tip (it's a long time ago :-)). I'm going to try this tomorrow. I'm trying to solve this certificate problem for many days now.

    I have an Exchange 2007 (Windows SBS 2008) environment with Outlook 2007 clients. For all the clients it works well except on 1 client. Most clients make a vpn ssl connection with the network.

    I get the certificate error after I have to fill in the credentials every time when I open Outlook.

    I tried to reinstall the certificates but nothing helped yet.

    The things I checked:

    • User rights on the notebook
    • Reconnect notebook in domain
    • Install certificate many times (but not the 2 certificates like mentioned above)

    I need a solution very quick.

    Is there anyone who can give me some advice?

    Thanks in advance!

    M. Verkerk

    Thursday, February 16, 2012 7:28 PM
  • Hello
    There is an error in one of the only outside from outlook when outlook is running. VPn connection. , to which the link, I get the following error in outlook.

    There is a problem with the Proxy Server's security certificate. mail.abc.com proxy cannot connect to the server. error code 8.

    Thank you.

    Elif T.

    Thursday, March 08, 2012 12:26 PM
  • If it happens when you're running with a VPN then it's probably because your certificate doesn't have the name that you're using to connect to the server.  Do you use differnet names internally and externally?

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    • Proposed as answer by OakSJ Tuesday, January 15, 2013 5:05 AM
    Thursday, March 08, 2012 3:30 PM
  • Solved my problem.  Client doesn't install certificate, i installed manually certificate and then solved this issue.

    thanks.

    Monday, March 12, 2012 7:25 AM
  • Abel, I have tried all of these troubleshooting ideas, but nothing seems to get rid of this certificate. 

    1. I tried the installation of the certificate into the "trusted publishers"

    2.  Removed the connection to  microsoft exchange using http

    Is this a local issue with machine or server issue..Please I need help with this issue its is annoying.  I am not an exchange Guru by any means so any help will greatly be appreciated

    Brian

    Tuesday, October 16, 2012 1:08 PM
  • having the same problem, but where do I get the certificates?


    Ken Compter

    Thursday, November 29, 2012 9:07 PM
  • Hi Ed:

    I have a different public domain from the internal. This is happening with outlook anywhere. Have done the new cert with autodiscover. mobile and webmail seem fine. just this pesky issue. What suggestions do you have?


    The Big Lug

    Monday, January 21, 2013 7:22 PM
  • Good morning Simon, Your solution is workaround. My users use sometimes external outlook, and I don't want to turn off "Outlook Anywhere". Can you have another solution !
    Tuesday, February 19, 2013 3:38 PM