none
How to correct Email address in SMTP format instead of EX in GAL

    Question

  • When user click Global addressbook in outlook. They email address type appears in native exchange format "EX". How do i fix this so user can see in right smtp format.

    This is how email looks like in addressbook for outlook GAL:
    /o=domain/ou=site/cn=recipients/cn=johndoe

    This is how it should display the outlook global address book:
    johndoe@abc.com

    How can i fix this?

    Thanks

    SHAQ

    Wednesday, September 13, 2006 4:41 PM

All replies

  • I am also experiencing this same problem.  Any advice or point in the correct direction would be of help.
    Monday, September 18, 2006 5:33 PM
  • Same problem.  Were you able to find a fix?
    Thursday, October 19, 2006 3:43 PM
  • I still have not found the fix for this so I've somewhat backed off of pushing people to use the GAL.  We're a small organization so I have that luxury, but if someone has the fix or work-around, that'd be great because I'd like to populate our AD with much more information (office extension, location, etc) but I can't have users looking at that address instead of their "real" address.

    Please post if you find a solution.

    Thursday, October 19, 2006 3:59 PM
  • no luck.

     

    have you too experience this after the migration from old exchange environment?

    Thursday, October 19, 2006 4:30 PM
  • My experience isn't after a migration from an old environment.  This is just happening on a new install and setup.  I actually inherited the setup.  We're on the SBS2003 platform and this has been this way ever since.  We actually don't use the Exchange service that much as we have outside hosted email, however, I'd like to look into changing that in the future providing I can get all the "user visible" benefits of Exchange working and in place so that it's worth the migration to in-house hosted email.

    Thursday, October 19, 2006 6:46 PM
  • thanks.

     

    i wanted to see if this was related to migration. because i have done several fresh installation that did not result in same situation.

    i have not still found the resolution to this problem. i am to the point, i will open a ticket with msft.

    shakeel

     

    Thursday, October 19, 2006 8:49 PM
  • I'd be interested to know more if this is a product of migration.  I don't have a lot of the history at my current location.  (I am their first IT person)  So, if you find something or get results off of the ticket with MS, I would appreciate if you could share any info or solutions.

     

    Thursday, October 19, 2006 9:08 PM
  • I too think the issue is related to a recent migration from Exchange 5.5 and the use of Active Directory Connector.
    Thursday, October 19, 2006 9:18 PM
  • Shaq

    This one has been ongoing with me for months and I haven't been able to find a fix.  I don't believe this is to do with migration as it is happening on a new build exch 2003 box. 

    Please let me know if anyone can get an answer from MS..............

    Regards

    Podzol

    Monday, November 06, 2006 4:16 PM
  • Hello there fo you all

    I am not sure if I understand You question well... If not describe me more please

    Sollution is Easy: You have to change primary e-mail adresses to users. That You can do by two ways:

    Set this for every user or for selected users only easier is of every:

    In Exchange management go to recipiens and recipiens policy, open using policy (default is Default Policy) and go to E-Mail adress policy. There you choose that right email adress type and push Set as Primary button. If it is not in the list You have to create new email type.

    Creating new type od adress: In the Default Policy Properties, in E-Mail adress policy Click new, select SMTP and click OK. To the adress tab type f.e. @abc.com and click OK. Now You can see it on the list...

    ofter OK button on (default) Default Policy Properties click right button on the policy and choose Aply this policy now..

    Thats all falks:)

    Thursday, November 09, 2006 3:17 PM
  • Shaq has the issued described above in the first post of this thread.  There is not much more to it than that.

    And no, neither setting the correct smpt address as the primary address in the default recipient policy nor setting the correct smtp address as the primary address under each individual users credentials in the Active Directory User management interface solves the issue.

    Thanks for the suggestions though.

    Thursday, November 09, 2006 8:02 PM
  • Thanks for your suggestions.

    Marian, If it was that simple what you describing in your reply. I would have not even open this thread.

    The problem is much more complexed.

    Little more explanation about this problem.

    When you click on the Outlook addressbook, user see "exchange format" email address not "smtp type."  User AD attributes does show smtp as their primary email address. I don't even know how to setup exchange format. But it does show EX format.

    So all we need to know is how to change this in addressbook.

     

    Thanks

    SHAQ

    Thursday, November 09, 2006 8:50 PM
  • Hi Shaq,

    As I posted, maybe I didn't understand You well..:)

    but I mean, that is what I tried to tell you...

    OK, lets take a look to exchange messaging... X400 is that what You nemed EX format..? 

    x400 is intra-exchange protocol that doesn't using any outgoing connector. If in e-mail address tab in any recipients properties in address book in outlook is only X400:c=com;a=......ect. that is really problem of recipient  policy. How are you assigning e-mail addresses to users..? If You are doing it in AD users and computers in tab e-mail addresses in users prop., try to delete them all (in one users prop.) and use recipient policy to update users emails, because it is exchange, who build global address list, not AD - that can only add new address-but like an alias only.

    And, if You have more than one exchange servers, have to wait for replicas aprx. 15 mins to see right changes...

    try it, see it post it:)

    If I didn't understand You again, I'm sorry, and try to describe me what exactly You see and exactly where... but I mean I hit the target:)

    Friday, November 10, 2006 8:00 AM
  • Thanks Marian for your help.

    I wish i could show you in pictures the exact problem.

    i understand what x400 format is, and how to change it in recipient policy.

    Let me make this clear,

    fact 1 = exchange is working fine

    fact 2=  6 exchange servers in domain

    fact 3= 8 dc in domain

    fact 4= Recipient policy and ad account both are set smtp as primary email address for all users.

     

    problem,

    one small problem.  when user click on address book in outlook it shows correct name/last name phone number. But, their email address shows in "EX" format  

    /o=domain/ou=site/cn=recipients/cn=marian

    all i need is to show smtp format in addressbook

    johndoe@domain.com

     

    Hope this explain little better.

     

    SHAQ

     

     

     

    Friday, November 10, 2006 6:22 PM
  • Yes, definitely.  Don't over-complicate things trying to identify the issue.  Exchange environment working perfectly.  RUS and email addresses generate properly.  However, if a user goes to Outlook and clicks on the address book to view recipients in the GAL, the default address that appears is the X.400 address.  I want the SMTP address to appear instead.  Its just an annoyance, not a real issue.  RjZ
    Friday, November 10, 2006 8:24 PM
  • Monday, November 13, 2006 12:54 PM
  • Thanks PODZOl for posting this picture. I wanted everyone to see this , so we can get the answer.

     

     

    Monday, November 13, 2006 3:16 PM
  • Hi, now (thanks to picture) I see the problem...

    interested is, when You try to get same list in ESM, it is with smtp adresses.. I'll take a look..

    Wednesday, November 15, 2006 2:13 PM
  • This is possible....and it is very easy to implement.....but it creates a bad side effect for  your exchange users....If you folks like i will post it for you.....
    This is my first time posting in this forum.
    Saturday, December 02, 2006 9:49 AM
  • This problem also occurs when attempting to export to Excel or Access. This is an ugly workaround, but it does work. Enter the email address as: SMTP:billy.bob@wherever.com. That forces the type to SMTP, unfortunately, removing that after adding, switches the type back to EX. Seems to me EX is used when the exchange server you are connected to is also the host for the recipient--but I'm just guessing.
    Tuesday, December 12, 2006 1:26 AM
  • Here's an even better way (but please have someone who knows what they're talking about review it first)!

    I am attempting to export my Contacts folder to Excel or Access, and I keep getting the behavior described above, but only for certain recipients. The problem is that the email type is stored as EX instead of SMTP. Email type cannot be changed in Outlook.

    Open Microsoft Access, create a new, blank database, select File | Get External Data Link Tables

    In the Files of Type dropdown on the new window, select Outlook()

    In the Link Exchange/Microsoft Outlook, click on the Plus sign to the left of your Mailbox

    Select Contacts, click Next, then Finish

    Now you are controlling the Outlook Contacts folder in Access.

    Find the appropriate contact, change the Email Type to SMTP.

    Close Access.

    Outlook now shows it as SMTP.

    Tuesday, December 12, 2006 1:36 AM
  • Yeah, I've found a better way.

    Create the contact in Outlook and typo the e-mail address to something non-existent.

    Click to another field.

    Double-click the typo'd e-mail address.

    Correct the first two fields (Display Name & E-mail Address) and the field should be grayed out as SMTP, so you don't have to change that.

    OK.

    Save and close.

    Confirm entry with Ctrl-shift-b

    -Charles
    Sunday, January 14, 2007 5:36 AM
  • please explain this little further, i am not sure what you referring too.

     

    if you have solved this problem. please post the instructions.

    thanks

    izaq

    Monday, January 15, 2007 4:51 AM
  • I did post the instructions. What part was not clear?

    The fact is you have to create a fake address first via New Contact so Outlook doesn't look it up on Exchange. Then after you TAB out of the field, the e-mail address is underlined. Then you double click the address and you correct the Display Name and the E-mail Address. After that, the address will be in SMTP mode and not EX.

    Monday, January 15, 2007 6:13 AM
  • I'm having the same problem as others are describing here and haven't found a fix either?

    I had this problem as well with Exchange 2007 Beta 2, and that was a fresh install.  I moved to RTM with an Upgrade.

    Wednesday, January 17, 2007 9:47 AM
  • Hi,

    Has anyone tried to follow Michelle's suggestions? ie: Use Exchange admin to set up primary email address type?

    Monday, January 22, 2007 6:52 PM
  • Has anyone actually tried Marian's suggestion below:

    -------->

    In Exchange management go to recipiens and recipiens policy, open using policy (default is Default Policy) and go to E-Mail adress policy. There you choose that right email adress type and push Set as Primary button. If it is not in the list You have to create new email type.

    Creating new type od adress: In the Default Policy Properties, in E-Mail adress policy Click new, select SMTP and click OK. To the adress tab type f.e. @abc.com and click OK. Now You can see it on the list...

     <----------

    Monday, January 22, 2007 6:56 PM
  • This has been tried before. No luck
    Monday, January 22, 2007 10:21 PM
  • To add a custom smtp address you can use the following:

    Add a new recipient policy in exchange system manager, recipients, recipient policies. In the addresses bit add a new SMPT address; here's the format I use:

    %g@test.com uses the first (given name) like fred@test.com, %s@test.com  uses surname like bloggs@test.com and %g%1s@test.com gives fredb@test.com. You can use any number, such as %2g or %3s. There are other parameters; I don't have a list though.

    When you save it should ask if you want to update addresses. It does no harm to rebuild the recipient update policies AS LONG AS YOUR GAL is not LARGE! It ca just take time.

    I hope this helps

    Alan

    Tuesday, January 23, 2007 10:42 AM
  • FINALLY!!!!!!!  This is not an Exchange problem but an Outlook 2003 problem, just installed Outlook 2007 and this error has gone.

    HOW ABOUT A HOTFIX FOR 2003 MS?

    Thursday, March 01, 2007 4:59 PM
  • Hi Pod!

    I can assure that this is not an Outlook problem.
    Im having the same problem... ill post here when i find the solution.

    Thursday, March 29, 2007 6:56 PM
  • Hallo,

    There is a way to save email address at SMTP type (Outlook 2003).

    When you create new entry in the Contact list there is important thing to choose :

    Put this entry

    (at first opening you have to choose some Address List ( Contact - for example)) .

     

    After that when you want to put e-mail adrese don't write it manualy now.

    Click on the button to choose e-mail address at the right side of the e-mail field.

    Now, it is opened clasic window to choose e-mail address from address book.

    Go to the left down corner and Choose: Advanced->New

    Now, there is again window to put new entry,

    but now,

    You can select option In this message only and choose Internet Address and the rest is easy... 

     

    I am sure this is working, I tried it  !!!

     

    Monday, April 09, 2007 12:45 PM
  •  

    There are several attributes used in AD for e-mail addresses, mail, proxyAddresses, textEncodedOrAddress and targetAddress

     

    The EX format address you are talking about is the legacyExchangeDN attribute.

     

    Exchange typically uses the legacyExchangeDN if one of the required attributes is empty, I'm suspecting the mail attribute or the textEncodedOrAddress attribute

     

    In an ideal situation for a mailbox the mail and proxyAddresses attributes hold the same SMPT: value.

     

    proxyAddresses may hold more than one value for smtp: and at least one for X400 (textEncodedOrAddress)

     

     Upper case SMTP: denotes the primary address, lower case denotes secondary addresses.

     

    Mail enabled contacts and users also have the targetAddress attribute populated

     

    Open ADSIEDIT.MSC and verify which of these attributes hold a value

     

     If possible, do an LDIFDE export and post the results for one user here, I'll have a look and see if I can spot what the issue is.

     

    LDIFDE -f usersattributes -v -d "cn=OU,cn=OU,cn=OU,DC=domain,DC=domain" -r "(objectClass=user)"

     

    Replace the cn and DC values above with the OU path to the users with the problem, in my exampke above I get

     

    cn=IT,cn=Staff,cn=services,DC=Cheddon,DC=com

     

    Dec

    Monday, April 30, 2007 11:08 PM
  • As far as I know this is an outlook thing, when using outlook 2007 its all SMTP in GAL and AL's. Dont know if you also need Exchange 2007

    Tuesday, May 01, 2007 11:57 AM
  • Charles' fix works perfectly.  The beauty of it is that it updates your original entry with all your other contact details!
    Thursday, May 24, 2007 1:22 PM
  • Hi, I've tried re-creating the contacts and found that if your connected to the exchange server on the lan i.e AD domains...then no matter what I do the email type is set tp EX. I suspect you can not change this unless you try and create the contact whilst not caonnected to the domain and exchange and see what happens. I have contacts in out look that used to be in the organisation but have left and their email type has changes to SMTP as they do not exist in the domain/exchange anymore.

    Wednesday, June 27, 2007 11:40 AM
  • I am having the same issue as well.  Is there any way to have the GAL show the SMTP address instead of the EX or X400 address in Exchange 2003?

    Microsoft do you have any answers for us?
    Friday, June 29, 2007 4:42 PM
  • This is an Outlook version problem, unless anyone can tell me otherwise.  I installed Outlook 2007 and all GAL address came up with the correct format SMTP.  Discovered that Outlook 2007 had a few "issues" not related to this problem and roled back to Outlook 2003, guess what GAL was back to EX400 format!!?!?!?!?!??!?!!!!!!!

     

    So to me that is enough evidence to assume that this error is caused by Outlook 2003.

     

    MS any suggestions??????

     

    Regards

     

    Podzol.

    Tuesday, July 17, 2007 11:52 AM
  • OK THANK YOU FOR HELPING GET A EMAIL ADDRESS

     

    Sunday, March 16, 2008 7:24 AM
  • I can confirm that it is NOT only Outlook 2007!

    We recently upgrades from Outlook 2003 to Outlook 2007 , but still on Exchange 2003!

    The outlook address book now displays the email address correctly. (not as in the screenshot above).

    But when I select all addresses and click on 'add to contacts' (for offline use) the email addresses are correctly displayed in Outlook 2007, but after syncing my PDA of Smartphone(whit Windows mobile 2003SE and WM6) it show the email address as in the screenshot above!

    The same thing happens when exporting contacts to Excel!

    The email setting in Outlook 2007 address book look like this:

     

    http://picasaweb.google.com/florisz/Oasen/photo#5192383642886508978

    <a href="

    Wednesday, April 23, 2008 10:22 AM
  • I've had the same problem for a while with Exchange 2003 (only with Outlook 2003 clients).

     

    I found an article elsewhere that said the resolved names for Outlook 2003 are stored in a file named (profilename).NK2 in the \application data\microsoft\outlook\ folder.

     

    I deleted (renamed) the .NK2 file and after that all the user names resolve properly.  No more CN names.

     

    I don't know what else the .NK2 file does, but Outlook recreated it and I haven't noticed any problems.

    Friday, May 09, 2008 7:55 PM
  • The .nk2 (nickname) file is the local cache file used by outlook 2003 and 2007 for resolved names.

    if there is something corrupt or incorrect you can delete the file.

    Exit outlook and allow the outlook.exe process to exit, then delete the file.

    When outlook starts it has an empty name cache

     

    Friday, May 09, 2008 8:32 PM
  • This is a product of migration from msEX2003 to msEX2010.

    Thursday, August 02, 2012 1:10 PM
  • My problem: IMAP couldn't send to EX email types. It would get stuck in the Outbox.

    I changed the view of my list and filtered to see who has the email type = EX. I had about 15...I opened each one, copied their email address, pasted it into the notes section, retyped it into their email address box, deleted the email from notes, saved.

    Don't click on any suggestions that Outlook tries to give you. I actually chose to hit the X on the suggestion to guarantee I don't accidentally take the suggestion.  If you take the suggestion, it will hold onto the EX email type.

    Then remove the filter.

    Worked for me...


    • Edited by ILSoybean Friday, August 17, 2012 3:00 PM
    Friday, August 17, 2012 2:59 PM
  • This thread might be worth a read as it included a fix that solved some similar issues for me:

    http://social.technet.microsoft.com/Forums/en-US/officeitpropreview/thread/0edadc04-28c3-4e0e-ae08-6ecb2f79a4df/

    • Proposed as answer by Alanasff Tuesday, October 16, 2012 4:59 PM
    Monday, October 15, 2012 8:40 PM