none
Can't create file : Document.pdf. Right-click the folder you want to create the file in, and then click properties on the shortc

    Question

  •  

    Really Good One .... I resolved my problem from outlook for open the files.

    Try it now....

    Similar to the previous post, I resolved by doing the following:

        1. Open REGEDIT.EXE and go to Edit -> Find... In the Find dialog box type "OutlookSecureTempFolder" without the quotes and locate that registry key.

        2. That key will contain the actual folder location, and will look like:

           C:\Documents and Settings\%USER_NAME%\Local Settings\Temporary Internet Files\OLK#\ (where # is a random letter or number)

        3. Copy the location of that folder.

        4. Click on Start -> Run... and paste the folder location from step #4 then click OK.

        5. Windows Explorer will open that folder. Please, delete all files present.

        6. Restart Microsoft Outlook and you should be able to open your attachments.

    Saturday, November 17, 2007 5:24 AM

All replies

  • I'm not entirely sure this is a resolution as much as a temporary fix.

     

    I have multiple computers that have this same problem. Having the users or worse, ME, manually deleting files because Outlook cannot count past 99 is at best a band-aid.

     

    Is there no PERMANENT solution for this?

     

    Thanks,

    pataz

     

    Monday, November 26, 2007 4:20 PM
  • When I go to that OLDx folder, there are NO files in there to delete, yet I still get the error that it cannot open the Document.pdf file...

     

    Any suggestions?

     

    Thanks

    Cavall

    Tuesday, February 12, 2008 6:27 PM
  • I've had much more luck running the same check in the registry and changing the location where Outlook saves these files to the regular Temp file location, that way when you are performing routine maintenance and you clear the temp files this folder gets cleaned out also.

     

    Wednesday, February 27, 2008 10:16 PM
  •  

    Dear all

    ples see this link for fixing problem http://support.microsoft.com/kb/305982

     

    Wednesday, March 19, 2008 3:27 AM
  • SweeeT!  it worked for me!  
    Thursday, June 19, 2008 4:21 PM
  • This KB only refers to roaming profiles on the server. This error is occuring locally for several of my users, and fails when they get to the 99 mark on the files.

     

    Any ideas for a fix in this case? In past testing I haven't noticed that Clearing Temporary Internet Files has cleared this random directory.

     

    Thanks,

    Maria

    Tuesday, August 12, 2008 2:22 PM
  • Thanks, it worked!

    Tuesday, August 19, 2008 8:45 AM
  • Hi all,

    This resolution does not fix the issue. We have been experiencing the problem for some time now and have not been able to isolate the actual cause. Some PC's will fill this directory and some won't. Regardless of where you put the folder or how you change the location in the reg. The folder will not exceed a count of 99. Why Microsoft released this as a fix is beyond me.

    I will continue to search for a resolution. Currently, I am looking at the idea of power users vs. local admins.
    Monday, September 08, 2008 2:08 PM
  •  

    I had this problem and I resolved with the automatic clean of Temporary Internet Files and the Cache.
    Monday, September 08, 2008 2:21 PM
  • By setting the auto clean of the temp files, did you relocate the secure outlook temp folder?


    Monday, September 08, 2008 6:24 PM
  • No, I setting only the auto clean by Internet Option! The minimal value!

     

    Tuesday, September 09, 2008 6:43 AM
  • Thanks !!!

    It works...
    how do you find this....


    Thursday, September 25, 2008 1:50 PM
  • I would recommend just deleting the OutlookTemp Folder all together. Chances are it probably got corrupted.
    Tuesday, April 07, 2009 10:37 PM
  • Outlook 2003

    If you are using Outlook 2003, follow these steps:
    1. Click My Computer, and then double-click drive C.
    2. On the File menu, click New, and then click Folder.
    3. Name the folder temp0.
    4. Click Start, click Run, type regedit, and then click OK.
    5. Locate and then click the following registry key:
      HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\Security\
    6. In the right pane, double-click OutlookSecureTempFolder.
    7. In Value Data field, type C:\temp0\ and then click OK.
    8. Exit Registry Editor.
    9. Restart the computer.

    Try this and make the comment

    • Proposed as answer by NJ Frank Wednesday, May 27, 2009 7:32 PM
    Thursday, May 14, 2009 12:50 PM
  • This worked for me in Outlook 2007
    Wednesday, May 27, 2009 7:33 PM
  • This works for me. I receive daily mails regarding some details and the attachment have same file name. For eg. Sheet1.xls --> Once the same file open count is above 99 then you will get this error (eg. in temp folder 'Sheet1(99).xls). You need to delete the files in that folder and the problem is solved.
    Wednesday, September 30, 2009 3:15 AM
  • and what if the OutlookSecureTempFolder is empty already? and it's still not letting the document.* open?
    Wednesday, October 21, 2009 9:50 PM
  • and what if the OutlookSecureTempFolder is empty already? and it's still not letting the document.* open?

    This is the case with one of my users. The "fixes" from this thread and the knowledge base worked for a while, but nothing works at all now. Does anyone have a fix? Outlook 2007 on Windows XP
    Tuesday, November 03, 2009 9:28 PM
  • yeap, same OS and same Outlook Version here.
    Anyone? Please help!
    Tuesday, November 03, 2009 11:55 PM
  • Vishal,

    One word...Genius!  This problem has been plaguing me for a month.  Your simple instructions fixed in 15 seconds.  The world is a better place today.
    Saturday, December 05, 2009 6:20 PM
  • One of my users had a similar problem with Outlook 2007 not being able to open or preview a specific excel file. She was unable to open an attachment that she receives daily as an attachment from a customer. The excel attachment file name is always the same. Looks like Outlook has some sort of maximum temp file with same name and won't open anymore files with this name once it reaches the maximum. Problem was solved by cleaning up the following folder:

    %drive%:\Documents and Settings\%user%\Local Settings\Temporary Internet Files\Content.Outlook\XXXXXXXX

    wherre XXXXXXXX is an 8 character random name.

    You might not be able to find the folder by browsing with windows explorer but you can paste the following link in Start-Run (don't forget to change the drive letter and username):
    %drive%:\Documents and Settings\%user%\Local Settings\Temporary Internet Files\Content.Outlook\
    This will open a windows explorer window and you will find the random name temp subfolder there.

    Good luck!
    Tuesday, January 12, 2010 3:08 PM
  • I have a client that had an issue where he could not open a certain .pdf and after reading all of the helpful post, In step 2. of your instructions I removed the OLK, thus dropping it in the Temp. Internet Folder.

    My theory is in ONE of the many updates the OLK was removed.
    Wednesday, January 20, 2010 5:58 PM
  • Yes there is, I have a client that had an issue where he could not open a certain .pdf and after reading all of the helpful post, OLK portion of the path in the registry, thus dropping it in the Temp. Internet Folder.

    My theory is in ONE of the many updates the OLK was removed.
    Wednesday, January 20, 2010 5:59 PM
  • Bravo, this is what help me.  I dropped the OLK portion of the path in the registry and it resolved my issue.

    Cause, I believe the updates along the way deleted the folder that was normally referenced.
    Wednesday, January 20, 2010 6:01 PM
  • The post by Tepes works; however it seems like Microsoft hasn't resolved the underlying problem in months. I should not need to repeatedly navigate to arcane folders and empty them. Is there a permanent, one-off fix ?
    Thursday, April 22, 2010 12:10 PM
  • It worked, thank you so much for your time/help!!

    Wednesday, July 07, 2010 12:45 PM
  • The post by Tepes works; however it seems like Microsoft hasn't resolved the underlying problem in months. I should not need to repeatedly navigate to arcane folders and empty them. Is there a permanent, one-off fix ?
    Yes, have a script delete *.* in that folder every time you log on.
    Friday, July 16, 2010 4:26 PM
  • Deleting files in the temp folder every time you log on will not work.  When a user tries to open and edit an attachment in Outlook, the attachment is first saved in the Outlook Temp folder and the permission of that attachment is changed to Read only. When the user tries to edit the attachment (for example signing a PDF) and then saving the attachment, the user will then get the error "The file may be read-only, or another user may have it open. Please save the document with a different name or in a different folder."

    So far from my research this feature was put in place by Microsoft:
    1. to sandbox attachments with malicious codes.
    2. to force users to save attachments outside of the Outlook temp folder to allow for future retrieval of any edited documents.  This is because users cannot use Windows Explorer to navigate to the Outlook temp folder.

    The above are just my theories and from reading other forums.  However, after all that explanation, I am still waiting for an official fix from Microsoft.

    Tuesday, August 03, 2010 4:58 PM
  • this worked for me!!

    Thanks!!

    Tuesday, October 12, 2010 9:41 PM
  • worked like a charm.

    Thanks!

    Tuesday, November 09, 2010 3:19 PM
  • This is the batch file I use to solve this problem over many users:

     

    del "c:\Documents and Settings\%username%\Local Settings\Temporary Internet Files\Content.Outlook\*" /f /s /q

    Thursday, December 30, 2010 4:20 PM
  • Awesome, it works on 2003,

     

    Thank you

    Wednesday, February 09, 2011 4:33 PM
  • YES!!!
    WC
    Friday, March 04, 2011 9:05 PM
  • Thank you, worked like a charm :)
    Wednesday, June 01, 2011 9:32 AM
  • For Windows 7 users, you'll need to clear all the contents within the path below. It's hidden so you'll need to enter it in the "RUN" command.

    C:\Users\USERNAME\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.Outlook

    Tuesday, October 25, 2011 5:18 PM
  • Though this is a workaround for the issue at hand, the obvious permanent resolution is to name the file something specific, ie. the date. This will require coordination from all parties, but will work as a resolution. Especially if you get the file from the same person all the time. Just my 2 cents. I have several persons in our legal department that have this same issue reoccur monthly.
    Tuesday, November 22, 2011 9:19 PM
  • Seriously? This is the fix that MS expects? The f*cktards in Redmond can't emtpy this folder upon closing Outlook or at the very least let it keep junking up the users hard drive with numbers higher than 99? Disk cleanup doesn't clear this folder either. This is just absurd.

    I regularly get calls from users having to fix this for them. They wonder why they're losing market share? Ballmer should be fired.....about 9 years ago.


    • Edited by TroyPippen Friday, February 10, 2012 2:23 PM
    Friday, February 10, 2012 2:19 PM
  • Outlook 2003

    If you are using Outlook 2003, follow these steps:
    1. Click My Computer, and then double-click drive C.
    2. On the File menu, click New, and then click Folder.
    3. Name the folder temp0.
    4. Click Start, click Run, type regedit, and then click OK.
    5. Locate and then click the following registry key:
      HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\Security\
    6. In the right pane, double-click OutlookSecureTempFolder.
    7. In Value Data field, type C:\temp0\ and then click OK.
    8. Exit Registry Editor.
    9. Restart the computer.

    Try this and make the comment

    I used this on Outlook 2007.  Also used the "let us fix it for you" link in the help section after backing up the registry and everything is working, at least for now.

    Hope this helps others!


    Friday, May 11, 2012 5:31 PM
  • I had a similar issue with a Wndows XP \ Office 2007 system. Fixed it by closing out of Outlook and renaming the subfolder under c:\Documents and Settings\%username%\Local Settings\Temporary Internet Files\Content.Outlook\*.  Office will recreate the temp folder again an attachment is openned.

    FYI - my last step was to delete the folder I renamed. That said I guess it is the same if you just delete the subfolder.


    Ncruz1980

    • Proposed as answer by GoHeat2013 Wednesday, November 20, 2013 3:34 PM
    Friday, December 07, 2012 11:37 PM
  • You, sir/madame, are a genius!  Thanks, it worked.
    Monday, July 08, 2013 7:49 PM
  • Worked an absolute charm. Thanks
    Friday, November 01, 2013 11:01 AM
  • This worked for me as well. Thanks!
    Wednesday, November 20, 2013 3:34 PM
  • Dude You are awesome!! It worked for me Thanks Alot God Bless you!!! Cheer's :-)
    Thursday, November 21, 2013 11:40 AM
  • Thanks Vishal....

    resolved my problem from outlook.

    Krishna

    Wednesday, January 15, 2014 7:52 AM