none
Sender ID (PRA) Domain Does Not Exist - Issue

    Question

  • I am having an issue with valid emails by a few of our clients being rejected by Sender ID with this message: 

    Sender ID (PRA) Domain Does Not Exist.

    You can ping the domain name from the Exchange Server of the sending email and it resolves so it is a valid domain name but, I believe it to be an improper setup on their end however I cannot convince them to bother with it as they always claim "Well I can send to everybody else with no problem,..."

    I think the issue is with a relaying server their ISP's use or something to that effect. However it is beyond my control.

    Is there a way to tweak the Sender ID settings so as to not reject messages with the: 

    Sender ID (PRA) Domain Does Not Exist
    Response. I have had to turn off Sender ID - Reject which is a shame because it was working great reducing spam and phishing emails.

    Thanks in advance,
    D

    Environment:
    Exchange 2007 SP1
    Windows Server 2003 SP2 X64

    Monday, March 02, 2009 10:41 PM

Answers

  • Hi,

     

    Yes, the X-MS-Exchange-Organization-SenderIDResult is the message header.

     

    The rule should be like below:

     

    Conditions: When a message header contains specific words

    Actions: set the spam confidence level to value

    Exceptions: except when the text specific words appears in a message header.

     

    I have local tested the rule on my test lab with Exchange 2007 Service Pack 1.

     

    Mike

    • Marked as answer by dflo16 Thursday, March 05, 2009 2:39 AM
    Thursday, March 05, 2009 2:36 AM

All replies

  • Hi,

    Sender ID looks for a SPF record in the DNS if no SPF exists it generates. But why don't you stamp the messages, this will ensure that the message is tagged with an SCL value but still delivers the message to the end users mailbox. Depending on the SCL values configured the mail will be placed in junk mail.

    Regards,

    Johan


    blog: www.johanveldhuis.nl
    Tuesday, March 03, 2009 9:43 PM
  • Thats the setting I had before but it didn't give it a high enough SCL even on Fails. For expample Sender ID would actually produce a Failed response (case in point was a phishing email spoofing a Bank of America Email Address) that Failed Sender ID (BoA has a DNS txt record of all its mail servers)and it only gave the email an SCL of 4!!!! Even though it Failed Sender ID check. And the email was delivered to the end users Inbox and not Junk Email Folder.

    Not Soft Fail but actual Fail and only an SCL of 4? Is there a way to tweak maybe with a Transport Rule to tell it to give it a hight SCL or even reject the message if it Sender ID: Fails?

    thx.
    Tuesday, March 03, 2009 10:24 PM
  • Hi,

     

    I suggest you attempt following method to check whether the issue can be solved:

     
    1.
    Configure the Sender ID filter to stamp message with Sender ID result  and processing if sender ID check fails.
    2.
    Create a transport rule on the edge server like below:

     

    When a “X-MS-Exchange-Organization-SenderIDResult” contains Fail

    Set the spam confidence level to 9

    Except when the text “Domain Does Not Exist” appears in a “Received-SPF”

     

    Note: I am not sure whether the “Domain Does Not Exist” is included in “Received-SPF” header. You need to update the text if the “Domain Does Not Exist” is not included in the “Received-SPF” header

     

    Mike

    Wednesday, March 04, 2009 9:54 AM
  •  Mike,

    I do not see the option in Transport Rules for: “X-MS-Exchange-Organization-SenderIDResult”
    Do I need to add it as a message header contains specific words or text patterns?

    Is this an option on a newer version? I am running SP1.

    Thank you for your response.

    -D
    Wednesday, March 04, 2009 6:45 PM
  • Hi,

     

    Yes, the X-MS-Exchange-Organization-SenderIDResult is the message header.

     

    The rule should be like below:

     

    Conditions: When a message header contains specific words

    Actions: set the spam confidence level to value

    Exceptions: except when the text specific words appears in a message header.

     

    I have local tested the rule on my test lab with Exchange 2007 Service Pack 1.

     

    Mike

    • Marked as answer by dflo16 Thursday, March 05, 2009 2:39 AM
    Thursday, March 05, 2009 2:36 AM
  • That worked! Great, I appreciate your help. I figured a Transport Rule would do it but I wasn't sure about how the message headers worked.

    Thanks again,

    D
    Thursday, March 05, 2009 2:39 AM