none
owa not working and emc problem

    Question

  • we have sbs 2011

    We are having a problem accessing our server via owa. outlook works fine in the office and email is routed etc correctly.

    the sharepoint site works fine and everyone can access it.

    the problem is if we access the exchange management shell from the gui or cmd line we get a error message.

    From the exchange powershell

    Full list of cmdlets: Get-Command
    Only Exchange cmdlets: Get-ExCommand
    Cmdlets that match a specific string: Help *<string>*
    Get general help: Help
    Get help for a cmdlet: Help <cmdlet name> or <cmdlet name> -?
    Show quick reference guide: QuickRef
    Exchange team blog: Get-ExBlog
    Show full output for a command: <command> | Format-List

    Tip of the day #57:

    Want to know what permissions an Active Directory user account has on a specific mailbox? Use:

    Get-Mailbox <Mailbox to Check> | Get-MailboxPermission -User <Active Directory User>

    VERBOSE: Connecting to FSL-SRV1.fsldomain.local
    [fsl-srv1.fsldomain.local] Connecting to remote server failed with the following error message : The WinRM client recei
    ved an HTTP server error status (500), but the remote service did not include any other information about the cause of
    the failure. For more information, see the about_Remote_Troubleshooting Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
       eption
        + FullyQualifiedErrorId : PSSessionOpenFailed
    VERBOSE: Connecting to FSL-SRV1.fsldomain.local
    [fsl-srv1.fsldomain.local] Connecting to remote server failed with the following error message : The WinRM client recei
    ved an HTTP server error status (500), but the remote service did not include any other information about the cause of
    the failure. For more information, see the about_Remote_Troubleshooting Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
       eption
        + FullyQualifiedErrorId : PSSessionOpenFailed
    VERBOSE: Connecting to FSL-SRV1.fsldomain.local
    [fsl-srv1.fsldomain.local] Connecting to remote server failed with the following error message : The WinRM client recei
    ved an HTTP server error status (500), but the remote service did not include any other information about the cause of
    the failure. For more information, see the about_Remote_Troubleshooting Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
       eption
        + FullyQualifiedErrorId : PSSessionOpenFailed
    Failed to connect to an Exchange server in the current site.
    Enter the server FQDN where you want to connect.:

    and from the gui we get a winrm http 500 error message

    I have check winrm config check the normal dll problems but i can not find the issue

    Anyone get and pointers
    Thursday, April 26, 2012 3:55 PM

All replies

  • Hi there,

    Open IIS and go to the Powershell virtual directory. Open the Auth module and make sure that anonymous access
    is disabled and Windows Integrated Authentication is enabled.


    Oliver Moazzezi | Exchange MVP, MCSA:M, MCITP:Exchange 2010, BA (Hons) Anim | http://www.exchange2010.com | http://www.cobweb.com | http://twitter.com/OliverMoazzezi

    Thursday, April 26, 2012 4:54 PM
  • Hi,
    Check the Bindings configured on your web sites in IIS.
    Your problem could be caused by Sharpoint taking port 80..the port the powershell Virtualdirectory is heavily dependent on. It must be assigned to the "Default Web Site".

    Martina Miskovic

    Thursday, April 26, 2012 8:00 PM
  • Basically you need to troubleshoot Exchange management console. Here are few articles which will help you to fix this issue

    Troubleshooting Exchange 2010 Management Tools startup issues
    http://blogs.technet.com/b/exchange/archive/2010/02/04/3409289.aspx

    Resolving WinRM errors and Exchange 2010 Management tools startup failures
    http://blogs.technet.com/b/exchange/archive/2010/12/07/3411644.aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Hasnain Shaikh| My blogs: http://messagingserversupport.com

    Thursday, April 26, 2012 8:45 PM
  • Hi,

    Please verify if your default website is running on port 80.

    If the issue still persists, then I recommend you to post the issue in forum for Small business Server to get better help.

    http://social.technet.microsoft.com/Forums/en/smallbusinessserver/threads


    Xiu Zhang

    TechNet Community Support

    Friday, April 27, 2012 8:19 AM
  • Hi,

    I have tried the above before I posted and, yes sharepoint is taking port 80, I thin iis is messed up for some reason. I did not set this server up.

    So I do not know if there was problems with the migration from 2008. sharepoint works and outlook works but no owa or access to the exchange ews etc.

    I have tried loads of the stuff posted with the same problem. i will post in the sbs forum as I think i may have to do a reinstall as there backup is broke :<

    Sunday, April 29, 2012 11:23 AM
  • Hi grimevil

    open C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\PowerShell

    Take a backup of the file web.config, rename it to web.config.old

    Open Web.config file, search for

    "file:///%ExchangeInstallDir%bin "

    replace it with "file:///C:\Program Files\Microsoft\Exchange Server\V14\bin "

    Save the file then restart IIS and try

    Change the drive C to your drive letter


    http://tariqjaber.com/blog


    Sunday, April 29, 2012 1:53 PM
  • after doing the above I now get error http 403 forbidden and in event viewer I am getting this error

    The Module DLL C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa\auth\exppw.dll failed to load.  The data is the error.

    I have already checked that this is showing in modules etc and done the fix for this, but it still shows

    and also this error

    A listener channel for protocol 'http' in worker process '13684' serving application pool 'WsusPool' reported

    I also still get the winrm http(500) error trying ews or exchange powershell

    thanks for the help


    • Edited by grimevil Sunday, April 29, 2012 8:18 PM
    Sunday, April 29, 2012 8:13 PM
  • Are you also getting event id Event ID:      2280 with description

    The Module DLL E:\exchsrvr\ClientAccess\Owa\auth\exppw.dll failed to load.  The data is the error.

    Please check  if the "Authenticated Users" have permissions  "Traverse Folder and Execute File" on OWA\Auth folder and sub files

    I recently had this issue and while working with EE we found the above resolution


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Hasnain Shaikh| My blogs: http://messagingserversupport.com

    Monday, April 30, 2012 2:44 PM
  • The  permissions are correct on the folders, but thanks for the reply
    Tuesday, May 01, 2012 8:00 AM
  • It's likely your SBS install has hijacked port 80 with some other app. At this point I would suggest you perform the KB article below to fix.

    Reinstall the Client Access Role in Windows Small Business Server 2008

    http://technet.microsoft.com/en-us/library/dd767439(WS.10).aspx


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Tuesday, May 01, 2012 2:07 PM
  • This a sbs 2011 server is the process the same.
    Tuesday, May 01, 2012 9:12 PM
  • Here you go.

    Reinstall the Client Access Role in Windows Small Business Server 2011

    http://technet.microsoft.com/en-us/library/gg680344.aspx


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Wednesday, May 02, 2012 6:06 PM
  • I am planning on doing this tomorrow. Would a systemstate restore via backup exec work better or could it make the problem worse. As I have managed to find a systemstate image from the day before this happened?

    thanks

    Thursday, May 03, 2012 9:34 AM
  • Naw unlikey system state will not help for this specific case.

    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Thursday, May 03, 2012 2:06 PM
  • I am planning on doing this tomorrow. Would a systemstate restore via backup exec work better or could it make the problem worse. As I have managed to find a systemstate image from the day before this happened?

    thanks

    No, that would probably make your problem worse.
    As already been mentioned serveral times in this thread, the problem seem to be that your Default Web Site don't have port 80 assigned (it need to).

    Did you even check that in IIS??




    Martina Miskovic

    Friday, May 04, 2012 3:44 AM
  • the default web site is running on port 80. the site that does not start is companyweb. every other site is running, my sharepoint is up its just owa that stopped working.

    thanks for the reply tho. I know its somthing to do with iis.

    Friday, May 04, 2012 9:19 AM
  • before I do a reinstall of the cas role. I am installing sbs 2011 in virtualbox to check my iis config again just incase I missed something

    Friday, May 04, 2012 9:20 AM
  • i have checked all the settings in iis and redone a cas reinstall. Still getting the winrm http 500 error on echange, owa gives me a blank screen.

    checked all web.config for correct paths, winrm, kerb etc are in the right modules, checked ssl, all website loads.

    Still same problem.

    the only thing that was done on the site was a sharesite add to the main website for testing could this have caused this problem. or is there any other thing i can try before I do a resetup etc

    Saturday, May 05, 2012 4:30 PM
  • Can you remove the sharesite? Any additional sites can hijack port 80 causing issues.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Saturday, May 05, 2012 5:25 PM
  • The main sharepoint site is used by the company. the sharepoint is not hijacking port 80 as far as i know as companyweb, default site etc are running no problem
    Saturday, May 05, 2012 10:05 PM
  • tried the remove and reinstall the cas role. This has not fixed the problem.

    The main problems are:-

    EWS, emc not working, winrm httpm 500 error

    powershell can not find the server.

    can not del and reinstall the powershell dir from the shell as it can not find the server?

    Friday, May 11, 2012 12:25 PM
  • try to add additional IP to your SBS2011 server, and bind the new IP to your sharepoint site, then try to reinstall CAS role to see if it works.
    Friday, May 11, 2012 1:03 PM
  • How do you mean additional IP to the SBS2011.

    Friday, May 11, 2012 11:44 PM
  • Hi,
    It's very clear to us that your problem started after settings up a Sharpoint WebSite and that you have problemes with bindings in IIS.

    I can see that have created a thread i the SBS Forum, but haven't updated that one since Maj 1. Why is that?
    It's there you can get the best help. Do note that there are many differences with SBS compared to having Exchange installed on a member server.






    Martina Miskovic

    Saturday, May 12, 2012 4:50 AM
  • Hi,

    We have not setup any other sharepoint site, other than the one we have been using for months. EWS, EMC, just stopped working and did not effect the sharepoint site we use in the office. as I have already said the sharepoint and iis bindings are correct and all sites are running, I am getting a blank screen or http 500 and internal error only on the owa sites.

    The other thread had not been updated as I have been wokring through what had been posted here. I have updated that thread today.

    Monday, May 14, 2012 12:23 PM
  • OWA installs in the default web site, is your Sharepoint in a different web site on the same server?  Do you get to them utilizing different host names?  Are the bindings using host headers?  Does the name in your OWAVirtual Directory settings match the name you are using to access OWA?

    Monday, May 14, 2012 12:31 PM
  • from your NIC's IP config properties page, TCP/IP 4 properties, advanced, add an addidtional IP address that doesn't use in your network. click OK, OK. BTW, make sure you disable IP v6 on your NIC as well.
    Monday, May 14, 2012 3:10 PM
  • as this is sbs 2011 it has a default website and a companyweb(sharepoint) setup and running. As sbs 2011 set this up it maps company web to the same ip etc as the iis website. yes the name on thwe owa, ews and ecp are correct(this was checked against a other exchange serve to checked both iis configs match up)

    Monday, May 14, 2012 4:00 PM
  • Does exchange not use ip6 for routing etc?. Or will it be ok to disable it and add a non local ip address to the nic settings.

    Monday, May 14, 2012 4:01 PM
  • The only acceptable way to disable ipv6 is to follow the KB http://support.microsoft.com/kb/929852.

    Have you tried disabling the sharepoint site to see if OWA starts working?

    Monday, May 14, 2012 4:11 PM
  • I will have a read of that later. I will try disabling the sharepoint site tonight when no users are accessing it. But I think I have already tried this.

    thanks

    Tuesday, May 15, 2012 11:21 AM
  • I have fixed the problem. by doing the following.

    Renamed the web.config in the the wwwroot folder, restarted iis and owa is now working fine, along side my sharepoint etc.

    thanks for the help

    • Marked as answer by grimevil Wednesday, May 16, 2012 3:13 PM
    Wednesday, May 16, 2012 3:13 PM
  • Hello guys and girls

    I have exactly the same problem and grimevil, however, I am not getting any further with the solution, would be nice to have the single steps where to change this.

    Sharepoint is I think to "blame" at my side, did deactivate all the Sharepoint Services (we are not using it anyway yet), however, I think the port 80 has been "hijacked" by SP.

    To rename the web.config, well, to rename it to what and what do you call the wwwroot folder?  In the IIS?  I cannot find it...

    Would appreciate your help here

    Thanks

    PS:  When I am trying to open the .../owa now, it comes back with "HTTP Error 404.  The requested resource is not found"

    Neither can I access the Exchange Management Console

    Deinstalled SP, we are not using it, will get back with more information



    • Edited by MIR_ICE Wednesday, May 23, 2012 11:36 AM
    Wednesday, May 23, 2012 10:12 AM
  • HI

    did not see your post. Not sure if you fixed it or not but the web.config is located in C:\inetpub\wwwroot

    I renamed mine to web.config.old, iisrest and it was all working again.

    Friday, June 29, 2012 3:21 PM