none
550 Access denied - Invalid HELO name (See RFC2821 4.1.1.1)

    Question

  • i m trying to send the emails to some of the domains and i am getting the reply like this.................
    Saturday, May 21, 2011 8:41 AM

Answers

  • Hi md,

     

    Please refer to see RFC2821 4.1.1.1:

     

    These commands are used to identify the SMTP client to the SMTP server. The argument field contains the fully-qualified domain name of the SMTP client if one is available. In situations in which the SMTP client system does not have a meaningful domain name (e.g., when its address is dynamically allocated and no reverse mapping record is available), the client SHOULD send an address literal, optionally followed by information that will help to identify the client system.

     

    This issue may be caused by the FQDN on your send connector, you can change it to the proper name.

     

    You can know more information from this document:

     

    RTC 2821 Simple Mail Transfer Protocol

    http://tools.ietf.org/html/rfc2821#section-4.1.1.1

     

    Thanks,

     

    Evan


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, May 25, 2011 4:06 PM

All replies

  • Hi,

    What is the domain configured on your send connector?

    Leif

    Saturday, May 21, 2011 8:49 AM
  • we are using spam filter trend micro, in the send connector it is showing trend,when i check the trend properties there is nothing mentioned  in ""specify FQDN for this connector option""
    • Proposed as answer by CathexisDev Wednesday, June 05, 2013 3:33 PM
    Sunday, May 22, 2011 7:23 AM
  • Hi md,

     

    Please refer to see RFC2821 4.1.1.1:

     

    These commands are used to identify the SMTP client to the SMTP server. The argument field contains the fully-qualified domain name of the SMTP client if one is available. In situations in which the SMTP client system does not have a meaningful domain name (e.g., when its address is dynamically allocated and no reverse mapping record is available), the client SHOULD send an address literal, optionally followed by information that will help to identify the client system.

     

    This issue may be caused by the FQDN on your send connector, you can change it to the proper name.

     

    You can know more information from this document:

     

    RTC 2821 Simple Mail Transfer Protocol

    http://tools.ietf.org/html/rfc2821#section-4.1.1.1

     

    Thanks,

     

    Evan


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, May 25, 2011 4:06 PM
  • HI people, to save people's time I decided tu write here the solution for outlook 2010 (avoid reading all the crap about protocols and things most people don't need to know), which is only enable the SMTP authentication (make a check in your  outlook "My SMTP server requires authentication").

    Microsoft Outlook® 2010 (PC)

    1. From the File menu, select "Info" and choose "Account Settings"
    2. Select your Network Solutions Email account and click the "Change" button above.Click the "More Settings..." button in the bottom-right corner of the E-Mail Accounts window.In the Internet Email Settings window, click the "Outgoing Server" tab.
    3. Ensure that the box next to "My outgoing server (SMTP) requires authentication" is checked and "use same settings as my incoming mail server" is selected.
    4. Click the "Advanced" tab and make sure that "Use the following type of encrypted connection" is set to "None" for the outgoing (SMTP) port settings.
    5. Change the outgoing server port to 587.

    • Proposed as answer by d_viking Monday, July 29, 2013 11:55 AM
    Thursday, December 13, 2012 8:09 PM
  • Fill in your mailer FQDN here. 

    example: mailer.xyz.com or mail.xyz.com


    Make sure your mail gets routed out on the correct IP address which also has a reverse DNS or MX lookup record pointing to the same valid FSDN address.


    If you are using postfix/sendmail also check the SMTP banner header/configuration on your mailer, and make sure it uses a FQDN in the handshake message. It could be pointing to the mailer's local hostname. Not sure if Exchange has a similar configuration for this.
    • Edited by CathexisDev Friday, July 05, 2013 6:33 AM Found the real reason for the same error on my side.
    Wednesday, June 05, 2013 3:36 PM
  • Thanks Dalejandro2307 - worked for me - immediately!
    Monday, July 29, 2013 11:56 AM
  • Thanks you solved the problem!!
     I did not have to change the out going port though....
    • Edited by Ozabro Saturday, January 18, 2014 2:01 AM
    Saturday, January 18, 2014 2:00 AM
  • This was the fix for us as well. I created a quick blog about it with screenshots of how to enable SMTP to handle the issue for those of us who work better with visual guides.

    http://danblee.com/the-server-responded-550-access-denied-invalid-helo-name-see-rfc-2821-4-1-1-1/

    Monday, March 10, 2014 6:56 PM
  • Thanks a lot.

    I resolved the same problem thanks to your clear recommendations.

    You made my day!

    Saturday, March 22, 2014 10:21 AM