none
Windows phone 7 certificate error

    Question

  • I am trying to setup my windows phone 7 with our Exchange server using internal CA cert.

    As there are no official ways to install custom root ca cert for windows phone 7 yet, I emailed my hotmail account a copy of my root ca cer file, and it install fine.

    However, when I configure my phone to sync with Exchange, it still return the 80072f0d error. Any one has a solution on this?

    Cheers

    Friday, October 22, 2010 5:23 PM

Answers

  • i had the same Problem, and now i have a solution :-)

    Have you a Root CA Certificate of you’re Domain, so go first to you're locale Client (PC, Laptop) then open the mmc and load the snap-in for Certificates, select Local computer;
    - on Trusted Root Certification Authorities - Certificates
    -Searche youre RootCA Certificate

    - then export this Certificate as a DER-coded-binary X.509 (CER) on you're local Computer

    - Search the Certificate and send it via Mail (another Mail-account Hotmail for example) to you're WP7

    - Sync the Mail Box and open the attachment

    - install this Certificate

    - now test you're Sync with the EAS Account

    it should be working, be happy and have fun

    Monday, October 25, 2010 8:42 AM
  • After power cycling it works now!
    Johann Deutinger | MCTS Exchange 2007 / OCS 2007
    Tuesday, October 26, 2010 8:07 AM

All replies

  • When you install the .cer manually it is installed in the MY (user) certificate store on the device. But root ca certs should be installed in the ROOT certificate store. Which you can't easily drop it into with Windows Phone 7. At the moment I am not aware of a way around this. (WP7 devices aren't available for another couple of weeks where I live so I haven't had time to hack around with it properly yet. The dev device isn't really the same thing.)

    The better solution altogether is to get an SSL cert issued from a trusted root. A GoDaddy cert will suit you nicely and set you back about 20$ if you go for the single name cert. (Depending on whether you're running 2003/2007/2010 and/or other you might want to consider a SAN cert or wildcard.)

    Friday, October 22, 2010 5:51 PM
  • I test to send the "private" (SBS 2008, own certificate) .CER to my phone, with private email, it's working for me, no problem with the connexion to Exchange 2007 SP2.


    Benji
    Sunday, October 24, 2010 12:04 PM
  • i had the same Problem, and now i have a solution :-)

    Have you a Root CA Certificate of you’re Domain, so go first to you're locale Client (PC, Laptop) then open the mmc and load the snap-in for Certificates, select Local computer;
    - on Trusted Root Certification Authorities - Certificates
    -Searche youre RootCA Certificate

    - then export this Certificate as a DER-coded-binary X.509 (CER) on you're local Computer

    - Search the Certificate and send it via Mail (another Mail-account Hotmail for example) to you're WP7

    - Sync the Mail Box and open the attachment

    - install this Certificate

    - now test you're Sync with the EAS Account

    it should be working, be happy and have fun

    Monday, October 25, 2010 8:42 AM
  • This did not work for me - Andreas already had explained above why that is not sufficient. My iPhone and Galaxy Tab are able to accept our certificate after confirmation. I do not want to buy a certificate just because my WP7 does not work with our enterprise CA.

     


    Johann Deutinger | MCTS Exchange 2007 / OCS 2007
    Monday, October 25, 2010 3:01 PM
  • After power cycling it works now!
    Johann Deutinger | MCTS Exchange 2007 / OCS 2007
    Tuesday, October 26, 2010 8:07 AM
  • Following the installation settings, then power cycling the device still does not work on a Windows Phone 7 device
    Thursday, October 28, 2010 8:40 AM
  • Hi Folks there is an other easy way to work around that problem:

    1. Upload the previously exported certificate to a webserver
    2. create single website that is accessible from the internet and that has your previously uploaded certificate file linked
    3. (optional - not needed for root certificates like CaCert) secure the access to the folder/file with password check (e.g. via .htaccess password)
    4. now navigate with your wp7 phone to the created website and click the download link and install the certificate
    5. restart phone
    6. done ;-)

    This solution has some advantages if you plan to use more than one wp7 phone:
    1. don't need to setup an temp mail accoun on every wp7 device you like to activate
    2. one static adress to navigate and dounload the certificate for every user
    3. no need to wait for the requested e-mail containing the certificate

    Greetings from Berlin/Germany

    Ralf

     

    Friday, November 05, 2010 1:25 PM
  • I followed the instructions but still can't sync with our exchange server.

    One special thing is that I have 2 Certs to install. One root and a client cert.

    Does it not work because i can't load them in the root cert store?

    Saturday, November 06, 2010 7:10 AM
  • I've got the same problem, where I tried to connect to my enterprise wifi.

    I need to install 2 Certs, one root and one client. In Windows Mobile 6 I could use pfx files or two separate .cer files but now in Windows Mobile 7 I didn't understand what installation has done.

    Other questions:

    1) Where I could find the installed certificate on my phone ? 

    2) Could I uninstall certificate that I previously installed on the phone ?

     

    Thanks for help

     

    Friday, November 12, 2010 8:41 AM
  • I can confirm that the solution is working.

    However I want to share a nice webcast which is explaining to take the cert of the server and checking whether the cert is used on the remote site.

    http://www.netometer.com/video/tutorials/sbs-2008-mobile-device-ssl-certificate-import/step1/index.php

    Also a small remark: You can't powercycle your device when it's connected to the usb port. Maybe obvious but this held me back several times trying to solve the issue.


    It's doing common things uncommonly well that brings succes.
    Friday, November 12, 2010 10:19 PM
  • Is there a way to do this on an IIS server? When I upload my .cer file to my website and create a link to download the .cer file all it does is open the actual file in the browser showing the certificate. It doesn't give you the option to download the file, same behavior when browsing to the website on a computer. If I rename the file to .der I can download it on a computer but the Windows Phone 7 says Windows Phone doesn't support .der files. I made this work on my Windows Mobile devices by creating a .cab file that automatically installs the Root CA but MS killed .cab files on WP 7. And you can't even sync files to a computer with WP7, really MS???

    I woul like to be able to download this file from an IIS server and install it. Setting up a temp Gmail account and configuring every phone to sync those emails just so I can install the certificate is way too much work.

    MS really screwed their Enterprise users on this re-write. MS these are your core user base, I understad you want to capture the consumer market but dont cut off your main user base at the same time.

    I also setup the IIS directory to allow directory browsing but when I click the file the same thing happens, it just opens the.cer file in the browser, not giving you the option to download or it or install it. Does it have to do anything with MIME Types on the IIS Server?

    Thanks in Advance.

    Tuesday, November 16, 2010 6:15 PM
  • For my HTC 7 Trophy I just emailed myself the certificate I used for desktop Outlook, installed it and restarted my phone. Worked perfectly for me.
    Tuesday, November 23, 2010 1:08 PM
  • Is there a way to do this on an IIS server? When I upload my .cer file to my website and create a link to download the .cer file all it does is open the actual file in the browser showing the certificate. It doesn't give you the option to download the file, same behavior when browsing to the website on a computer. If I rename the file to .der I can download it on a computer but the Windows Phone 7 says Windows Phone doesn't support .der files. I made this work on my Windows Mobile devices by creating a .cab file that automatically installs the Root CA but MS killed .cab files on WP 7. And you can't even sync files to a computer with WP7, really MS???

    I woul like to be able to download this file from an IIS server and install it. Setting up a temp Gmail account and configuring every phone to sync those emails just so I can install the certificate is way too much work.

    MS really screwed their Enterprise users on this re-write. MS these are your core user base, I understad you want to capture the consumer market but dont cut off your main user base at the same time.

    I also setup the IIS directory to allow directory browsing but when I click the file the same thing happens, it just opens the.cer file in the browser, not giving you the option to download or it or install it. Does it have to do anything with MIME Types on the IIS Server?

    Thanks in Advance.


    On my IIS 7.5 box I had to add the MIME type for .cer. It should be "application/x-x509-ca-cert" (same as .der).
    Tuesday, November 23, 2010 3:19 PM
  • Thank you Andreas for your response. I am using Win 2k3 so it is IIS 6 and I do have the MIME type set for .cer as application/x-x509-ca-cert but I still get the file opening in the browser vs. the option to download it or save it. I will try it out on an Win 2K8 R2 server and see what happens.

     

    thanks,

    Danny

    Wednesday, November 24, 2010 9:40 PM
  • Update, I was able to get this to work on my Win 2K8 R2 (IIS 7.5) server when I added the MIME type for .cer as application/x-x509-ca-cert. Strange that IIS 6 handles it differently. This makes setting up WP7 for our Exchange Server much easier as all I do now is use IE on WP7 and browse to the website I built and download the .cer file and install it.

    Now MS, just waitng for Cut and Paste, Multi Tasking, On Device Encryption and a built in Mobile VPN client. wink wink.

    thanks,

    -D

    Friday, November 26, 2010 5:53 PM
  • So I am having the same problem, but I am not not amili with server computers. I started my journey less than a week ago and although I am skilled with computers I know nothing of exchange server and the job of setting up the new windows phones was mine. We have no IT for our server and it took me all day to figure out what the setngs should be (which was not helped by the fact that I don't know which version of exchange server we have.) then our certificate was expired. A few hours of research later and a few errors, I was able to instal a current certificate on the server. Now when going to the remote site, we no longer get the IE message about the expired certificate. So another full day and I have installed 43 certificates on my phone and I still get the error about the certificate. Can somone tell me in been terms how I can figure out which certificate to install on my phone? We have a custom local cert (which I didn't make, but found and installed. Anyways, I'll take any help I can get.

    Sunday, January 30, 2011 11:15 PM
  • So I am having the same problem, but I am not not amili with server computers. I started my journey less than a week ago and although I am skilled with computers I know nothing of exchange server and the job of setting up the new windows phones was mine. We have no IT for our server and it took me all day to figure out what the setngs should be (which was not helped by the fact that I don't know which version of exchange server we have.) then our certificate was expired. A few hours of research later and a few errors, I was able to instal a current certificate on the server. Now when going to the remote site, we no longer get the IE message about the expired certificate. So another full day and I have installed 43 certificates on my phone and I still get the error about the certificate. Can somone tell me in been terms how I can figure out which certificate to install on my phone? We have a custom local cert (which I didn't make, but found and installed. Anyways, I'll take any help I can get.


    Saturday, March 05, 2011 9:59 PM
  • Hi guys,

    this is not very complicated. After your phone is connected with your desktop (usb), or you have the 3G connection.
    Place you internal root certificate into a webserver, like described before, but take note that you have to save the certificate as P7B.
    You can export the root cert from any member computer or from the CA itself.

    Regards

    Thomas

    Tuesday, March 15, 2011 6:14 AM
  • In my opinion it's beyond complicated.  MS is trying to develop a phone that challenges iOS and dumping many who have supported them and WM for years on the corporate side, this is another example.  I know they'll catch up but it will be too late for me, too many users to mess with this Mickey Mouse stuff - Android and iPhone will setup on an Exchange server with only inputting email and pw - a Microsoft Exchange server.  They won't even connect to their own system as well as these other devices they're trying to compete with.

     

    Can't manage the phone at all - if you say activesync, then I say iOS and Android are more managament and more secure with or without activesync.

    Can't access the sd drive - many uses for personal and corporate

    Can encrypt

    Can go international

    Can install corporate apps

    Can't wipe corporate only data

    now - can't setup exchange unless you buy an expensive certificate.

    I'm done messing with WP7, too bad I liked it, thought it would really work.

    Sunday, May 01, 2011 5:48 PM
  • I also would like to know:

     

    1) Where I could find the installed certificate on my phone ? 

    2) Could I uninstall certificate that I previously installed on the phone ?

     

    thx

    Thursday, May 05, 2011 5:49 AM
  • So long as you can access the Exchange Server and get a copy of the Certificate - it works a treat. What's totally galling is that Outlook (a Microsoft product) will not allow you to send it to another PC running Outlook. In the end we opened up a Google Mail Account and stored it there. If any of our users have to reset their W7 phones then they setup up an agreed common Google Email account and we email it out. Once received it can be downloaded and activated.

    Why do Microsoft insist on making you jump through hoops??

    Sunday, May 15, 2011 11:34 PM
  • I send a .der certificate to my hotmail account, installed the certificate as attached from hotmail and this solved my problem on my new HTC Trophy phone.
    Thursday, May 26, 2011 12:28 PM
  • Thomas, 

    I (and some other people) have been having a hell of a time trying to have the phone memorize my certificate.  I have been using .cer.   I'll try the p7b format tomorrow but is there any specific reason to use that format?

    I *do* remember a sample wp7 cert installer app which is an aspx sample code page I found around that coughs them in p7b format. I even have it on my project but stopped using it.   

    The sample project that is giving us trouble does use .cer and seems to work for some people and not to others (http://watoolkitwp7.codeplex.com/discussions/257804).   So, all in all and more of an academic question: Why P7B?   

    Friday, May 27, 2011 5:09 AM
  • I used the internal web site CERTSRV, downloaded the root certicate and it installed.
    Wednesday, June 01, 2011 2:41 AM
  • Hi

    It works

    thanks

    CG

    Thursday, June 02, 2011 9:29 PM
  • It is worth noting that I initially installed an expired certificate from my Server (through an email to my Hotmail account), and realized this afterward.  Anyway, after installing the correct, not expired Certificate on my Windows 7 Phone (HTC Trophy) I had to reboot the phone before the "Attention Required" with the 80072F06 Error code would go away.


    Directory of Technology
    Tuesday, June 14, 2011 8:55 PM
  • STILL NOT WORKING

    I TRIED EVERY SINGLE WAY

    for the love of god cant MS just fix this the was IPHONE and Android does !!! its a shame that a bug like that makes our life living hell 

    please let us IGNORE the certificate error and start work 

     

    Sunday, July 17, 2011 6:45 PM
  • I have been having issues with my Windows Phone 7.  I imported the certificates, and tried just about everything.  One thing I found was that my domain account was a domain admin account.  There is a setting that gets reset on a domain admin account that effects exchange syncing to mobile devices.

     

    Open up AD users and computers.  Enable advanced view, then open up your account.  Click on the security tab, then select Exchange Trusted subsystems, then tick full control.

     

    Retry your sync and see if that helps :)

     

    This tripped me up for aaages.  Hope this information helps.

     

     

    Sunday, August 14, 2011 9:13 AM
  • i had the same Problem, and now i have a solution :-)

    Have you a Root CA Certificate of you’re Domain, so go first to you're locale Client (PC, Laptop) then open the mmc and load the snap-in for Certificates, select Local computer;
    - on Trusted Root Certification Authorities - Certificates
    -Searche youre RootCA Certificate

    - then export this Certificate as a DER-coded-binary X.509 (CER) on you're local Computer

    - Search the Certificate and send it via Mail (another Mail-account Hotmail for example) to you're WP7

    - Sync the Mail Box and open the attachment

    - install this Certificate

    - now test you're Sync with the EAS Account

    it should be working, be happy and have fun


    Works like a charm! Thank you! :)
    Monday, September 05, 2011 1:56 AM
  • I have tried all of the above, nothing seems to be working. I have tried both CER and P7B options. and am still getting the same error that dosent change no matter what. The error code is 85010016. Has anyone got any new ideas? I am just a user not a domain admin my works it guys are pretty slack to taking things into my own hands.

    Tuesday, September 20, 2011 3:20 AM
  • I am trying to synch an LG Quantum phone with an exchange server running exchange 2003 sp2.

    We have a self-issued certificate.

    I have installed the root certificate for my exchange server onto the phone using the "email it to my gmail account and install it from there" method.

    I have power cycled the phone.

    When I attempt to synch outlook with my server it tells me that the required information (server, password, domain) is incorrect. However I have determined that I am in fact providing the correct information.

    My question is this:

    When importing a certificate to a laptop, it will default to placing the cert into the "personal" cert store. I have to navigate to the "Trusted Root Certificates" store and save it there for it to allow outlook to connect to our exchange server. When I installed the certificate on the phone, it did not offer me any options, it just installed it. Where? I do not know. Are there "personal" certificate stores that differ from "trusted root certificate" stores in WP7? If so, how can I tell the phone to install the certificate there instead of in the "personal" cert store?

    Every bit of documentation I have found has told me that exporting the root certificate in this way should solve my problem. Yet it is not working for me. I find post after post after post of frustrated users saying it does not work for them, but never any further solutions beyond installing the root cert. Can anyone help me solve this issue?

    Thanks so much.

     

    Wednesday, September 28, 2011 8:46 PM
  • Even to told you the place to "install" it every time you proceed into internal site which your CERT evaluate your Id ,IT's WILL be continued ........to do it

    When MS will solved this issue ;  who knows !!!!!

    Saturday, October 01, 2011 7:31 AM
  • Exactly the same for me.

    i keep looking and trying. i got the root certificate sent to me by network admin today, installed, still only get email when on company wifi.

    is there a specific point at which i should install the certificates? i first got the outlook web access certificate, then the root. there were only two in the tree he went to.

    should i undo my exchange mailbox - delete and start over?

    i cannot connect to microsoft exchange outlook email with my windows phone. what a thing to have to say. if there were not so many with the same problem, i'd blame it on our IT folks.

    my iphone and android friends can, the IT guys set them up. but anything they try cannot help me.

    Thursday, October 06, 2011 2:32 AM
  • As I am not interested in dealing with Certs and emailing them, I logged into the Outlook Web Access (OWA) account and clicked mobile devices, removed my device and then after 1 minute, I resync'd my phone. Worked perfectly!
    Thursday, October 06, 2011 7:28 AM
  • when install the cert, it needs password for the certintaller

    what is the password?

    Thursday, October 06, 2011 9:46 AM
  • UPDATE:

    I was given a MS Quick Assistance card by a friend. I called MS tech support, they were able to confirm that my exchange server was configured correctly. We then confirmed that the phone was configured correctly. We then decided to delete the outlook profile on the phone and start over. Previously, when configuring the phone, we used Settings>email>outlook to configure the account. This time, when we configured it we used Settings>email>Advanced. In the advanced function, it first asked for the email address and password. Once I entered that information, I pressed the "next" button. On the subsequent screen it asks if the email account is an ActiveSync account or a POP/IMAP account. I selected ActivSync and pressed "next". I  was then asked to enter the domain name and the server address, I entered the info, de-selected the "must use SSL connection" option, selected "next" and the phone began to sync.

    Apparently, if you do not use the "Advanced" option, ActiveSync on the phone does not know to connect to ActiveSync on the server.

    I hope this information is helpful.

    Thursday, October 06, 2011 5:27 PM
  • The phone I was working on did not request a password to install the cert. Have you tried to use the phones password?


    • Edited by BuddyD Thursday, October 06, 2011 7:43 PM
    Thursday, October 06, 2011 5:30 PM
  • I tried everything above here and am now getting an error code of 80072EFD.

     

    Any ideas how to fix this?

    Thursday, October 13, 2011 4:37 AM
  • I am trying to do the same and have installed the certificate and still can't get my email to work. I am so frustrated. I have tried the new Android and now the HTC Windows 7 phone and can't get either to work. Everyone that has an iPhone just connects without the hassle. I don't really want to be like everyone else and get an iPhone, but it appears I don't have a choice. You would think a Windows Phone would work with MS Exchange much easier than an iPhone but I guess that would be too much to ask. I guess I will go out and purchase the iPhone since I have no other option and have already wasted 3 weeks of my time trying to get a stupid phone to work.
    Thursday, November 03, 2011 6:04 PM
  • i agree.  I gave up after months of wasting time with the thing and had to go out and get a iphone 3g... because I had dumped 100's on the WP7.  so unbelievably disappointed.  there are hundreds of threads out there with the same problem.  I dont like the iphone... but hell... it works with exchange... and wp7 doesnt - at least not if you are using certificates.  I have to say - that this experience topped with dropping 100's on vista - now I have replaced everything with macs... and... it... just... works... everything...
    Wednesday, November 23, 2011 1:40 AM
  • I had the same issue of certificate error and tried several time to install .cer file but unable to sync with my exchange. When i try this by exporting this certificate with .p7b extensions it works fine for me. I do the following steps.

    1. Export the certificate into .p7b

    2. Email it to my hotmail account tagged with my windows mobile

    3. Download this certificate and install.

    4. Configure new outlook settings

    and it starts working fine.

     

    Friday, November 25, 2011 10:36 AM
  • Such a pity that this problem has not been resolved in over a year. I can connect to the exchange server at work with an iphone, an ipad and all android phones - but not a windows phone. Get your act together MS and let the  windows phones talk to the windows server. If I need to talk to a computer admin to connect a phone you are doing something wrong.
    Monday, December 12, 2011 1:15 AM
  • Windows Phones work just fine! It's Android and iPhones who do an incomplete check of server certificate time validity. Check if your server certificate has expired...
    Tuesday, December 13, 2011 8:53 AM
  • I was getting the dreaded certificate error 80072f0d (our Exchange server uses a self-signed certificate) and tried importing the cert as a .CER — it did not work.  Then I tried importing the cert as .P7B as reccommended Shazee123, and now it works.  Thanks for the tip (I don't have to return my Titan now)!!

    Thursday, December 15, 2011 11:14 PM
  • Also the trick with .p7b certificate worked for me. Thanks.


    Daniel
    Thursday, December 22, 2011 10:27 AM
  • This did not work for me , it says installed (screen looks the same when using .cer or .p7b but i get the dreaded error still. I had to put a cert on to enable iphones activesync access and since then my windows phone 7 devices have went kaput even when on wlan and not just 3g.
    Monday, December 26, 2011 8:47 PM
  • I successfully copied the certificates after I logged into my employers Outlook Web Access Exchenge server. The certificates were not valid there either. Clicking on the angry red certificate error next to the web address allowed me to view the offending certificates. I exported them to a file on my PC, emailed them to my self using a Gmail account, opened the attachments and it all worked. Wow!
    Oh and I cycled power afterwards.
    • Edited by burlbatman Wednesday, December 28, 2011 4:41 AM
    Wednesday, December 28, 2011 4:41 AM
  • Please be aware that i some cases you also need to export the persnal certifcate!!!!! SO DO THIS BEFORE CHANGING TO A IPHONE!

    Step Two Install the personal Certificate from the device to the handset:

    Have you a Root CA Certificate of you’re Domain, so go first to you're locale Client (PC, Laptop) then open the mmc and load the snap-in for Certificates, select My User Account

    Go to Certificates – Current User

    -      Personal -> Certificates  

    -      Find the Local user/domain certificate (usually your name and used for Encrypting File system)

    -      All tasks – export – Next

    -      Yes export the private key

    -      Personal – PKC – tick Include all certificates & Export all extended

    -      Supply password

    -      Email or copy it to your phone and double click to install it.

    Sunday, January 22, 2012 11:53 PM
  • yeah, but new year = new certificate,
    and now it didn't work like that
    Tuesday, January 24, 2012 9:51 AM
  • Hi, I have personal Blackberry and it connects to Company's Outlook Web Access to pull mail via BIS. But recently I got Samsung Focus Flash with Mango update and it gives me error code 85010004. I followed posts on net and downloaded and installed root.cer, leaf.cer and intermediate1.cer files SSL Chainsaver created onto my phone, but it still doesn't work. Also exported all as .p7b file. Admin won't be able to run Active Sync like suggested in few posts. Please suggest how can I resolve this as this is deal breaker for me. Thanks, Jay
    • Edited by Dub123 Friday, January 27, 2012 3:37 AM
    Friday, January 27, 2012 3:36 AM
  • I have a Samsung Omnia 7.

    I have tried everything to get this phone working with Outlook exchange server with certificates.  My friends have iPhones and Android phones and no problem with our company mail.


    This is tragic.  I got the certificate mailed to me from our IT admin (I don't have an admin account).  I tried converting it to .p7b.  If I try to install the cert as a .cer it says successfully installed.  I restart, and it doesn't work.  I installed it as a .p7b, and again it doesn't work.  When I try a second time, it says I have already installed the cert.


    This is just tragic.  Microsoft phones won't work with their own software.



    Monday, February 06, 2012 10:54 PM
  • I didnt have to do any of the certificate crap. Just delete your existing email account that stopped working all of a sudden and then re add it and then shut the phone down and turn it back on. That worked for me it might work for some of you. Try that before updaing cert files.
    • Proposed as answer by RAurelian Friday, February 10, 2012 4:19 PM
    • Unproposed as answer by RAurelian Friday, February 10, 2012 4:19 PM
    Friday, February 10, 2012 1:40 PM
  • Anyone knows if mycrosoft will ever provide the option to just ignore the certifficate?

    I am the IT Admin in my company and we have all kinds of mobile devices (iOS, Android, Symbian, Bada, WebOS, WinMobile, BlackBerry) and they all work with our Exchange 2003 SP2 server (self-signed certificate), but now we also purchased two WP7 devices (LG Optimus 7 and Samsung Omnia 7) and for one of them (the Omnia) I cannot set up the Outlook account or ActiveSyc, nomatter what I try - and belive me, I have tried everything I found on Google. It was a pain installling the certificate on the Optimus 7, but at least it worked - however, at least that worked, because the Omnia 7 would not work regardless of what certificate I installed. i just get the 80072F05 error and that`s it.

    So, does anyone happen to know if Microsoft at least acknowledged this issue and are working on a fix? I have seen posts like this going back a year and three monts now and this issue is still not addressed. Can anyone of you help me to talk to a Microsoft support rep directly? because from their website I only get redirected and redirected...

    Thank you! 

    Friday, February 10, 2012 4:30 PM
  • Nokia Lumia 800 = 50+ failed atempts using everything from above... but this did the trick:

    1) Go first to your local Client (PC, Laptop) then open the mmc and load the snap-in for Certificates, select My User Account

    -   Go to Certificates – Current User

    -    Select Trusted Certification Authorities -> Certificates

    -      Find the Local user/domain certificate

    -    Double click on the certificate. Go to the Details tab and click copy to file. Export it 3 times using the 3 different format options (I did this just in case).

    2) Now load the snap-in for Certificates, select Computer Account

    -   Go to Certificates – Computer Account

    -    Select Trusted Certification Authorities -> Certificates

    -      Find the Local user/domain certificate

    -    Double click on the certificate. Go to the Details tab and click copy to file. Export it 3 times using the 3 different options (I did this just in case).

    3) Email (using gmail to self gmail webmail) and when you receive all 6 attachments, double tap each one to install them

    4)If phone is plugged via USB, remove cable, shuttown phone... restart phone. Readd exchange accont credentials.

    Worked, for me - hope it works for you.
    • Edited by Mr-Spidey Sunday, February 12, 2012 9:32 AM
    Sunday, February 12, 2012 9:31 AM
  • /\ /\ /\ /\

    Excuse the ignorance but how do you know which one is the "Find the Local user/domain certificate"

    Thanks


    • Edited by ZippaZappa Monday, February 13, 2012 9:37 PM
    Monday, February 13, 2012 9:37 PM
  • I have tried these steps, imported and installed the Root CA cert in my WP7.5 phone, still getting the same error message. Have tried rebooting and synchronising again as well. anything else I should try?

    Thanks

    Vikas

    Tuesday, February 14, 2012 1:25 AM
  • I have tried these steps, imported and installed the Root CA cert in my WP7.5 phone, still getting the same error message. Have tried rebooting and synchronising again as well. anything else I should try?

    Thanks

    Vikas

    See if you can find another ROOT CA certificate in your repository.... For me there were two ROOT CA certificates.... only one of them worked though....

    Tuesday, February 21, 2012 9:37 AM
  • I have tried these steps, imported and installed the Root CA cert in my WP7.5 phone, still getting the same error message. Have tried rebooting and synchronising again as well. anything else I should try?

    Thanks

    Vikas

    See if you can find another ROOT CA certificate in your repository.... For me there were two ROOT CA certificates.... only one of them worked though....

    Tuesday, February 21, 2012 9:37 AM
  • I have tried these steps, imported and installed the Root CA cert in my WP7.5 phone, still getting the same error message. Have tried rebooting and synchronising again as well. anything else I should try?

    Thanks

    Vikas

    See if you can find another ROOT CA certificate in your repository.... For me there were two ROOT CA certificates.... only one of them worked though....

    Tuesday, February 21, 2012 9:37 AM
  • Try deleting the Outlook accont that doesn't sync before rebooting the phone. The steps in the Feb 17 2012 post of this thread worked for me:

    http://answers.microsoft.com/en-us/winphone/forum/wp7-sync/error-code-80072f0d-by-sync-wp-7-with-ms-outlook/707810f0-fd33-4ffc-b287-c655ef800a99

    Tuesday, February 21, 2012 3:38 PM
  • you are wrong. our cert works properly for every other application and check was issued by digi. we paid several thousand dollars for this cert. exchange 2010 confirms it so does our owa why not windows phone 7. 
    Friday, February 24, 2012 6:14 PM
  • Worked perfectly. Thank you very . Make sure you turn phone off and on again. 
    Friday, March 16, 2012 2:19 AM
  • I find out a very simple way to fix it

    Here it goes

    Internet Explorer -> Options -> Content -> Certificates

    Locate your certificate and click over it -> Export -> Save as XXX.cer

    Now send this file by e-mail to your WP7 e-mail so you can open it there

    Click on it -> WP7 will ask if you want to install it -> Install

    That it.... Now you Exchange e-mail should be working...

    Rgds,

    Afonso Meireles

    Saturday, March 24, 2012 12:04 AM
  • People, look this article that have the steps to create.

    http://answers.microsoft.com/en-us/winphone/forum/wp7-sync/error-code-80072f0d-by-sync-wp-7-with-ms-outlook/707810f0-fd33-4ffc-b287-c655ef800a99?tm=1332782760047

    Search by reply of RoyceFu. I follow these steps and may mobile phone sync now.

    Monday, March 26, 2012 5:38 PM
  • i had the same Problem, and now i have a solution :-)

    Have you a Root CA Certificate of you’re Domain, so go first to you're locale Client (PC, Laptop) then open the mmc and load the snap-in for Certificates, select Local computer;
    - on Trusted Root Certification Authorities - Certificates
    -Searche youre RootCA Certificate

    - then export this Certificate as a DER-coded-binary X.509 (CER) on you're local Computer

    - Search the Certificate and send it via Mail (another Mail-account Hotmail for example) to you're WP7

    - Sync the Mail Box and open the attachment

    - install this Certificate

    - now test you're Sync with the EAS Account

    it should be working, be happy and have fun


    How do i knows which one is my RootCA Certificate do i need to export the certificate really from the local machine or best to export it from exchange server?
    Friday, April 20, 2012 10:59 AM
  • Thanks Thomas,

    It works like magic!

    Kelvin (on his NOKIA Lumia 800)

    Tuesday, May 15, 2012 6:41 AM
  • Hi everyone,

    I have a Nokia Lumia 710 device. I try to sync with my company's Exchange 2010 server, but my device unable to sync. The error code is 80072F0D and the message says the certificate is not valid.

    Previously I tried to install different type of certificates I found on my PC. None of them worked, every time the same error code appeared.

    Finally I got the my companys certificate from the admin. When I installed the certificate, the device said "The certificate has been already installed". The message this time was different from the ones I got when I had installed the former certificate.

    Previously the device asked also, that if  want to install the certificate. This time this question did not appear on the screen. Could be the reason for this is the fact, that one of the name of the previously installed certificate the same as I got from the admin (although its content is different)? I mean is it possible that if I have already installed a certificate on my device, the telephone will not install a certificate with the same name, with different content? Also I would like to know, if this is is situation, what can I  do? How can I delete the previously installed certificate?

    I tried several thing to solve this problem (eg.: save the certificate as P7B, etc, bot none of them worked.

    Thanks for your help

    Laszlo

    Tuesday, May 22, 2012 9:38 PM
  • Hello everyone,

    I hope my fix helps you out. I just got myself a Nokia Lumia 900 and I was having Certificate errors.

    My fix consisted of copying the exact settings from the exchange account already setup on my laptop,

    • 1

      In Microsoft Outlook 2010, click File, click Account Settings, and then click Account Settings.

    • 2

      Click your Microsoft Exchange email account name, and then click Change.

    • 3

      Click More Settings.

    • 4 Click the Connection tab, click Exchange Proxy Settings, and then ***note the server*** address in the Use this URL to connect to my proxy server for the Exchange mailbox.In this area, the settings in my case were reflecting a different server name, when I initially tried to setup my account. (This is the part that was wrong in my initial setup when trying to setup exchange initially, and I was receiving the dreaded error with the certificate, so I just copied the exact settings on my phone, in the server address field, and BOOM I had an instant connection with no errors, woohoo!Here is the link below, which was a godsend for me:)

    http://www.microsoft.com/windowsphone/en-us/howto/wp7/people/set-up-an-email-account.aspx

    Good Luck,

    Anthony

    Friday, May 25, 2012 6:24 AM
  • What I have understood about this all I have to install cert for mail.domain.com and if that dont work I have to install also server root certificate that is issued by serverdomain-servername.ca to serverdomain-servername.ca.

    Is this correct?

    Tuesday, May 29, 2012 10:05 AM
  • I got it working by installing certificate from mail.mydomain.com/owa which is issued to mail.mydomain.com by internaldomain-servername-CA, installing root certificate issued to internaldomain-servername-CA by internaldomain-servername-CA and placing to mailbox credentials to "Domain" internaldomain.local as suggested by following link.

    I havent tested what of these three parts are necessary and if some of them is not but now it works for me.

    http://brownsmart.co.uk/setting-up-windows-phone-7-for-outlook-exchange-2010/
    • Edited by Junkelo Thursday, May 31, 2012 6:14 AM
    Thursday, May 31, 2012 6:13 AM
  • What worked for me: (only .p7b worked, not .cer file!)
     - Start -> Run -> mmc
     - Load the snap-in for Certificates, select My User Account
     - Certificates – Current User
     - Trusted Certification Authorities -> Certificates
     - My Local user/domain certificate
     - RightClick -> AllTasks -> Export -> PKCS #7 (.p7b) with <include all sertificates if possible>

    Then put the file to skydrive and open it with the program BoxFiles on my Mobile.

    Wednesday, July 25, 2012 9:28 AM
  • It doesn't work for me although I followed the same steps.

    When I use the Lumia 710 to browse OWA, I did not get an cert error warning so I assume the certificate is correctly installed, however, when I use the phone to sync with Exchange I get the error saying that I need a personal certificate...

    I've even try to reset the phone and re-install the certificate but still doesn't work..

    Any idea?

    Wednesday, July 25, 2012 3:12 PM
  • plz mail me iam also suffering for that erros while open emails  in my nokia lumia710

    plz sen me RootCA Certificate to me through mail hotmail

    my mail id i s naveendols@gmail.com

    Tuesday, July 31, 2012 8:31 AM
  • To browse OWA with your phone browser dont need that cert to be installed to your phone. It is a different thing.

    For Exchange to work, you need correct certs' installed.


    Try my instructions below and let me know if it worked.
    • Edited by Junkelo Thursday, August 09, 2012 12:55 PM
    Thursday, August 09, 2012 12:52 PM
  • We cannot send you cert for your organization. You have to ask for it from the admins of your organization or your server admins.

    Try my instructions below and let me know if it worked.

    • Edited by Junkelo Thursday, August 09, 2012 12:55 PM
    Thursday, August 09, 2012 12:53 PM
  • This method worked for my HTC Radar and now my emails are configured and working properly... :)

    Thanks Slaet...

    Thursday, August 23, 2012 4:52 AM
  • Hello, I have a LG Optimus 7 and I am trying to synchronize with SBS 2003. I have installed the certificate on the phone but when you sync gives the error 85002028 "Windows Phone Your server does not support this version. Contact support person or service provider."

    I tried everything you have put in the thread and does not work. What I can do?
    Wednesday, September 26, 2012 4:10 PM