none
Outlook 2010 talking to wrong Public Folder Server

    Question

  • Hello,
    I have an Exchange 2010 DAG with a Public Folder database on one of the servers. I also have a DR site that houses a replicated copy of that Public Folder database.

    When I monitor Outlook 2010 using RPCDIAG, I keep seeing it connecting to the DR Public Folders. This happens consistently, especially when I initially open Outlook. Eventually the connection goes away, though if I access Public Folders at that point the connection doesn't show up again - is rpcdiag a bit unreliable when it comes to this or why does this not show up?

    The database client settings point to the correct server. The Public Folder referral is configured to use AD Site Costs, but if the database is specifically told to connect to Server X, why is it connecting to Server Y (DR)? The workstations I've tested are in the same site as the Exchange server, while the DR server is in another site. Shouldn't all of this configuration ensure that the connection is made to the correct server?

    I've also noticed that some other clients connect to the correct public folders, while others end up showing connections to both at the same time.

    And lastly I've been getting these SYNC errors every time I open Outlook. They refer to the DR server which Outlook shouldn't be connecting to. I assume this is all related.

     14:26:17 Downloading from server 'DR-SERVER.domain'
    14:26:17 Error synchronizing folder
    14:26:17                                 [80004005-501-4B9-560]
    14:26:17                                 The client operation failed.
    14:26:17                                 Microsoft Exchange Information Store
    14:26:17                                 For more information on this failure, click the URL below:
    Can anyone explain this behavior?

    Thanks,
    Matt

    • Edited by exxczyk Wednesday, March 14, 2012 9:37 PM
    Wednesday, March 14, 2012 9:36 PM

Answers

All replies