none
OWA user is not able to change password

    Question

  • One of the user logs on to his mail account using OWA tries to change his password and gets "401: you don't have the permission to access this directory " . As he clicks the change password from options he gets this message. Where should I start looking from.

    Thanks,

    Shireesh

    Thursday, August 30, 2012 2:53 AM

Answers

  • Hi,

    Please check the following registry value on the CAS server:

    1. On the Client Access Server (CAS), click Start > Run and type regedit and click OK.

    2. Navigate to HKLM\SYSTEM\CurrentControlSet\Services\MSExchange OWA.

    3. Right click the MSExchange OWA key and click New > DWord (32-bit).

    4. The DWORD value name is ChangeExpiredPasswordEnabled and set the value to 1.

    5. Note: The values accepted are 1 (or any non-zero value) for "Enabled" or 0 or blank / not present for "Disabled"

    6. After you configure this DWORD value, you must reset IIS. The recommended method to reset IIS is to use IISReset /noforce from a command prompt.

    Thanks,

    Simon Wu

    Exchange Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, August 31, 2012 7:17 AM

All replies

  • You could start by finding out what version, service pack and update rollup level you're running.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Thursday, August 30, 2012 4:03 AM
  • Thanks Ed,

    I have a feeling that the 'windows security' dialog box for user credential is getting suppressed on his browser which is causing the attempt to change the password error out with 401. Waiting to confirm this.


    • Edited by Shireesh1 Thursday, August 30, 2012 6:03 AM
    Thursday, August 30, 2012 6:02 AM
  • Hi,

    Please check the following registry value on the CAS server:

    1. On the Client Access Server (CAS), click Start > Run and type regedit and click OK.

    2. Navigate to HKLM\SYSTEM\CurrentControlSet\Services\MSExchange OWA.

    3. Right click the MSExchange OWA key and click New > DWord (32-bit).

    4. The DWORD value name is ChangeExpiredPasswordEnabled and set the value to 1.

    5. Note: The values accepted are 1 (or any non-zero value) for "Enabled" or 0 or blank / not present for "Disabled"

    6. After you configure this DWORD value, you must reset IIS. The recommended method to reset IIS is to use IISReset /noforce from a command prompt.

    Thanks,

    Simon Wu

    Exchange Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, August 31, 2012 7:17 AM
  • Hi,

    Is there any update on this thread?

    Thanks,

    Simon Wu

    Exchange Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, September 03, 2012 2:41 AM