none
Outlook 2007 Points to Wrong Server

    Question

  • We just upgraded our Exchange from 2007 to 2010.  We continue to use Outlook 2007 on our desktops.  When we migrated mailboxes, the user's Outlook client automatically updated and pointed to the new 2010 CAS server.  OWA and everything else works, so this doesn't appear to be an autodiscover issue. 

    My servers are:  EX01 (Exchange 2007 Mailbox Server); EX02 (Exchange 2010 Mailbox Server); EXCAS01 (2007 CAS); EXCAS02 (2010 CAS)

    While existing users all updated correctly, if I turn off EX01 and EXCAS01 and login to a different computer, my Outlook will not point me to EXCAS02 but continues to search for EX01 (2007) and fails.  If I manually update the profile to point to EXCAS02 and reboot, everything saves and will always work.  With EX01 and EXCAS01 running, I can login to a different machine and it will automatically point me to EXCAS02.

    To make matters worse, it is only a desktop issue.  We run Outlook on Citrix, which would obviously be an internal connection, and whether EX01 and EXCAS01 are on or off, it will point me to the right server automatically.

    I have searched through our Office 2007 Configuration Tool and I do not see any configuration files that would point the client to EX01.  Is there a configuration file I can push down on first login to change the Exchange Server on the client machines to point to EXCAS02?  I tried changing our DNS but that trick failed (at least it seemed to have failed...).  I'm really at a loss and I'm afraid to finish decommissing our Exchange 2007 environment until I know we can roll out new machines and get new employees without having to manually change each machine every time a new user logs in.

    Thanks in advance...I hope I covered all necessary information.

    Friday, June 15, 2012 10:03 PM

Answers

  • Hi Mike,

    I think the issue  you are encountering is by design and what we need to do is setting up a CASArray to provide load balance.

    Refer to:

    http://blogs.technet.com/b/omers/archive/2010/10/11/microsoft-exchange-2010-cas-array-steps-and-recommendations.aspx

    Regarding the configuration file, not there is no such file. If you go through the article below you may noticle the SCP record that Outlook use t to contact Autodiscover service and update Outlook profile automatically.

    Generally the first SCP record is the first CAS server in your organization. If the first CAS server is down, which means Outlook will find this record but will fail to contact the target server. If this is true, Outlook will not update it' profile. That's why it could not point to ExCAS02 atomacally.

    http://technet.microsoft.com/en-us/library/bb124251.aspx

    As for Outlook on citrix, I assume users create Outlook profile every time they login. So Outlook can search for the live CAS server and confige the profile automatically; and finally connect successfully. Let me know if there is any misunderstanding.


    Fiona Liao

    TechNet Community Support

    Monday, June 18, 2012 9:38 AM
    Moderator

All replies

  • Have you created checked the value of the RPCClientAccess value on the 2010 database?

    Can you alos check the autodiscover URL on the 2007 server and 2010 server?

    Have you created a CAS Array or not?

    Are all mailbox moved to the 2010?


    Sukh

    Friday, June 15, 2012 10:43 PM
  • We only have one 2010 CAS Server.  If I run a Get-ClientAccessServer |fl identity,autodiscoverserviceinternaluri, it returns the following:

    Identity EXCAS01 - https://mail.company.com/autodiscover/autodiscover.xml

    Identity EXCAS02 - https://mail.company.com/autodiscover/autodiscover.xml

    All of our mailboxes have been moved.  And, aside from logging into a new computer for the first time, there hasn't been a single issue.  This is the only thing stopping me from shutting down 2007.

    I'm not sure what command to run to check the RpcClientAccessServer.

    Friday, June 15, 2012 11:17 PM
  • Check the SCP values and see which one is listed 1st and if one exists for 2010

    http://www.msexchange.org/articles_tutorials/exchange-server-2010/management-administration/exchange-autodiscover.html

    Sukh

    Friday, June 15, 2012 11:49 PM
  • Hi Mike,

    I think the issue  you are encountering is by design and what we need to do is setting up a CASArray to provide load balance.

    Refer to:

    http://blogs.technet.com/b/omers/archive/2010/10/11/microsoft-exchange-2010-cas-array-steps-and-recommendations.aspx

    Regarding the configuration file, not there is no such file. If you go through the article below you may noticle the SCP record that Outlook use t to contact Autodiscover service and update Outlook profile automatically.

    Generally the first SCP record is the first CAS server in your organization. If the first CAS server is down, which means Outlook will find this record but will fail to contact the target server. If this is true, Outlook will not update it' profile. That's why it could not point to ExCAS02 atomacally.

    http://technet.microsoft.com/en-us/library/bb124251.aspx

    As for Outlook on citrix, I assume users create Outlook profile every time they login. So Outlook can search for the live CAS server and confige the profile automatically; and finally connect successfully. Let me know if there is any misunderstanding.


    Fiona Liao

    TechNet Community Support

    Monday, June 18, 2012 9:38 AM
    Moderator