none
mailbox database defaults

    Question

  • how do you change the mailbox database defaults?  in particular the storage quotas?    thinking about creating a database for mgt with higher quotas than the other databases.  I see where i can change the quota on a particular user, just not the database as a whole.
    Tuesday, April 12, 2011 4:28 PM

Answers

  • 1. Open Echange Management Console, 
    2. Click Mailbox under Organization Configuration and select the Database Management tab
    3. Right-click the database you want to configure and click Properties
    4. Open Limits tab
    From Echange Managment Shell
    Set-MailboxDatabase -Identity MyrDatabase -IssueWarningQuota 1000MB -ProhibitSendQuota 1200MB -ProhibitSendReceiveQuota 1500MB
    Remember that quotas takes up to 120 minutes to take in effect.

    Adam Bokiniec
    Tuesday, April 12, 2011 6:33 PM

All replies

    1. Start Registry Editor (regedit).
    2. Locate the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<Server Name>\Private-<database GUID>

    You can get the GUID of a database by running the following command in the Exchange Management Shell: Get-MailboxDatabase -Identity "<database name>" | Format-Table Name, GUID

    If the Database Size Limit in GB DWORD exists for the subkey, change its value to the desired size in gigabytes. If the DWORD does not exist, create it and set its value to the desired size in gigabytes.

    http://technet.microsoft.com/en-us/library/bb232092.aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by nleslie1970 Tuesday, April 12, 2011 5:06 PM
    • Unmarked as answer by nleslie1970 Tuesday, April 12, 2011 6:16 PM
    Tuesday, April 12, 2011 4:56 PM
  • I think these are instructions on how to set the limit of a database not change the mailbox size for the users in the database.
    Tuesday, April 12, 2011 6:17 PM
  • The instructions m.salah gave you were for those users running the Standard version of Exchange.

    If you are running the Enterprise version, the Limit's tab on the database properties gives you the default mailbox sizes. Once set, you must restart the information store for the change to show up to each user.

    If you are running the Standard version, you would follow m.salah's suggestions.

    Tuesday, April 12, 2011 6:27 PM
  • 1. Open Echange Management Console, 
    2. Click Mailbox under Organization Configuration and select the Database Management tab
    3. Right-click the database you want to configure and click Properties
    4. Open Limits tab
    From Echange Managment Shell
    Set-MailboxDatabase -Identity MyrDatabase -IssueWarningQuota 1000MB -ProhibitSendQuota 1200MB -ProhibitSendReceiveQuota 1500MB
    Remember that quotas takes up to 120 minutes to take in effect.

    Adam Bokiniec
    Tuesday, April 12, 2011 6:33 PM
  • Hello,

     

    For more reference to meet your requirement, here are the related links:

     

    Configure Mailbox Database Properties

    http://technet.microsoft.com/en-us/library/dd297937.aspx

     

    Understanding Quota Messages

    http://technet.microsoft.com/en-us/library/bb232173.aspx

     

    Thanks,

    Simon

    Friday, April 15, 2011 1:45 AM
  • I was a little confused because i think i was looking for the word quota.  I see now that by putting a figure in the prohibit send etc is effectively setting the quota.  i understand now. 

     

    thx

    Monday, May 02, 2011 3:47 PM