none
550 5.3.4 message size exceeds fixed maximum

    Question

  • Hi all,

     

    I've installed an Exchange 2007 installation with one of my customers. The installation works almost fine.

    Our customer has an need to send emails larger than 10Mb.

    Browsing the internet gives me several tips how to do the trick with the powershell. And it works - almost-.

    The exchange server has the limits set when i look at "Get-TransportConfig | fl max* ". But when the clients mail files larger than 10Mb they still receive the message size error from the exchange server. The transport service is also restarted after the change (also the complete server).

    Does anyone have any idea where this can go wrong?

     

    Thanks in advance.

    Ron

     

     

    - There are 10 types of people, those who understand binairy and those who don't -

     

    Friday, July 13, 2007 9:59 AM

Answers

  • Hello folks,

     

    I found the solution. Read the text below:

    Connector Limits

    As mentioned above, it is also possible to set message size limits for Exchange Server 2007 Send Connectors, receive Connectors and Foreign Connectors.

    Should you wish to see the number of Exchange Receive connectors, use the following CMDLet:

    Get-receiveconnector | List


    Figure 3: GET-RECEIVECONNECTOR

    Should you wish to see the configuration of Exchange Send connectors, use the following CMDLet:

    Get-sendconnector | List


    Figure 4: GET-SENDCONNECTOR

    Should you wish to change the message size limit for a connector, use the following CMDLet:

    SET-SENDCONNECTOR –IDENTITY RAUS –MaxMessageSize MessageSizeYouWant

    Please note:
    You must use the –IDENTITY parameter only if there is more than one send connector on the server.

    Friday, July 27, 2007 7:23 AM

All replies

  • Hi,

     

    You can try the following:

     

    Start adsiedit and find:

     

    Configuration --> Configuration --> Services --> Microsoft Exchange --> Exchange Organization name --> Global Settings --> Message Delivery

     

    Get the properties of Message Delivery and look for the values "DelivContentLength" and "SubmissionContentLength". If these values are set to 10240 you click the Clear button followed by the OK button to make sure that these values are not set.

     

    After AD replication you restart the exchange services and should be all set.

     

    Leif

     

    Saturday, July 14, 2007 6:35 PM
  • Hi Leif,

     

    thanks for your help. Tomorrow I will try it en than I let you know if it works! Have a nice day!

     

    Ron

    Monday, July 16, 2007 2:49 PM
  • Hi Leif,

     

    I have tried the solution with a file of 7 MB, and indead it works. But now I have tried with a file of 10,1 MB and I get the same error message as above....

     

    Do you have some more tips/tricks? I have already restarted the exchange-services.

     

    Ron

    Tuesday, July 17, 2007 1:58 PM
  • There is a very simple solution for those of you out there with this problem.

    Set-ReceiveConnector -identity "Default [SERVERNAME]" -maxmessagesize 20MB

     

    If you want to read more on the issue you can check out my blog.

     

    After this I restarted all of the Exchange Services, but I am not certain that this step is required. 

    Thursday, July 19, 2007 3:12 PM
  • Sunday, July 22, 2007 7:52 PM
  • Hi Steve,

     

    I've applied your solution, but I still get the error-message!!! Grrrrrrrrrrr

    Also when I restarted all the Ex-services.

    Do you have any other suggestions?

     

    Kind regards,

     

    Ron

    Monday, July 23, 2007 7:48 AM
  • Monday, July 23, 2007 8:34 AM
  • Dear Lasse,

     

    I've readed the article, but I have already applied the solutions.

    It seems not te be working.

    The providers allow mail messages from max 30 MB.

     

    Do you have any other suggestions?

     

    Gr. Ron

     

    Wednesday, July 25, 2007 12:44 PM
  • Hello folks,

     

    I found the solution. Read the text below:

    Connector Limits

    As mentioned above, it is also possible to set message size limits for Exchange Server 2007 Send Connectors, receive Connectors and Foreign Connectors.

    Should you wish to see the number of Exchange Receive connectors, use the following CMDLet:

    Get-receiveconnector | List


    Figure 3: GET-RECEIVECONNECTOR

    Should you wish to see the configuration of Exchange Send connectors, use the following CMDLet:

    Get-sendconnector | List


    Figure 4: GET-SENDCONNECTOR

    Should you wish to change the message size limit for a connector, use the following CMDLet:

    SET-SENDCONNECTOR –IDENTITY RAUS –MaxMessageSize MessageSizeYouWant

    Please note:
    You must use the –IDENTITY parameter only if there is more than one send connector on the server.

    Friday, July 27, 2007 7:23 AM
  • Found the answer to the 10meg limit.

     

    On the TransportConfig the unlimited configuration results in 10mb limit.  In SP1 the output from the command (Get-Transportconfig | fl) will show 10 mb limit.  This is displayed in the 1st article.  The 2nd article show that a 64base attachments increase in 33% in size due to TNEF (Transport Neutral Encapsulation Format).  I set the transport configuration to 30 megs to compensate for the overhead.  This setting does not require a restart of the transport service but requires at least 15 minutes to replicate between the Hub Transport and the Mailbox Server.

     

    I sent a test to a internet user and successfully transported a 20 meg file attachment.

     

    1st Technet Article:  The below article explains the limit defaults

    http://technet.microsoft.com/en-us/library/bb124345.aspx

     

    Section of above article:

    Source

    Parameter

    Default value in Exchange 2007 RTM

    Default value in Exchange 2007 SP1

    Set-TransportConfig

    MaxReceiveSize

    Unlimited

    10 MB

    Set-TransportConfig

    MaxSendSize

    Unlimited

    10 MB

     

     

    2nd TechNet Article:

    http://technet.microsoft.com/en-us/library/aa996221.aspx

     

    Section of above article:

    For outgoing SMTP messages being sent between routing groups, Exchange Server will render attachments in the Transport Neutral Encapsulation Format (TNEF), which is base64 or quoted printable rather than binary. This will cause an approximate 33 percent size increase in the messages.

    Tuesday, January 08, 2008 7:34 PM
  • So I spent few hours looking for solutions - and mine turned out to be SmartHost setting (not Exchange).  So if you have IronPort as a smarthost, be sure to check the default MailFlow size setting - and it is really easy to adjust.

    Cheers.


    Zach

    Wednesday, December 05, 2012 9:26 PM
  • Hi All,

    sometimes that problem just because of " an email message that is larger than the sending message size limit or the receiving message size limit is not delivered". 

    After you configure the Sending message size option or the Receiving message size option in Exchange System Manager, you may experience one or more of the following symptoms:
    • Users cannot receive messages that are larger than the sending message size limit.
    • Users cannot send messages that are larger than the receiving message size limit.
    • If you do not configure one of the options, messages are restricted by the limit that you set on the remaining option. For example, if you do not set the Sending message size option, users cannot send or receive messages that are larger than the limit that you configured for the Receiving message size option.
    The Sending message size option and the Receiving message size option are under Global Settings on the Defaults tab of the Message Delivery Properties dialog box. Messages that are larger than the minimum size of either of the configured message sizes generate a non-delivery report (NDR) that is similar to the following:

    The following recipient(s) could not be reached:

    <var>user</var>@<var>company</var>.com on <var>month</var>/<var>day</var>/<var>year</var><var>hour</var>:<var>minutes</var> AM

    The message was not delivered because it is larger than the current system limit.
    Create a shorter message body or remove attachments and try sending it again.

    <<var>server_name</var>.<var>domain</var>.com #5.2.3> 

    Cause:

    This problem occurs because of the method that the Exchange message categorizer uses to enforce message size limits. The categorizer does not differentiate between incoming messages and outbound messages, and it applies both message size limits to all messages. For example, the categorizer uses the following logic when the categorizer determines whether to deliver a message. The message is delivered if the following conditions are true:

    • The size of the message that is being sent is less than the limit that is configured for the Sending message size option.

      -and-
    • The size of the message that is being sent is less than the limit that is configured for the Receiving message size option.

    Note The message size limit that is configured in the Sending message size option limits the size of messages that can be sent. The message size limit that is configured in the Receiving message size option limits the size of messages that can be received. These message size limits are applied to the whole organization. These sending and receiving message size limits also affect messages that are sent to and that are received from recipients who are not members of the Exchange organization. These global settings affect all Exchange recipients. If a recipient has configured their own personal sending or receiving message size limits, the global message size limits override the individual message size limits of the mailbox. 

    More Information:

    The Microsoft Exchange 2000 Server and Microsoft Exchange Server 2003 global message delivery options Sending message size and Receiving message size do not provide the functionality that you might expect based on their descriptions.
    • The sending message size is the maximum size of both inbound and outbound messages that can be submitted to the message categorizer.
    • The receiving message size is the maximum message size that the categorizer will process and deliver to the intended destination.
    These settings do not specifically control inbound and outbound message size delivery for an organization. Both of these limits work in tandem to control the size of messages that the categorizer can process. Because of this, the smallest message size that is specified for either of these options effectively controls the maximum message size that Exchange can process for both incoming and outgoing messages on any server. These settings do not work independently from each other.

    Note In Exchange 2000, the following default delivery options are listed on the Defaults tab:
    • Outgoing message size
    • Incoming message size
    However, in Exchange 2000 Server Service Pack 2 (SP2), Exchange 2000 Server Service Pack 3 (SP3), and Exchange 2003, the names of the delivery options have been changed to the following names:
    • Sending message size
    • Receiving message size

    For additional information about how to set size limits for messages, click the following article number to view the article in the Microsoft Knowledge Base:
    322679 Set size limits for messages  


    Wednesday, December 11, 2013 7:56 AM